Can't boot after update

I recently tried to update garuda, but my pc wont boot after doing so. Fortunatly garuda makes automatic snapshots and i've been able to access my computer using those snapshots.
This is the command i tried :

sudo pacman -Syu

and i can't copy paste the error because my pc didn't want to boot but basically, it goes like :

  • pc is on
  • grub is starting
  • i select "garuda linux" in grub (first choice of the list)
  • then it display :
__common_interrupt : 10.55 No irq handler for vector

and then that's it, it never go further. And it never display the SDDM. so i can't login and can't use my computer.

i've already tried to update it three times with the same errors.

All the best,

Hi there, welcome!
You should start from here.

My best guess would be to use a live USB, chroot, and enter update, which is more complete than the sudo pacman -Syu.
But it could be a lot of things. E.g. Nvidia drivers?
When you are in chroot you could provide also your inxi -Faz and maybe check the list of packages upgraded in the last update which made troubles...

Another thing you could try, since you probably just upgraded to kernel 5.15.2-zen1, which is very new so can have some regression issues at first, could be to install, after chrooting, the lts kernel
sudo pacman -S linux-lts linux-lts-headers
After that, you'll find it in the grub under advanced options submenu.

1 Like

You were asked for the output of inxi -Faz so people would know what your PC is.

Which packages are being updated? e.g. check /var/log/pacman.log.


Yes, sorry for the lack of information,
this is the output of inxi -Faz :

System:    Kernel: 5.14.14-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=cf751b6b-e9f9-4eb8-ba85-51705ef43dfa rw
[email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.1 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux
base: Arch Linux
Machine:   Type: Desktop Mobo: Micro-Star model: B450M-A PRO MAX (MS-7C52) v: 1.0 serial: <filter> BIOS: American Megatrends
v: 3.90 date: 11/27/2020
CPU:       Info: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 family: 17 (23) model-id: 71 (113)
stepping: 0 microcode: 8701021 cache: L2: 3 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 86398
Speed: 3607 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz): 1: 3607 2: 3617 3: 3622 4: 3624 5: 3418
6: 3605 7: 3599 8: 3601 9: 3599 10: 3678 11: 3625 12: 3708
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: NVIDIA GK208B [GeForce GT 730] vendor: Micro-Star MSI driver: nvidia v: 470.74
alternate: nouveau,nvidia_drm bus-ID: 29:00.0 chip-ID: 10de:1287 class-ID: 0300
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 101 s-size: 966x272mm (38.0x10.7") s-diag: 1004mm (39.5")
Monitor-1: VGA-0 res: 1920x1080 hz: 60 dpi: 85 size: 575x323mm (22.6x12.7") diag: 660mm (26")
Monitor-2: HDMI-0 res: 1920x1080 hz: 60 dpi: 102 size: 476x268mm (18.7x10.6") diag: 546mm (21.5")
OpenGL: renderer: NVIDIA GeForce GT 730/PCIe/SSE2 v: 4.6.0 NVIDIA 470.74 direct render: Yes
Audio:     Device-1: NVIDIA GK208 HDMI/DP Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus-ID: 29:00.1
chip-ID: 10de:0e0f class-ID: 0403
Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio vendor: Micro-Star MSI driver: snd_hda_intel
v: kernel bus-ID: 2b:00.4 chip-ID: 1022:1487 class-ID: 0403
Sound Server-1: ALSA v: k5.14.14-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.39 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI driver: r8169 v: kernel
port: f000 bus-ID: 25:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp37s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    Local Storage: total: 223.57 GiB used: 155.45 GiB (69.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400M8240G size: 223.57 GiB block-size: physical: 512 B
logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 62B3 scheme: MBR
Partition: ID-1: / raw-size: 223.57 GiB size: 223.57 GiB (100.00%) used: 155.45 GiB (69.5%) fs: btrfs dev: /dev/sda1
maj-min: 8:1
ID-2: /home raw-size: 223.57 GiB size: 223.57 GiB (100.00%) used: 155.45 GiB (69.5%) fs: btrfs dev: /dev/sda1
maj-min: 8:1
ID-3: /var/log raw-size: 223.57 GiB size: 223.57 GiB (100.00%) used: 155.45 GiB (69.5%) fs: btrfs dev: /dev/sda1
maj-min: 8:1
ID-4: /var/tmp raw-size: 223.57 GiB size: 223.57 GiB (100.00%) used: 155.45 GiB (69.5%) fs: btrfs dev: /dev/sda1
maj-min: 8:1
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.55 GiB used: 1020.2 MiB (6.4%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 53.1 C mobo: N/A gpu: nvidia temp: 44 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:      Processes: 369 Uptime: 10h 31m wakeups: 0 Memory: 15.55 GiB used: 7.54 GiB (48.5%) Init: systemd v: 249
tool: systemctl Compilers: gcc: 11.1.0 Packages: pacman: 1919 lib: 358 Shell: fish v: 3.3.1 default: Bash v: 5.1.8
running-in: konsole inxi: 3.3.08

and regarding the packages which are being updated, the /var/log/pacman is full of a lot of stuff (looks like 1800 packages are being updated)

1 Like

You should check in the pacman log, e.g.:
cat /var/log/pacman.log | grep 2021-11-12 | egrep -i 'installed|upgraded'
Have you tried anything suggested above?


This GPU needs the nvidia-470xx-dkms driver - Nvidia dropped support for Kepler cards from 495xx.


thanks, i'll try to install it

Do you know where is the garuda assistance ?
because on your link, i found this :

i had the same problem.
i manually uninstalled the nvidia-dkms and all the other listed packages with the 470 driver number (before updating to the 495) in the "pacman -Qs nvidia" list in terminal and after that i used garuda assistant to automatically choose the driver for me and it chose the 390 series for my kepler cards and then i updated and rebooted no problem.

In terminal


or in launcher.

ok thanks for your answer,
i don't want to bother you too much, but where can i find the driver i'm supposed to install ? (in the garuda assistant)

Please explore your system.
This goes a little bit beyond a normal support request. It's there. If you find it and learn how to use it by yourself this will be of much help for the future.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.