Can't boot after faulty motherboard/cpu swap

Hi there,

Because of a faulty motherboard, I had to send back both my mb and cpu for investigation.

So I have bought replacement parts, a new cpu (same model as before) and a new motherboard that is the same chipset but a different brand.

After installing the new hardware, I can't boot Garuda. The kernel seems to boot fine, but I always end up in emergency mode.

There, journalctl doesn't seem to show any major errors, and trying systemctl default doesn't work.

I tried fallback initramfs and recovery mode with the same result.

I'd like some leads as to what to investigate next?

Thanks a lot.

A motherboard fault (or just a power loss) may have caused data corruption on the hard disk (hopefully not but you never know). Does the live media boot, and can you mount the hard disk from there?
If there's no problem with the file system, it may be some subtle difference even if it's the same chipset, and maybe it needs rebuilding the initramfs.
But first make sure there's no issue with the filesystem to avoid further data loss.
I read that btrfs is quite tricky, avoid running fsck and btrfs check/rescue/restore on it or it may get worse, unless someone with some experience says it's fine to do so.
Personally, assuming you have backups (you have backups, right?), in such a case I'd throw the towel and reinstall. But that is me, and I don't know much.
Also, a garuda-inxi from the live media may turn useful, to compare with the previous motherboard.
I see from a previous post that you are using two drives with RAID0, I wouldn't rule out some problem with that, are the two recognized correctly as one logical volume?


Hi there,

The old motherboard had startup glitches but I still could run (and shut down) Garuda properly with it. So I'd say drive corruption seems unlikely to me. I will check if all drives are recognized properly tho.

About the initramfs, I don't know these things for sure but would I reach a functional tty if it was faulty?

Finally, I have no meaningful data on my system drive, they are safe on my NAS server. So yeah if I can't find an easy solution I'll just end up reinstalling.

1 Like

yeah you would. Personally experienced that with a vm in virtualbox where dracut couldn't build any initramfs and the system just couldn't boot into or start the xorg server at all. But the tty still was there.

So I checked and :

  • all my partitions are recognized and mounted properly.
  • tried running dracut to regenerate initramfs, with no difference.

Also noticed that NetworkManager won't start either.

you'll need to reinstall to recreate the hardware profile which uses the unique hardware identifiers built into each of the mobo's internal components.
as far as i am aware, there's no easy way to do this with linux if it exists at all.

the same thing happens with windows when it asks you to 'reactivate' after a component swap, the difference being that windows will create a new hardware profile and updates the kernel's hardware initialization sequence at startup.
i do not know of a way to duplicate this function in linux, but my knowledge base is limited.


Ok then, thanks for the explanation.

1 Like

I'm not exactly sure that answer is true, (unless something has drastically changed recently). I have swapped old installations on an SSD into very different hardware quite a few times running Arch & derivatives. Even extremely different hardware has always booted for me after transferring over an old installation. The only time it didn't boot was when I used an old install with nvidia drivers on a new system with ATI graphics. Even this isn't a showstopper, as the graphics drivers can be swapped before changing hardware or afterwards from a TTY.

I haven't actually done a swap in over a year, so perhaps things have changed. Or, maybe I have gold plated horseshoes up my arse, but it's always worked in the past for me. :grin:


Voted Best Hyperbole of May, 2023. :trophy:



Oddly, it did boot properly once while I was trying to reinstall and failed at selecting the installation media in my bios.

However, it just ended up failing again after a reboot.

Si yeah, something was probably corrupted somewhere.

In the end I ended up reinstalling.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.