Can't boot a pendrive to install Garuda Linux

Hello everyone, I’ve been doing some dual boots on my acer nitro 5 notebook for a long time but never stick with a linux distro for long. I decided to try Endevour OS but for some reason I can’t run games like Muse Dash, they crash every time so I decided to try a new distro: Garuda, which I choose for being a gaming focused distro and bc I loved the UI.
But for some reason I can’t install it anymore, I did it once, tested and loved the distro, many games (like Muse Dash or Dark Souls 1) that ran very poorly on Endevour were running perfectly on Garuda, but I had an issue regarding my windows dual boot, because of that I deleted my Garuda Partition, I managed to solve this other issue after some time, but now I cannot boot the Garuda installer anymore. I boot the pendrive, it opens the initial menu, i choose my language, keyboard and location and choose to boot it with nvidia drivers but I always get a black screen, my computer keeps running but nothing happens.
I already tried to burn the iso again, use different programs to burn it, reinstall the iso file, did a checksum and its everything ok, bought another pendrive, reinstalled my windows and formated my entire disk but nothing works, I keep getting a black screen…
I searched on some foruns looking for a similar issue but found nothing, I would love to know if anyone has an answer for that.

Sata controller is set to AHCI in the BIOS?


Search here, :slight_smile: use “black screen”
You did not write if you try the gaming version, but if, use the non gaming version and use garuda-gamer app later.

With nvidia, use first open driver and install later with dkms.

Or try the LTS version here.


yes, it is set to AHCI

by gaming version you mean the KDE Dr460nized? if so then yes, I tried to install it for most of the time, but I also tried the cinnamon version and got the same issue, would that be the non gaming version or is there more?
also I tried to open it with both open drivers and the nvidia ones, none worked.
Right now I am trying to download this LTS version but every time it reaches 2Gb it fails

Just test it, correct. Sorry about that.
Seems a Nextcloud problem.

Thanks for the hint.

Please ry

1 Like

Just tried this new iso and it worked! thanks a lot

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.