Cannot update files

It is showing problem with keys.

:: File /var/cache/pacman/pkg/libcap-ng-0.8.3-2-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] 
error: openssl: signature from "Pierre Schmitz <[email protected]>" is marginal trust
:: File /var/cache/pacman/pkg/openssl-3.1.2-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] 
error: libldap: signature from "Frederik Schwan <[email protected]>" is marginal trust
:: File /var/cache/pacman/pkg/libldap-2.6.6-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] 
error: util-linux-libs: signature from "Christian Hesse <[email protected]>" is marginal trust
:: File /var/cache/pacman/pkg/util-linux-libs-2.39.2-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] 
error: audit: signature from "David Runge <[email protected]>" is marginal trust
:: File /var/cache/pacman/pkg/audit-3.1.2-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
╭─edhe@Hebrews in ~ took 8ms
 ╰─λ garuda-inxi
System:
  Kernel: 6.1.26-1-lts arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
    root=UUID=6e279b6d-14f9-47ba-aadc-d7f05766d87d rw rootflags=subvol=@
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3 ibt=off
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
    v: 4.18.0 vt: 7 dm: LightDM v: 1.32.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop System: Dell product: OptiPlex 790 v: 01
    serial: <superuser required> Chassis: type: 6 serial: <superuser required>
  Mobo: Dell model: 0HY9JP v: A00 serial: <superuser required> UEFI: Dell
    v: A06 date: 07/25/2011
Battery:
  Device-1: hidpp_battery_0 model: Logitech K350 serial: <filter>
    charge: 70% (should be ignored) rechargeable: yes status: discharging
  Device-2: hidpp_battery_1 model: Logitech Wireless Mouse M510
    serial: <filter> charge: 55% (should be ignored) rechargeable: yes
    status: discharging
CPU:
  Info: model: Intel Core i5-2400 bits: 64 type: MCP arch: Sandy Bridge
    gen: core 2 level: v2 built: 2010-12 process: Intel 32nm family: 6
    model-id: 0x2A (42) stepping: 7 microcode: 0x2F
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
    desc: 1x6 MiB
  Speed (MHz): avg: 1600 min/max: 1600/3400 scaling: driver: intel_cpufreq
    governor: schedutil cores: 1: 1600 2: 1600 3: 1600 4: 1600 bogomips: 24755
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
Graphics:
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
    vendor: Dell driver: i915 v: kernel arch: Gen-6 code: Sandybridge
    process: Intel 32nm built: 2011 ports: active: VGA-1 empty: DP-1,HDMI-A-1
    bus-ID: 00:02.0 chip-ID: 8086:0102 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.8 compositor: xfwm v: 4.18.0 driver: X:
    loaded: modesetting alternate: fbdev,intel,vesa dri: crocus gpu: i915
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: VGA-1 model: Asus VX248 serial: <filter> built: 2017
    res: 1920x1080 hz: 60 dpi: 92 gamma: 1.2 size: 531x299mm (20.91x11.77")
    diag: 609mm (24") ratio: 16:9 modes: max: 1920x1080 min: 720x400
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo
    missing.
Audio:
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
    vendor: Dell driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:1c20 class-ID: 0403
  API: ALSA v: k6.1.26-1-lts status: kernel-api tools: N/A
  Server-1: PipeWire v: 0.3.70 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Intel 82579LM Gigabit Network vendor: Dell driver: e1000e
    v: kernel port: 3080 bus-ID: 00:19.0 chip-ID: 8086:1502 class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 3.64 TiB used: 5.77 GiB (0.2%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000LM007-1R8174
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 5400 serial: <filter> rev: EB01 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Western Digital
    model: WD20SDRW-11VUUS1 size: 1.82 TiB block-size: physical: 512 B
    logical: 512 B type: HDD rpm: 5400 serial: <filter> rev: 1018 scheme: GPT
Partition:
  ID-1: / raw-size: 1.82 TiB size: 1.82 TiB (100.00%) used: 5.77 GiB (0.3%)
    fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 576 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
    used: 5.77 GiB (0.3%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-4: /var/log raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
    used: 5.77 GiB (0.3%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-5: /var/tmp raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
    used: 5.77 GiB (0.3%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.5 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 39.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 228 Uptime: 28m wakeups: 6 Memory: 15.5 GiB
  used: 2.75 GiB (17.7%) Init: systemd v: 253 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 1215
  libs: 358 tools: paru Shell: Bash v: 5.1.16 running-in: xfce4-terminal
  inxi: 3.3.26
Garuda (2.6.16-1):
  System install date:     2023-09-17
  Last full system update: 2023-09-17
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       No/Undetected
  Failed units:            [email protected]

Hi there, welcome to the forum.
How are you updating?
Do you use

garuda-update 

?
If so, but you have the error, try

update remote keyring

If this doesn’t help, try

update remote fix
2 Likes
garuda-update
[sudo] password for edhe:        
:: Synchronizing package databases...
error: failed to synchronize all databases (unable to lock database)
:: Synchronizing package databases...
error: failed to synchronize all databases (unable to lock database)

--> Refreshing mirrorlists using rate-mirrors, please be patient..🍵

:: Synchronizing package databases...
error: failed to synchronize all databases (unable to lock database)

Failed to update mirrorlist
:: Synchronizing package databases...
error: failed to synchronize all databases (unable to lock database)
:: Synchronizing package databases...
error: failed to synchronize all databases (unable to lock database)
:: Synchronizing package databases...
error: failed to synchronize all databases (unable to lock database)
update remote keyring
[sudo] password for edhe:
gpg: /etc/pacman.d/gnupg/trustdb.gpg: trustdb created
gpg: no ultimately trusted keys found
gpg: starting migration from earlier GnuPG versions
gpg: porting secret keys from ‘/etc/pacman.d/gnupg/secring.gpg’ to gpg-agent
gpg: migration succeeded
==> Generating pacman master key. This may take some time.
gpg: Generating pacman keyring master key…
gpg: directory ‘/etc/pacman.d/gnupg/openpgp-revocs.d’ created
gpg: revocation certificate stored as ‘/etc/pacman.d/gnupg/openpgp-revocs.d/09151A86D13D45F140EE1483C910CB8A77122F00.rev’
gpg: Done
==> Updating trust database…
gpg: marginals needed: 3 completes needed: 1 trust model: pgp
gpg: depth: 0 valid: 1 signed: 0 trust: 0-, 0q, 0n, 0m, 0f, 1u
==> Appending keys from archlinux.gpg…
==> Appending keys from chaotic.gpg…
==> Locally signing trusted keys in keyring…
→ Locally signed 11 keys.
==> Importing owner trust values…
gpg: setting ownertrust to 4
gpg: setting ownertrust to 4
gpg: setting ownertrust to 4
gpg: inserting ownertrust of 4
gpg: setting ownertrust to 4
gpg: setting ownertrust to 4
gpg: inserting ownertrust of 4
gpg: setting ownertrust to 4
gpg: inserting ownertrust of 4
gpg: setting ownertrust to 4
gpg: setting ownertrust to 4
==> Disabling revoked keys in keyring…
→ Disabled 39 keys.
==> Updating trust database…
gpg: marginals needed: 3 completes needed: 1 trust model: pgp
gpg: depth: 0 valid: 1 signed: 9 trust: 0-, 0q, 0n, 0m, 0f, 1u
gpg: depth: 1 valid: 9 signed: 95 trust: 0-, 0q, 0n, 9m, 0f, 0u
gpg: depth: 2 valid: 73 signed: 27 trust: 73-, 0q, 0n, 0m, 0f, 0u
gpg: next trustdb check due at 2023-10-27
gpg: key A6234074498E9CEE: 4 duplicate signatures removed
gpg: key A6234074498E9CEE: 1 signature reordered
gpg: key A6234074498E9CEE: “Christian Hesse [[email protected]](mailto:[email protected])” 8 signatures cleaned
gpg: key FBA220DFC880C036: “Nico Jensch (Chaotic-AUR) [[email protected]](mailto:[email protected])” not changed
gpg: marginals needed: 3 completes needed: 1 trust model: pgp
gpg: depth: 0 valid: 1 signed: 9 trust: 0-, 0q, 0n, 0m, 0f, 1u
gpg: depth: 1 valid: 9 signed: 95 trust: 0-, 0q, 0n, 9m, 0f, 0u
gpg: depth: 2 valid: 73 signed: 27 trust: 73-, 0q, 0n, 0m, 0f, 0u
gpg: next trustdb check due at 2023-10-27
gpg: Total number processed: 2
gpg: unchanged: 1
gpg: signatures cleaned: 8
→ Locally signed 2 keys.
==> Updating trust database…
gpg: marginals needed: 3 completes needed: 1 trust model: pgp
gpg: depth: 0 valid: 1 signed: 10 trust: 0-, 0q, 0n, 0m, 0f, 1u
gpg: depth: 1 valid: 10 signed: 94 trust: 1-, 0q, 0n, 9m, 0f, 0u
gpg: depth: 2 valid: 72 signed: 27 trust: 72-, 0q, 0n, 0m, 0f, 0u
gpg: next trustdb check due at 2023-10-27
:: Synchronizing package databases…
error: failed to synchronize all databases (unable to lock database)
sudo rm /var/lib/pacman/db.lck

Then retry the commands.

6 Likes

Each of the three failed

That worked. Thank you.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.