Cannot resolve dependencies during update

Hello all along,

when I update my system, I receive the following message:

:: Complete system update is started ...
Dependencies are resolved ...
A search is made for conflicting packages ...
Error: Process could not be prepared (Cannot resolve) dependencies.
:: Installation of alsa-lib (1.2.5.1-3) violates dependency "alsa-lib=1.2.5", required by lib32-alsa-lib
:: Installation of libpcap (1.10.1-1) violates dependency "libpcap=1.10.0", needed by lib32-libpcap

Has anyone an idea, how I can resolve that issue?

Thx.

My specs in a nutshell:

OS: Garuda Linux x86_64 
Host: HP Pavilion Power Desktop 580-1xx 
Kernel: 5.12.10-zen1-1-zen 
Packages: 1661 (pacman) 
Shell: fish 3.2.2 
DE: Plasma 5.22.0 
WM: KWin 
WM Theme: Sweet-Dark 
Theme: Sweet [Plasma], Sweet-Dark [GTK2/3] 
Icons: BeautyLine [Plasma], BeautyLine [GTK2/3] 
Terminal: konsole 
Terminal Font: FantasqueSansMono Nerd Font Mono 12 
CPU: AMD Ryzen 5 1600 (12) @ 3.200GHz 
GPU: AMD ATI Radeon RX 470/480/570/570X/580/580X/590 
Memory: 2406MiB / 15951MiB 

inxi -Faz is here, if needed:
https://bin.garudalinux.org/?70e28662daaaba57#J6tnhAH62f3i3e5KPEYknko3d1t97rFUSvy7W4n1LVrq

Does the same happen when you update using upd?

How do I do that?

Type upd in terminal

╭─[email protected] in ~
╰─λ udp
fish: Unknown command: udp

its upd not udp

:astonished: Oh sorry.

no change, the same error. :frowning:

You should post the complete output, starting from where you typed what.

4 Likes

Wasn't this the one which was solved editing etc/pacman.conf and enabling the multilib repo?
Could you please check if it is enabled for you?
[multilib]
Include = /etc/pacman.d/mirrorlist

6 Likes

Thats the solution! Thank you sooo much! :star_struck:

You are absolutely right. Please excuse my carelessness. I will be more reliable in the future.

Thank you all for for the help.

Case closed.

Cheers.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.