Cannot Reinstall Grub Bootloader

System:
Kernel: 5.17.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=2ecb5eb0-9844-4dcc-9b71-863c603513c2 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Convertible System: HP
product: HP Pavilion x360 Convertible 14-cd0xxx v: Type1ProductConfigId
serial: <superuser required> Chassis: type: 31
serial: <superuser required>
Mobo: HP model: 8487 v: 72.23 serial: <superuser required> UEFI: Insyde
v: F.34 date: 04/29/2019
Battery:
ID-1: BAT0 charge: 14.2 Wh (78.9%) condition: 18.0/18.0 Wh (100.0%)
volts: 10.3 min: 11.6 model: 333-42-5D-A TF03041XL type: Li-ion
serial: <filter> status: discharging
Device-1: hid-0018:04F3:262C.0001-battery model: ELAN2514:00 04F3:262C
serial: N/A charge: N/A status: N/A
CPU:
Info: model: Intel Core i7-8550U bits: 64 type: MT MCP arch: Coffee Lake
family: 6 model-id: 0x8E (142) stepping: 0xA (10) microcode: 0xEC
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 900 min/max: 400/4000 scaling: driver: intel_pstate
governor: powersave cores: 1: 900 2: 900 3: 900 4: 900 5: 900 6: 900 7: 900
8: 900 bogomips: 31999
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX unsupported
Type: l1tf mitigation: PTE Inversion
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel UHD Graphics 620 vendor: Hewlett-Packard driver: i915
v: kernel ports: active: eDP-1 empty: HDMI-A-1 bus-ID: 0000:00:02.0
chip-ID: 8086:5917 class-ID: 0300
Device-2: NVIDIA GM108M [GeForce MX130] vendor: Hewlett-Packard
driver: nvidia v: 510.54 alternate: nouveau,nvidia_drm bus-ID: 0000:01:00.0
chip-ID: 10de:174d class-ID: 0302
Device-3: Chicony HP Wide Vision HD Camera type: USB driver: uvcvideo
bus-ID: 1-4:2 chip-ID: 04f2:b627 class-ID: 0e02
Display: x11 server: X.Org v: 1.21.1.3 compositor: kwin_x11 driver: X:
loaded: intel,nvidia unloaded: modesetting,nouveau alternate: fbdev,nv,vesa
gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 mapped: eDP1 model: AU Optronics 0x413d built: 2016
res: 1920x1080 hz: 60 dpi: 157 gamma: 1.2 size: 310x170mm (12.2x6.69")
diag: 354mm (13.9") ratio: 16:9 modes: 1920x1080
OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2)
v: 4.6 Mesa 22.0.0 direct render: Yes
Audio:
Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 0000:00:1f.3
chip-ID: 8086:9d71 class-ID: 0403
Sound Server-1: ALSA v: k5.17.1-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.49 running: yes
Network:
Device-1: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter
vendor: Hewlett-Packard driver: rtw_8822be v: N/A modules: rtw88_8822be
port: 3000 bus-ID: 0000:02:00.0 chip-ID: 10ec:b822 class-ID: 0280
IF: wlo1 state: up mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
Bluetooth:
Device-1: Realtek Bluetooth 4.2 Adapter type: USB driver: btusb v: 0.8
bus-ID: 1-5:3 chip-ID: 0bda:b00b class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
RAID:
Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode]
driver: intel_nvme_remap v: N/A port: 5060 bus-ID: 0000:00:17.0
chip-ID: 8086:282a rev: N/A class-ID: 0104
Drives:
Local Storage: total: 465.76 GiB used: 37.02 GiB (7.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: WDS500G2B0C-00PXH0 size: 465.76 GiB block-size: physical: 512 B
logical: 512 B type: SSD serial: <filter> rev: 211210WD temp: 39.9 C
scheme: GPT
Partition:
ID-1: / raw-size: 100 GiB size: 100 GiB (100.00%) used: 36.96 GiB (37.0%)
fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
used: 63.1 MiB (24.7%) fs: vfat dev: /dev/nvme0n1p2 maj-min: 259:2
ID-3: /home raw-size: 100 GiB size: 100 GiB (100.00%)
used: 36.96 GiB (37.0%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-4: /var/log raw-size: 100 GiB size: 100 GiB (100.00%)
used: 36.96 GiB (37.0%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-5: /var/tmp raw-size: 100 GiB size: 100 GiB (100.00%)
used: 36.96 GiB (37.0%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.37 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 60.0 C pch: 50.0 C mobo: 49.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 275 Uptime: 6m wakeups: 3 Memory: 15.37 GiB
used: 2.97 GiB (19.3%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 clang: 13.0.1 Packages: 1714 pacman: 1709 lib: 368 flatpak: 5
Shell: fish v: 3.3.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.14
Garuda (2.5.6-2):
System install date:     2022-04-01
Last full system update: 2022-04-01 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:            systemd-networkd-wait-online.service

I tried Garuda boot repair but it says

Installing for i386-pc platform.
grub-install: warning: File system `fat' doesn't support embedding.
grub-install: error: filesystem `btrfs' doesn't support blocklists.
1 Like

Could you plz post the command line you issued right above this:

You say you tried to reinstall GRUB but you don't mention what command you issued.

I see GRUB is trying to install i386 platform (BIOS LEGACY support) but your inxi says your partition table is GPT, therefore you should install x64efi GRUB, not i386.

My other question would be "Are you dual-booting Windows?"

2 Likes

Yes i actually dual booted it but it was running fine before. I actually was doing a separate garuda install on a external SSD for a separate use case but i had not paid attention to the install option and it messed my efi on my device. After removing the external i booted into my normal install and it keeps me throwing into windows. I went to bios to check and i now see that on the UEFI option for OS manager Garuda is gone. I went to Windows to check efi but now i only see a grubx64.efi present instead of the Garuda folder inside the EFI folder. I restarted to boot from efi file and i can actually use grub to come into linux and it works but my menu is gone from UEFI OS boot manager so what should i do?

Ok hang on I have stuff for this I've being doing it at least 25 times in the last 2 month. Let me check my notes for the exact steps... I'll be back, he said. :smiley:

Ok so the bellow steps will reinstall GRUB and recreate the OS boot option in UEFI.

A few caveats though:

  • I am NEVER tried while dual-booting Windows. I've read it should work but I cannot confirm this 100%.
  • You might need to adjust a few parms in the steps to match your configuration, I can help nailing them down but I'm not familiar reading INXI and am not fully confident I will have it right.

To reinstall GRUB UEFI and re-instate the Garuda Boot Option in boot menu:

Boot into the Garuda Live ISO and open a Terminal to issue:

sudo mount /dev/nvme0n1p5 /mnt
sudo mount --rbind /dev /mnt/@/dev
sudo mount --rbind /proc /mnt/@/proc
sudo mount --rbind /sys /mnt/@/sys
sudo chroot /mnt/@
mount /dev/nvme0n1p5 /
 
	mount /dev/nvme0n1p2 /boot/efi (X = EFI partition)
	grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id="Garuda"
	umount /boot/efi
	umount /
exit
exit

What these commands do is mount your Garuda root in order to bind DEV-SYS-PROC which allow reinstalling GRUB. It then mounts your EFI partition which allows GRUB to redirect it's installation files and Boot Menu configuration into.
It also specifies the LABEL you want to see in UEFI Menu, frankly you can put whatever you want there (bootloader-id).

It also tags your Garuda as the FIRST boot option to boot into. This is by design when installing GRUB UEFI.

Now I need help identifying your actual Garuda Root disk partition number and your EFI partition number, I will re-read your INXI in case I find something obvious to me....

Ok, so your disk is /dev/nvme0n1
Your EFI partition is /dev/nvme0n1p2
Where is your Garuda installed? /dev/nvme0n1p1?

Garuda Linux root is on /dev/nvme0n1p5. So after making changes the commands should be?

Damn I was way off... lolll

Let me edit my above steps with this and see how it looks.

I am actually in my Garuda Install so should actually use the live iso or just doing it in here would be fine?

I never trusted doing it in the same OS I was booted into. That doesn't mean it won't work, it just mean I never wanted to try it in case it would break, so I cannot answer that question. :frowning: My understanding is when the EFI partition is mounted it's sort of hidden so I never wanted to play with that.

Nvm i remember even on extending partition live iso is required. So revised commands?

Yes I have edited my post above and explained what those commands do, so you can assess the "concept" before actually jumping into it.

If you are booted into Garuda, you really shouldn't be having a problem here. Try this:

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=garuda

3 Likes

Oh, my bad i didn't check that your re edited your comment, please wait a moment i will run those real quick.

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=garuda
This first?

Try TNE's first, yes plz.
He's never wrong.

[email protected] in ~
λ grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=garuda
Installing for x86_64-efi platform.
grub-install: warning: disk does not exist, so falling back to partition device /dev/nvme0n1p2.
grub-install: warning: disk does not exist, so falling back to partition device /dev/nvme0n1p2.
grub-install: warning: disk does not exist, so falling back to partition device /dev/nvme0n1p2.
grub-install: error: disk `hostdisk//dev/nvme0n1p2' not found.

What does sudo fdisk -l return? (that's an L, not an i)

[sudo] password for partha:
Disk /dev/nvme0n1: 465.76 GiB, 500107862016 bytes, 976773168 sectors
Disk model: WDC WDS500G2B0C-00PXH0
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 509FE31C-5384-4BBC-B484-6A4FD6E7CD21

Device             Start       End   Sectors   Size Type
/dev/nvme0n1p1      2048 732460200 732458153 349.3G Microsoft basic data
/dev/nvme0n1p2 942177449 942709928    532480   260M EFI System
/dev/nvme0n1p3 944189440 975643514  31454075    15G Microsoft basic data
/dev/nvme0n1p4 975644672 976769023   1124352   549M Windows recovery environment
/dev/nvme0n1p5 732461056 942176255 209715200   100G Linux filesystem

Partition table entries are not in disk order.


Disk /dev/zram0: 15.37 GiB, 16506683392 bytes, 4029952 sectors
Units: sectors of 1 * 4096 = 4096 bytes
Sector size (logical/physical): 4096 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes


Disk /dev/loop0: 446.95 MiB, 468660224 bytes, 915352 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

How the h.... is your EFI actually mounted?
Maybe findmnt -l ? Again an L.