Cannot mount AppImage, please check your fuse setup

Hello.

Guys today I'd like to touch problem with AppImage. I'm not sure if it's right section (so please move it if I've marked it inccorrectly).

Let's start with template:

╰─λ garuda-inxi
System:
Kernel: 5.17.5-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=20aec52d-3c03-4c92-9591-0f03b67c1af2 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.3 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: Gigabyte model: P55-US3L serial: <superuser required>
BIOS: Award v: FE date: 03/05/2010
CPU:
Info: model: Intel Core i5 750 bits: 64 type: MCP arch: Nehalem family: 6
model-id: 0x1E (30) stepping: 5 microcode: 0xA
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 8 MiB
desc: 1x8 MiB
Speed (MHz): avg: 2798 min/max: 1197/2661 boost: enabled scaling:
driver: acpi-cpufreq governor: performance cores: 1: 2798 2: 2798 3: 2798
4: 2798 bogomips: 21317
Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
Type: mds
status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT disabled
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Redwood XT [Radeon HD 5670/5690/5730] vendor: Gigabyte
driver: radeon v: kernel alternate: amdgpu pcie: gen: 2 speed: 5 GT/s
lanes: 16 ports: active: HDMI-A-1 empty: DVI-I-1,VGA-1 bus-ID: 01:00.0
chip-ID: 1002:68d8 class-ID: 0300
Device-2: Logitech Webcam C930e type: USB driver: snd-usb-audio,uvcvideo
bus-ID: 1-1.2:3 chip-ID: 046d:0843 class-ID: 0102 serial: <filter>
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
compositor: kwin_x11 driver: X: loaded: radeon unloaded: modesetting
alternate: fbdev,vesa gpu: radeon display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: HDMI-A-1 mapped: HDMI-0 model: AOC 2757M serial: <filter>
built: 2012 res: 1920x1080 hz: 60 dpi: 82 gamma: 1.2
size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
OpenGL:
renderer: AMD REDWOOD (DRM 2.50.0 / 5.17.5-zen1-1-zen LLVM 13.0.1)
v: 3.3 Mesa 22.0.3 compat-v: 3.1 direct render: Yes
Audio:
Device-1: Intel 5 Series/3400 Series High Definition Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:3b56
class-ID: 0403
Device-2: AMD Redwood HDMI Audio [Radeon HD 5000 Series] vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 1002:aa60 class-ID: 0403
Device-3: Creative Labs CA0106/CA0111 [SB Live!/Audigy/X-Fi Series]
driver: snd_ca0106 v: kernel bus-ID: 06:04.0 chip-ID: 1102:0007
class-ID: 0401
Device-4: Philips s SAA7131/SAA7133/SAA7135 Video Broadcast Decoder
vendor: Avermedia DVB-T Super 007 driver: saa7134 v: 0, 2, 17
bus-ID: 06:05.0 chip-ID: 1131:7133 class-ID: 0480
Device-5: Logitech Webcam C930e type: USB driver: snd-usb-audio,uvcvideo
bus-ID: 1-1.2:3 chip-ID: 046d:0843 class-ID: 0102 serial: <filter>
Sound Server-1: ALSA v: k5.17.5-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.21 running: no
Sound Server-3: PulseAudio v: 15.0 running: yes
Sound Server-4: PipeWire v: 0.3.51 running: yes
Network:
Device-1: Realtek RTL8192EE PCIe Wireless Network Adapter driver: rtl8192ee
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: ee00 bus-ID: 02:00.0
chip-ID: 10ec:818b class-ID: 0280
IF: wlp2s0 state: down mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: ce00 bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp5s0 state: up speed: 100 Mbps duplex: full mac: <filter>
IF-ID-1: docker0 state: down mac: <filter>
Drives:
Local Storage: total: 447.13 GiB used: 175.64 GiB (39.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: GOODRAM model: N/A size: 447.13 GiB
block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s type: SSD
serial: <filter> rev: 01.7 scheme: MBR
Partition:
ID-1: / raw-size: 195.31 GiB size: 195.31 GiB (100.00%)
used: 73.72 GiB (37.7%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 11.68 GiB used: 2.66 GiB (22.8%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 59.0 C mobo: N/A gpu: radeon temp: 57.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 327 Uptime: 11h 2m wakeups: 0 Memory: 11.68 GiB
used: 9.6 GiB (82.2%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 clang: 13.0.1 Packages: apt: 0 pacman: 1787 lib: 391
Shell: fish v: 3.4.1 running-in: konsole inxi: 3.3.15
Garuda (2.6.2-1):
System install date:     2021-05-29
Last full system update: 2022-05-07
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       <superuser required>
Snapshots:               Timeshift
Failed units:            bluetooth-autoconnect.service

So I have read about AppImage files. I wasn't super happy to use it but I don't have other option.
In theory we download .AppImage files open it and it should run. In reality (at least my case) it ask for integration , which fails finally and that's why it ask one more time for extract all files and run it directly. So sure, what elese do I have..? After that again it can't handle and return following error:

Cannot mount AppImage, please check your fuse setup.
You might still be able to extract the contents of this AppImage
if you run it with the --appimage-extract option.
See FUSE · AppImage/AppImageKit Wiki · GitHub
for more information

In that part I have to admit that I have my temporar solution like this:

  1. downoload appimage file
    a) run with
./Ultimaker_Cura-4.13.1.AppImage --appimage-extract-and-run

Yeap, here is about Cura (slicer soft for 3d printing which my is my best choice). And please don't advice here me to install it from pacman etc. while pacman version is outdated and desn't cover a lots of things. Besides Ulimaker suggest their official Appimage iso. So that's bying said let's follow with that path.

That way run app behave perfectly fine and work great! No doubs about it.

b) next more convinet way is option where we can firstlu extract it :

./cura.AppImage--appimage-extract

This way I get :
image

c) the best option is just create a shutrcut link for run that particular app. So we have to edit

Desktop content in my case is :

[Desktop Entry]
Name=Cura
Name[de]=Cura
GenericName=3D Printing Software
GenericName[de]=3D-Druck-Software
Comment=Cura converts 3D models into paths for a 3D printer. It prepares your print for maximum accuracy, minimum printing time and good reliability with many extra features that make your print come out great.
Exec=MESA_GL_VERSION_OVERRIDE=4.5 MESA_GLSL_VERSION_OVERRIDE=450 /home/zawier/CURA/squashfs-root/./AppRun
Icon=cura-icon
Terminal=false
Type=Application
MimeType=model/stl;application/vnd.ms-3mfdocument;application/prs.wavefront-obj;image/bmp;image/gif;image/jpeg;image/png;text/x-gcode;application/x-amf;application/x-ply;application/x-ctm;model/vnd.collada+xml;model/gltf-binary;model/gltf+json;model/vnd.collada+xml+zip;
Categories=Graphics;
Keywords=3D;Printing;
X-AppImage-Version=4.13.1

And setting up additional parameters :

I'm able to create pernament icon enywhere and it also works great.
That's my current solution.

But question is why standard AppImage files are not able tu run properly itself? Probably you suspect that's broken Cura version or something. Not at all. I have the same problem with that type of files always. No matter what app I'd like to fire up.

Can it be fixed somehow, that system knows from begining what it should to do and how?

I haven't found answer for that problem . That's why I've posted here.
What is your experience with that extention? Have you also noticed that behavior?

Best regards

Oh yeap, I've seen that post and aslo add

chmod +x /path/to/file
╭─[email protected] in ~ took 2s
╰─λ history | grep chmod
2022-02-22 01:29:10 chmod +x Cura_3.14.1.1.desktop
2022-02-22 01:26:49 chmod +x cura.desktop

With the same result. So It desn't answer my question. Even if adding mod before running.

Do you have fuse2 and fuse3 installed?

Yes, I do:
fuse2 - version 2.9.9-4
fuse3 - version 3.10.5-1

Do you have libappimage installed? Does Garuda Downloader work?

╰─λ pacman -Q libappimage
libappimage 1.0.4-1

I haven't installed Garuda Downoloader until now. Quick check and it look to work fine:

And you do have AppimageLauncher installed, right? I don't do any Appimages till I have that installed.

Of couse I do.

So the issue is with the AppImage you downloaded in that case, since Garuda's seems to work fine?

I'm affraid no, because iso was downloaded but once I've tried lunch flasher (real appimage) then
image

And one more time :

Oh you use an AppImage launcher? Ewwwww.

sudo pacman -R appimagelauncher
reboot (necessary!)
And then try again.

Appimagelauncher most likely isn't the issue. I get that message with Zoho Mail but it launches and runs without issue, and my other programs installed using Appimagelauncher just work without any error message.

Didn't help. The same case. Besides before I was able to run any appimages on my way. Currently I'm not. So that's why I've installed it one more time.

1 Like

Did you do a reinstall or any major changes between AppImages working and not.

No issues with them on myside so its weird. I know you have fuse2 and fuse3 installed. I know it doesnt work with fuse3 so wondering if your system isnt picking up fuse2 for some reason.

https://docs.appimage.org/user-guide/troubleshooting/fuse.html

Well, surprisingly no. I had that issue from begining, since first time tried run AppImage file. But then I was able to find workaround (which still works for me, but I'm just tired to always go that way. I'd like to work it as designed, straight out of the box).

Regarding a link, been there before. Only one usefull info is :

sudo chmod u+s `which fusermount`

Which unfortunatelly hasn't fixed a problem.

I've been researching your issue and everything points to an issue with FUSE. Usually if a person needs to extra an appimage its because FUSE isn't working.

I suspect that FUSE might be installed but isn't loaded into the kernel as a module.

If you do a lsmod in the terminal does it show that fuse has been loaded?

Yep, here it is:

╭─[email protected] in ~ as 🧙 took 6s
╰─λ lsmod
Module                  Size  Used by
ext4                 1028096  1
crc16                  16384  1 ext4
mbcache                16384  1 ext4
jbd2                  192512  1 ext4
snd_seq_dummy          16384  0
snd_seq_midi           20480  0
snd_hrtimer            16384  1
snd_seq_midi_event     16384  1 snd_seq_midi
snd_seq                94208  9 snd_seq_midi,snd_seq_midi_event,snd_seq_dummy
xt_conntrack           16384  1
xt_MASQUERADE          20480  1
nf_conntrack_netlink    61440  0
nfnetlink              20480  2 nf_conntrack_netlink
xt_addrtype            16384  2
iptable_filter         16384  1
iptable_nat            16384  1
nf_nat                 57344  2 iptable_nat,xt_MASQUERADE
nf_conntrack          184320  4 xt_conntrack,nf_nat,nf_conntrack_netlink,xt_MASQUERADE
nf_defrag_ipv6         24576  1 nf_conntrack
nf_defrag_ipv4         16384  1 nf_conntrack
br_netfilter           32768  0
bridge                376832  1 br_netfilter
stp                    16384  1 bridge
llc                    16384  2 bridge,stp
saa7134_alsa           28672  2
qrtr                   49152  4
tda1004x               40960  1
saa7134_dvb            65536  0
videobuf2_dvb          16384  1 saa7134_dvb
dvb_core              200704  1 videobuf2_dvb
iTCO_wdt               16384  0
intel_powerclamp       20480  0
intel_pmc_bxt          16384  1 iTCO_wdt
ppdev                  24576  0
iTCO_vendor_support    16384  1 iTCO_wdt
tda827x                32768  2
coretemp               20480  0
tda8290                32768  1
tuner                  36864  1
kvm_intel             393216  0
rtl8192ee             147456  0
snd_hda_codec_realtek   176128  1
btcoexist             233472  1 rtl8192ee
snd_hda_codec_generic   110592  1 snd_hda_codec_realtek
ledtrig_audio          16384  1 snd_hda_codec_generic
kvm                  1171456  1 kvm_intel
snd_hda_codec_hdmi     90112  1
rtl_pci                36864  1 rtl8192ee
irqbypass              16384  1 kvm
saa7134               237568  2 saa7134_dvb,saa7134_alsa
snd_usb_audio         393216  2
snd_ca0106             65536  2
joydev                 28672  0
rtlwifi               143360  3 rtl_pci,btcoexist,rtl8192ee
uvcvideo              155648  0
tveeprom               28672  1 saa7134
snd_hda_intel          61440  6
intel_cstate           20480  0
videobuf2_vmalloc      20480  2 uvcvideo,dvb_core
videobuf2_dma_sg       20480  2 saa7134_dvb,saa7134
snd_intel_dspcfg       36864  1 snd_hda_intel
snd_ac97_codec        192512  1 snd_ca0106
intel_uncore          217088  0
snd_usbmidi_lib        49152  1 snd_usb_audio
snd_intel_sdw_acpi     20480  1 snd_intel_dspcfg
videobuf2_memops       20480  2 videobuf2_vmalloc,videobuf2_dma_sg
snd_rawmidi            49152  3 snd_seq_midi,snd_usbmidi_lib,snd_ca0106
mac80211             1290240  3 rtl_pci,rtlwifi,rtl8192ee
videobuf2_v4l2         40960  3 saa7134_dvb,saa7134,uvcvideo
snd_hda_codec         188416  4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek
ac97_bus               16384  1 snd_ac97_codec
snd_seq_device         16384  3 snd_seq,snd_seq_midi,snd_rawmidi
mousedev               24576  0
r8169                 126976  0
videobuf2_common       90112  8 saa7134,videobuf2_vmalloc,videobuf2_v4l2,uvcvideo,dvb_core,videobuf2_dma_sg,videobuf2_dvb,videobuf2_memops
snd_hda_core          122880  5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek
realtek                36864  1
snd_hwdep              16384  2 snd_usb_audio,snd_hda_codec
videodev              311296  5 saa7134,videobuf2_v4l2,uvcvideo,videobuf2_common,tuner
mdio_devres            16384  1 r8169
snd_pcm               176128  8 snd_hda_codec_hdmi,snd_hda_intel,snd_usb_audio,snd_hda_codec,snd_ac97_codec,snd_ca0106,saa7134_alsa,snd_hda_core
snd_timer              49152  3 snd_seq,snd_hrtimer,snd_pcm
libarc4                16384  1 mac80211
i2c_i801               45056  0
libphy                176128  3 r8169,mdio_devres,realtek
snd                   131072  42 snd_hda_codec_generic,snd_seq,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_usb_audio,snd_usbmidi_lib,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_ac97_codec,snd_ca0106,saa7134_alsa,snd_pcm,snd_rawmidi
mc                     73728  8 videodev,saa7134,snd_usb_audio,videobuf2_v4l2,uvcvideo,dvb_core,videobuf2_common,tuner
cfg80211             1093632  2 rtlwifi,mac80211
lpc_ich                28672  0
parport_pc             69632  0
rfkill                 32768  5 rtlwifi,cfg80211
mac_hid                16384  0
soundcore              16384  1 snd
i2c_smbus              20480  1 i2c_i801
i7core_edac            45056  0
acpi_cpufreq           32768  0
parport                77824  2 parport_pc,ppdev
squashfs               77824  21
loop                   32768  42
vboxnetflt             32768  0
vboxnetadp             28672  0
vboxdrv               569344  2 vboxnetadp,vboxnetflt
uinput                 24576  0
ipmi_devintf           20480  0
ipmi_msghandler        86016  1 ipmi_devintf
sg                     49152  0
fuse                  184320  1
crypto_user            20480  0
zram                   40960  2
bpf_preload            16384  0
ip_tables              32768  2 iptable_filter,iptable_nat
x_tables               61440  6 xt_conntrack,iptable_filter,xt_addrtype,ip_tables,iptable_nat,xt_MASQUERADE
btrfs                1785856  1
blake2b_generic        20480  0
libcrc32c              16384  3 nf_conntrack,nf_nat,btrfs
crc32c_generic         16384  0
ata_generic            16384  0
xor                    24576  1 btrfs
pata_acpi              16384  0
raid6_pq              122880  1 btrfs
crc32c_intel           24576  4
xhci_pci               24576  0
xhci_pci_renesas       24576  1 xhci_pci
pata_jmicron           16384  0
nouveau              2850816  0
mxm_wmi                16384  1 nouveau
wmi                    40960  2 mxm_wmi,nouveau
i915                 3579904  0
video                  57344  2 i915,nouveau
intel_agp              24576  0
intel_gtt              28672  2 intel_agp,i915
usbhid                 77824  0
amdgpu               9256960  0
gpu_sched              53248  1 amdgpu
radeon               1957888  62
drm_ttm_helper         16384  3 amdgpu,radeon,nouveau
ttm                    90112  5 amdgpu,radeon,drm_ttm_helper,i915,nouveau

Please try running

sudo modprobe fuse

Then see if your app opens

Also are you trying to run the images from your home folder?

Done it long time ago, but checked it one more time - the same error, sorry.

It doesn't matter which location it is run from. Current tried from /home/zawier/Applications/ but also /home doesn't work.