Cannot install video-hybrid-intel-nvidia-dkms-prime-render-offloading

Hello, thanks for your help.
I am a new Garuda user coming from Manjaro, I'm trying to install "video-hybrid-intel-nvidia-dkms-prime-render-offloading" from the Garuda hardware manager on Garuda KDE Dr460nized.
After clicking on install inside Garuda Hardware Manager I get the following log:

Waiting for user input...
Starting
Installing video-hybrid-intel-nvidia-dkms-prime-render-offloading...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/hybrid-intel-nvidia-dkms-prime-render-offloading/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
downloading chaotic-aur.db...
warning: nvidia-utils-455.45.01-1 is up to date -- skipping
warning: nvidia-prime-1.0-4 is up to date -- skipping
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
Packages (13) archlinux-appstream-data-20201128-1 dkms-2.8.3-1 gc-8.0.4-4 guile-2.2.6-2 libxnvctrl-455.45.01-1 make-4.3-3 patch-2.7.6-8 texinfo-6.7-3 lib32-nvidia-utils-455.45.01-1 lib32-opencl-nvidia-455.45.01-1 nvidia-dkms-455.45.01-1 nvidia-settings-455.45.01-1 opencl-nvidia-455.45.01-1
Total Installed Size: 406.37 MiB
Net Upgrade Size: 387.45 MiB
:: Proceed with installation? [Y/n]
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Running pre-transaction hooks...
(1/1) Creating Timeshift snapshot before upgrade...
E: Commands listed below are not available on this system:

  • rsync
  • /sbin/blkid
  • df
  • mount
  • umount
  • fuser
  • crontab
  • cp
  • rm
  • touch
  • ln
  • sync
    Please install required packages and try running TimeShift again
    ** (process:8910): CRITICAL **: 18:32:10.231: app_lock_remove: assertion 'self != NULL' failed
    Unable to run timeshift-autosnap! Please close Timeshift and try again. Script will now exit...
    error: command failed to execute correctly
    error: failed to commit transaction (failed to run transaction hooks)
    Errors occurred, no packages were upgraded.
    Error: pacman failed!
    Error: script failed!
    Done ...

Keep in mind this is a fresh install, maybe this is a bug? Is there any fix to this?

Hello and welcome :wave:
Please try installing the packages

archlinux-appstream-data-20201128-1 dkms-2.8.3-1 gc-8.0.4-4 guile-2.2.6-2 libxnvctrl-455.45.01-1 make-4.3-3 patch-2.7.6-8 texinfo-6.7-3 lib32-nvidia-utils-455.45.01-1 lib32-opencl-nvidia-455.45.01-1 nvidia-dkms-455.45.01-1 nvidia-settings-455.45.01-1 opencl-nvidia

with sudo pacman -S archlinux-appstream-data dkms etc.. to see if its caused by the hardwaremanager

2 Likes

Hey, I ran pacman on all the requested packages, most were installed so they were reinstalled by pacman.
The nvidia packages were the only ones not on my system, so pacman downloaded and installed them.
It seems a problem with mhwd, I also tried installing the option "video-optimus-manager" from mhwd and got the same output, seems a problem with Timeshift according to the error output

Try creating a snapshot directly from Timeshift, to see if it acts the same.
I think that any package install/update triggers a hooked timeshift snapshot. Don't you get similar errors during any pacman updates/installations?

2 Likes

I was having similar issues I had to install the hybrid driver and then reinstall the video-optimus-manager. Then all was working for me.

1 Like