Cannot enable Bluetooth

Hi guys, I have a dual-boot setup with Windows (but it is an AtlasOS modification which disabled BT for Windows (I only use that for gaming), but I don’t think it will affect my Garuda installation since those settings can’t directly access BIOS hardware such as BT devices) and i can’t enable Bluetooth on my garuda installation:

0: asus-wlan: Wireless LAN
Soft blocked: no
Hard blocked: no
1: asus-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no
2: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
3: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no


Waiting to connect to bluetoothd...[bluetooth]# Agent registered
[bluetooth]# list
[bluetooth]# devices
No default controller available


sudo garuda-inxi

Kernel: 6.9.1-zen1-2-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=110bfeb9-8982-41d5-8228-1e349f3e6005 rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.0.4 tk: Qt v: N/A wm: kwin_wayland with: krunner
dm: SDDM Distro: Garuda base: Arch Linux
Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop M1603QA_M1603QA
v: 1.0 serial: <filter>
Mobo: ASUSTeK model: M1603QA v: 1.0 serial: <filter>
uuid: 16acb14b-55ba-634d-8173-e24aba7e118b UEFI: American Megatrends LLC.
v: M1603QA.306 date: 11/21/2022
ID-1: BAT0 charge: 41.9 Wh (85.9%) condition: 48.8/50.0 Wh (97.5%)
power: 18.9 W volts: 11.9 min: 11.9 model: ASUSTeK ASUS Battery type: Li-ion
serial: N/A status: charging cycles: 37
Info: model: AMD Ryzen 5 5600H with Radeon Graphics socket: FP6 bits: 64
type: MT MCP arch: Zen 3 gen: 4 level: v3 note: check built: 2021-22
process: TSMC n7 (7nm) family: 0x19 (25) model-id: 0x50 (80) stepping: 0
microcode: 0xA50000D
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 927 high: 2652 min/max: 400/4280 base/boost: 3300/4250
scaling: driver: amd-pstate-epp governor: powersave volts: 1.2 V
ext-clock: 100 MHz cores: 1: 400 2: 400 3: 2286 4: 400 5: 400 6: 400
7: 400 8: 400 9: 400 10: 400 11: 2652 12: 2597 bogomips: 79053
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Device-1: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
vendor: ASUSTeK driver: amdgpu v: kernel arch: GCN-5 code: Vega
process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s ports: active: eDP-1 empty: HDMI-A-1
bus-ID: 03:00.0 chip-ID: 1002:1638 class-ID: 0300 temp: 34.0 C
Device-2: IMC Networks USB2.0 HD UVC WebCam driver: uvcvideo type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-3:3 chip-ID: 13d3:5463
class-ID: fe01 serial: <filter>
Display: server: X.Org v: 24.1 with: Xwayland v: 24.1.0
compositor: kwin_wayland driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :1 screens: 1
Screen-1: 0 s-res: 1920x1200 s-dpi: 96 s-size: 508x318mm (20.00x12.52")
s-diag: 599mm (23.6")
Monitor-1: eDP-1 model: AU Optronics 0x459d built: 2022 res: 1920x1200
hz: 60 dpi: 143 gamma: 1.2 size: 340x220mm (13.39x8.66") diag: 406mm (16")
ratio: 16:10 modes: max: 1920x1200 min: 640x480
API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
device: 1 drv: swrast surfaceless: drv: radeonsi x11: drv: radeonsi
inactive: gbm,wayland
API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.7-arch1.3
glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics (radeonsi
renoir LLVM 17.0.6 DRM 3.57 6.9.1-zen1-2-zen) device-ID: 1002:1638
memory: 500 MiB unified: no
API: Vulkan v: 1.3.279 layers: 3 device: 0 type: integrated-gpu name: AMD
Radeon Graphics (RADV RENOIR) driver: mesa radv v: 24.0.7-arch1.3
device-ID: 1002:1638 surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
(LLVM 17.0.6 256 bits) driver: mesa llvmpipe v: 24.0.7-arch1.3 (LLVM
17.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
speed: 16 GT/s bus-ID: 03:00.1 chip-ID: 1002:1637 class-ID: 0403
Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: ASUSTeK
driver: N/A alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x,
snd_pci_acp6x, snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps,
snd_sof_amd_renoir, snd_sof_amd_rembrandt, snd_sof_amd_vangogh,
snd_sof_amd_acp63 pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
speed: 16 GT/s bus-ID: 03:00.5 chip-ID: 1022:15e2 class-ID: 0480
Device-3: AMD Family 17h/19h HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 03:00.6 chip-ID: 1022:15e3
class-ID: 0403
API: ALSA v: k6.9.1-zen1-2-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 1.0.6 status: n/a (root, process) with:
1: pipewire-pulse status: active 2: wireplumber status: active
3: pipewire-alsa type: plugin 4: pw-jack type: plugin
tools: pactl,pw-cat,pw-cli,wpctl
Device-1: MEDIATEK MT7921 802.11ax PCI Express Wireless Network Adapter
vendor: AzureWave driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s
lanes: 1 bus-ID: 01:00.0 chip-ID: 14c3:7961 class-ID: 0280
IF: wlp1s0 state: up mac: <filter>
Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
Device-1: IMC Networks Wireless_Device driver: btusb v: 0.8 type: USB
rev: 2.1 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-2:2 chip-ID: 13d3:3563
class-ID: e001 serial: <filter>
Report: btmgmt ID: hci0 rfk-id: 2 state: up address: N/A
Local Storage: total: 476.94 GiB used: 22.72 GiB (4.8%)
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNU512GZ
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 002C temp: 26.9 C scheme: GPT
SMART: yes health: PASSED on: 9d 3h cycles: 456
read-units: 7,164,189 [3.66 TB] written-units: 4,769,261 [2.44 TB]
ID-1: / raw-size: 78.5 GiB size: 78.5 GiB (100.00%) used: 22.7 GiB (28.9%)
fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p5 maj-min: 259:5
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
used: 25.8 MiB (26.9%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
maj-min: 259:1
ID-3: /home raw-size: 78.5 GiB size: 78.5 GiB (100.00%)
used: 22.7 GiB (28.9%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p5
maj-min: 259:5
ID-4: /var/log raw-size: 78.5 GiB size: 78.5 GiB (100.00%)
used: 22.7 GiB (28.9%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p5
maj-min: 259:5
ID-5: /var/tmp raw-size: 78.5 GiB size: 78.5 GiB (100.00%)
used: 22.7 GiB (28.9%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p5
maj-min: 259:5
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.03 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12 dev: /dev/zram0
System Temperatures: cpu: 39.1 C mobo: 38.0 C gpu: amdgpu temp: 34.0 C
Fan Speeds (rpm): cpu: 0
Memory: total: 16 GiB note: est. available: 15.03 GiB used: 2.59 GiB (17.3%)
Processes: 289 Power: uptime: 15m states: freeze,mem,disk suspend: s2idle
wakeups: 0 hibernate: platform avail: shutdown, reboot, suspend, test_resume
image: 6 GiB services: org_kde_powerdevil, power-profiles-daemon, upowerd
Init: systemd v: 255 default: graphical tool: systemctl
Packages: pm: pacman pkgs: 1503 libs: 392 tools: paru Compilers:
gcc: 14.1.1 Shell: garuda-inxi (sudo) default: Bash v: 5.2.26
running-in: konsole inxi: 3.3.34
Garuda (2.6.26-1):
System install date:     2024-05-14
Last full system update: 2024-05-23
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       Yes
Failed units:            httpd.service

And if you remove that crap & enable it {BT} in Windows, what happens after you cold-boot into Garuda?

1 Like

No, I can’t, I’m currently using it and it’s boosting the performance of my Windows apps for my own needings, as I said, I don’t think it’s a trouble with my Atlas install, so it maybe a Garuda problem.

BT isn’t working on Windows because I didn’t install the driver, but the Bluetooth drivers always come with Garuda by default, so it’s so strange.

Try the LTS kernel.


It’s a bug in the Linux kernel 6.9 : as per this and so it is a general kernel issue and nothing to do with Garuda.
As per solving the issue you could try the LTS kernel as @BluishHumility suggested, or you can try this bypass mentioned in archlinux fourum instead. :grinning:

Edit: Oh you can also downgrade the Zen kernel :stuck_out_tongue:


Not recommended unless you are a very experienced Linux user. :wink:


I had this same issue and my solution was to unplug my computer, hold the power button for a few seconds, and plug it back in. Before this I tried downgrading Bluez to version 5.75-1, I tried the LTS kernel which worked until the next reboot, I tried a USB bluetooth/wifi receiver. Unplugging my computer solved the bluetooth problem on all kernels that I have, which are LTS, mainline arch, and zen.

How do I change to the LTS kernel?

Solved my problem by installing linux-lts and linux-lts-headers packages, then used grub-customizer and there was a “Garuda linux with linux-lts” entry when I installed linux-lts packages, so I edited the entries in a way that I will always boot Garuda Linux with linux-lts.

Linux-lts solved my BT problem and now my adapter is working and recognizing bluetooth devices!

Garuda Linux does not support the grub-customizer and I personally advise against it.
You can simply add an installed kernel as default with “Garuda Boot Options”.


That’s right, Grub Customizer can break things really badly–it can even mess up your bootable snapshots.

It’s kind of tricky to remove; uninstalling the package is not enough. This is from another distro, but it has some good guidance for removing Grub Customizer if you would like to take a look:

You can accomplish this safely with Grub’s GRUB_TOP_LEVEL option. See this post here:


I’ve had to do that twice with this 2019 rig, once recently. :frowning:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.