Cannot delete old timeshift snapshots after installing snapper

Hey y'all, s'me again....

So, I noticed in Garuda Assistant, after replacing Timeshift with Snapper:

  1. On the Btrfs tab, I toggled on "Show subvolume tab"
  2. On the Btrfs Subvolumes tab, I toggled on "Include Timeshift and Snapper Snapshots".

There, I have listed, all the Snapper snapshots listed up top, then the regular btrfs subvolumes (@, @cache, @home, etc), and then underneath the regular btrfs subvolumes, I have a series of subvolumes that begin with timeshift-btrfs/snapshots/[DATE]/[SUBVOLUME]

Btrfs Subvolume Screenshot

This tab has a button to "Delete Selected", but nothing happens when I click on it. I can confirm that Garuda Assistant is running with sudo privileges, as it prompts for my PW on execution.

I've checked the solution in another thread, but that seems to be specific to Timeshift, which I no longer have installed, and I'd be loathe to trying to do it manually via command-line, as I will most definitely bork my system. Any ideas?

Thanks!!

inxi -Faz
System:    Kernel: 5.14.9-zen2-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=12979374-b0c5-4bc8-8f21-3b53bd02741b rw
           [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
           systemd.unified_cgroup_hierarchy=1 resume=UUID=334332cc-a79e-45e2-b657-65270e259a03 loglevel=3
           sysrq_always_enabled=1 intel_iommu=on iommu=pt acpi_backlight=vendor delayacct
           Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
           Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: LENOVO product: 20175 v: Lenovo IdeaPad Yoga 13 serial: <filter> Chassis:
           type: 10 v: Lenovo IdeaPad Yoga 13 serial: <filter>
           Mobo: LENOVO model: INVALID v: 31900003WIN8 STD MLT serial: <filter> UEFI: LENOVO v: 66CN55WW
           date: 02/28/2013
Battery:   ID-1: BAT1 charge: 38.1 Wh (99.2%) condition: 38.4/49.3 Wh (78.0%) volts: 16.1 min: 14.8
           model: Lenovo IdeaPad Mocca2 type: Unknown serial: <filter> status: Unknown
CPU:       Info: Dual Core model: Intel Core i7-3537U bits: 64 type: MT MCP arch: Ivy Bridge family: 6
           model-id: 3A (58) stepping: 9 microcode: 21 cache: L2: 4 MiB
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19954
           Speed: 2534 MHz min/max: 1184/3100 MHz Core speeds (MHz): 1: 2534 2: 2773 3: 2893 4: 2757
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable
           Type: meltdown mitigation: PTI
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2
           mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
           Type: srbds status: Vulnerable: No microcode
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel 3rd Gen Core processor Graphics vendor: Lenovo driver: i915 v: kernel
           bus-ID: 00:02.0 chip-ID: 8086:0166 class-ID: 0300
           Device-2: Chicony Lenovo EasyCamera type: USB driver: uvcvideo bus-ID: 2-1.7:4 chip-ID: 04f2:b322
           class-ID: 0e02
           Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: intel unloaded: modesetting
           alternate: fbdev,vesa display-ID: :0 screens: 1
           Screen-1: 0 s-res: 1600x900 s-dpi: 96 s-size: 423x238mm (16.7x9.4") s-diag: 485mm (19.1")
           Monitor-1: LVDS1 res: 1600x900 hz: 60 dpi: 140 size: 290x170mm (11.4x6.7") diag: 336mm (13.2")
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) v: 4.2 Mesa 21.2.3 compat-v: 3.0
           direct render: Yes
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Lenovo driver: snd_hda_intel
           v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20 class-ID: 0403
           Device-2: DisplayLink Kensington SD4000 USB Dock type: USB driver: cdc_ncm,snd-usb-audio
           bus-ID: 4-2.1:3 chip-ID: 17e9:4344 class-ID: 0a00 serial: <filter>
           Sound Server-1: ALSA v: k5.14.9-zen2-1-zen running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: no
           Sound Server-4: PipeWire v: 0.3.38 running: yes
Network:   Message: No device data found.
           IF-ID-1: enp0s20u2u1i5 state: up speed: 100 Mbps duplex: half mac: <filter>
           IF-ID-2: vmnet1 state: unknown speed: N/A duplex: N/A mac: <filter>
           IF-ID-3: vmnet8 state: unknown speed: N/A duplex: N/A mac: <filter>
           IF-ID-4: wlp0s26u1u4i2 state: up mac: <filter>
Bluetooth: Device-1: Realtek RTL8723AU 802.11n WLAN Adapter type: USB driver: btusb,rtl8723au bus-ID: 1-1.4:4
           chip-ID: 0bda:1724 class-ID: e001 serial: <filter>
           Report: bt-adapter ID: hci0 rfk-id: 0 state: down bt-service: enabled,running rfk-block:
           hardware: no software: yes address: <filter>
Drives:    Local Storage: total: 1.14 TiB used: 458.82 GiB (39.2%)
           SMART Message: Unable to run smartctl. Root privileges required.
           ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: MZMTD256HAGM-000L1 size: 238.47 GiB block-size:
           physical: 512 B logical: 512 B speed: 3.0 Gb/s type: SSD serial: <filter> rev: 2L0Q scheme: GPT
           ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Western Digital model: WD My Passport 0820
           size: 931.48 GiB block-size: physical: 512 B logical: 512 B type: N/A serial: <filter> rev: 1007
           scheme: GPT
Partition: ID-1: / raw-size: 922.42 GiB size: 922.42 GiB (100.00%) used: 268.26 GiB (29.1%) fs: btrfs
           dev: /dev/sdb2 maj-min: 8:18
           ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.45%) used: 562 KiB (0.2%) fs: vfat
           dev: /dev/sdb1 maj-min: 8:17
           ID-3: /home raw-size: 922.42 GiB size: 922.42 GiB (100.00%) used: 268.26 GiB (29.1%) fs: btrfs
           dev: /dev/sdb2 maj-min: 8:18
           ID-4: /var/log raw-size: 922.42 GiB size: 922.42 GiB (100.00%) used: 268.26 GiB (29.1%) fs: btrfs
           dev: /dev/sdb2 maj-min: 8:18
           ID-5: /var/tmp raw-size: 922.42 GiB size: 922.42 GiB (100.00%) used: 268.26 GiB (29.1%) fs: btrfs
           dev: /dev/sdb2 maj-min: 8:18
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
           ID-1: swap-1 type: zram size: 7.64 GiB used: 216.8 MiB (2.8%) priority: 100 dev: /dev/zram0
           ID-2: swap-2 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sdb3
           maj-min: 8:19
Sensors:   System Temperatures: cpu: 61.0 C mobo: N/A
           Fan Speeds (RPM): N/A
Info:      Processes: 262 Uptime: 16h 35m wakeups: 1 Memory: 7.64 GiB used: 3.92 GiB (51.3%) Init: systemd
           v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: 1686 pacman: 1676 lib: 467
           flatpak: 10 Shell: Zsh v: 5.8 running-in: alacritty inxi: 3.3.06

I am seeing the same issue. Let me take a look and see if I can figure out what is going on there.

EDIT: Well, that didn't take long. The issue is that it uses timeshift to delete it if it is a timeshift snapshot. Let me fix that so it checks to see if timeshift is installed first.

3 Likes

I think I had the same issue.
What I had to do without timeshift is to mount each subvolume and then I was able to delete them (I had only 3 or 4 of them), e.g.
sudo btrfs subvolume list /
sudo mount -o subvolid=602 /dev/sda5 /mnt
sudo btrfs subvolume delete -i 602 /mnt
then
sudo umount /mnt
finally
sudo update-grub to remove them from the grub as well.
I hope I remember the procedure correctly, since it was a few weeks ago now, but this is what my history seems to tell me... :wink:

2 Likes

You definitely don't need to do that. If you mount the root of the btrfs volume you can delete them all in one command using xargs.

3 Likes

This is now fixed and will be in the next version.

8 Likes

Yes, I see, I was a bit "panicking" at that time and since they were only 3 I did it manually...

I didn't realize you were in a high-pressure emergency snapshot removal situation. :rofl:

1 Like

It is just that for a moment I thought I had done something wrong moving from timeshift to snapper but, as stubborn as I am, I tried to solve it myself.
Sometimes I do... before thinking...
But it worked, so I completely forgot about it until I read this thread.

2 Likes

Thanks! I'll wait for the update instead of enumerating manually through all "timeshift" snapshots, as I'm not very familiar with xargs and I don't wanna mess anything up.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.