Cannot delete old icon from the application launcher

Hello.
I had installed vscode from chaotic repo. But I didn't find some extensions that I used to use. So I downloaded it form AUR (Visual-Studo-Code). It worked fine for me. I had uninstalled the first one which I had downloaded form Chaotic (Code-OSS). But both icons are there in app luancher menu. I searched in /usr/share/applicaitons, I didn't find .desktop file for CodeOSS. And When I removed the old launcher and added new launcher of vs-code in my dock, it worked fine until I reboot the pc. After reboot it would try to open the old CodeOSS and error would popup.
How do I solve this problem??

The code-oss .desktop icon is probably in your $HOME/.local/share/applications/ folder. Once you remove that you may need to unpin from dock, open VS Code, and pin it again.

Don't forget to include the output of garuda-inxi when posting for help, as it is requested for all help requests.

1 Like

Edit: I found the icon in ~/.local/share/applications I deleted that its fine now.

2 Likes

A sidenote: the OSS version doesn't have the same marketplace as the non-OSS which results in missing extensions. There are workarounds such as downloading from vscode store and installing manually or using an AUR package called vscode-marketplace (or similar, just gotta search for marketplace) which unlocks it.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.