Cannot boot after upgrade

Blank screen after upgrade just says loading zen kernel. Tried everything and boots into old snapshot but fails as soon as I upgraded. So wiped system and installed Garuda from usb. System works fine but after update fails to boot again. Tried installing linux-zen and linux-zen=headers as per blank screen failure on forum but no help. System uses Nvidia gt770 card. Did same thing on old laptop but it works after update, it has intel graphics. Cannot get it to boot after update. any suggestions?

I think this is one of the cards Nvidia dropped from the 495xx driver - you'll have to switch to the 470xx driver instead.

1 Like

I am having the same issue with my GTX770. I rolled back to snapshot before I did the upgrade and everything is working. NVIDIA did drop support for the 770 after 470..... Thanks NVIDIA. I too much of a noob to figure out how to update my software exclude the NVIDIA driver. If anyone can point me in the right direction how to keep my driver at 470, I would appreciate it. My wiki and internet searching must be weak, because I couldn't find an answer.

1 Like

Possibly you are right, how do I downgrade drivers so they stay downgraded when I upgrade? I only have cli access for now.

I'm no Nvidia expert (nor ever had one) but I think the logic of this post could be applicable.
Of course check what you have installed now (so to add it to ignorepkg), what you have in the cache, etc..
Instead of installing from the cache, of course, you could rollback to a snapshot.

1 Like

Same here, after every update I have to run pacman - U

Block it in pacman.conf.

2 Likes

Thank you it did the trick, thanks

Thanks that was the key to keep it from upgrading

1 Like

Follow advice below it worked for me.

Thanks that was key

1 Like

You

can

use

one

@Cybertruck

post, please, next time.
There is no badge for many posts. :slight_smile:

And for "Thanks" we use just the :heart: :blush:

image

2 Likes

Thank you for all the help. I learned how to use VIM and keep this old tank of a machine still working.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.