Can we start kde plasma after user login from command line?

Hello Garuda users.

So I have two users in my OS now, one is using dragonized kde plasma edition and other one is using dwm with X11.

when I use login display manager in my case it is sddm and after login in user with dwm, it still opens up kde in that user, so for that reason I have disabled systemctl disable sddm and now there is plane blank thing for login, and now I can login into dwm user and it works.

but now the problem arise when I try to login into user with kde plasma configuration, is there any similar command like startx in x11 for kde plasma as well so I can start that desktop environment there earlier I was using garuda sway edition there dbus-run-session command was working.

Or further I would like to define this thing in maybe xinitrc for if kde uses wayland then some kind of config file itself so it shows up user specific desktop environment or startx for dwm.

Thanks.

System:
Kernel: 6.3.5-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=d81c9e20-12ce-4bca-a5bd-4199f01659e5 rw rootflags=subvol=@
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=e2f828e9-a24d-4ebb-b265-9c39b304a139 loglevel=3 ibt=off
Desktop: dwm v: 6.4 vt: 2 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Dell product: Inspiron 5593 v: N/A
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: Dell model: 0HP5Y9 v: A00 serial: <superuser required> UEFI: Dell
v: 1.26.0 date: 03/13/2023
Battery:
ID-1: BAT0 charge: 21.1 Wh (96.8%) condition: 21.8/42.0 Wh (52.0%)
volts: 11.8 min: 11.4 model: BYD DELL 1VX1H99 type: Li-ion serial: <filter>
status: discharging
CPU:
Info: model: Intel Core i5-1035G1 bits: 64 type: MT MCP arch: Ice Lake
gen: core 10 level: v4 note: check built: 2019-21 process: Intel 10nm
family: 6 model-id: 0x7E (126) stepping: 5 microcode: 0xBA
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 2 MiB desc: 4x512 KiB L3: 6 MiB
desc: 1x6 MiB
Speed (MHz): avg: 1615 high: 3369 min/max: 400/3600 scaling:
driver: intel_pstate governor: powersave cores: 1: 1200 2: 3369 3: 1200
4: 1255 5: 1625 6: 1200 7: 1621 8: 1453 bogomips: 19046
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: Intel Iris Plus Graphics G1 vendor: Dell driver: i915 v: kernel
arch: Gen-11 process: Intel 10nm built: 2019-21 ports: active: eDP-1
empty: HDMI-A-1 bus-ID: 0000:00:02.0 chip-ID: 8086:8a56 class-ID: 0300
Device-2: NVIDIA GP108M [GeForce MX230] vendor: Dell driver: nouveau
v: kernel non-free: 530.xx+ status: current (as of 2023-05) arch: Pascal
code: GP10x process: TSMC 16nm built: 2016-21 bus-ID: 0000:01:00.0
chip-ID: 10de:1d11 class-ID: 0302
Device-3: Microdia Integrated_Webcam_HD driver: uvcvideo type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-6:4 chip-ID: 0c45:671e
class-ID: 0e02
Display: server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
compositor: xcompmgr driver: X: loaded: modesetting,nouveau
alternate: fbdev,intel,nv,vesa dri: iris,nouveau gpu: i915 display-ID: :1
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: LG Display 0x05f2 built: 2018 res: 1920x1080
hz: 60 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
ratio: 16:9 modes: 1920x1080
API: OpenGL v: 4.6 Mesa 23.1.1 renderer: Mesa Intel UHD Graphics (ICL GT1)
direct-render: Yes
Audio:
Device-1: Intel Ice Lake-LP Smart Sound Audio vendor: Dell
driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_icl
bus-ID: 0000:00:1f.3 chip-ID: 8086:34c8 class-ID: 0403
API: ALSA v: k6.3.5-zen2-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 0.3.71 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell
driver: r8169 v: kernel port: 3000 bus-ID: 0000:02:00.0 chip-ID: 10ec:8136
class-ID: 0200
IF: enp2s0 state: down mac: <filter>
Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
vendor: Dell driver: ath10k_pci v: kernel bus-ID: 0000:03:00.0
chip-ID: 168c:0042 class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
IF-ID-1: br-c680a8bca5ba state: down mac: <filter>
IF-ID-2: docker0 state: down mac: <filter>
Bluetooth:
Device-1: Qualcomm Atheros driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-10:5 chip-ID: 0cf3:e009
class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
RAID:
Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode]
driver: intel_nvme_remap v: N/A port: 5060 bus-ID: 0000:00:17.0
chip-ID: 8086:282a rev: N/A class-ID: 0104
Drives:
Local Storage: total: 1.38 TiB used: 45.11 GiB (3.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: BC511 NVMe 512GB
size: 476.94 GiB block-size: physical: 512 B logical: 512 B tech: SSD
serial: <filter> fw-rev: 11001101 temp: 41.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM049-2GH172
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 7200 serial: <filter> fw-rev: SDM2 scheme: GPT
Partition:
ID-1: / raw-size: 467.84 GiB size: 467.84 GiB (100.00%)
used: 45.11 GiB (9.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 467.84 GiB size: 467.84 GiB (100.00%)
used: 45.11 GiB (9.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 467.84 GiB size: 467.84 GiB (100.00%)
used: 45.11 GiB (9.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 467.84 GiB size: 467.84 GiB (100.00%)
used: 45.11 GiB (9.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.53 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
ID-2: swap-2 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/nvme0n1p3 maj-min: 259:3
Sensors:
System Temperatures: cpu: 70.0 C mobo: 43.0 C gpu: nouveau temp: 54.0 C
Fan Speeds (RPM): cpu: 3039
Info:
Processes: 246 Uptime: 6m wakeups: 10181 Memory: available: 7.53 GiB
used: 1.86 GiB (24.7%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 13.1.1 Packages: pm: pacman pkgs: 1342
libs: 349 tools: octopi,paru,yay Shell: fish v: 3.6.1 default: Zsh v: 5.9
running-in: konsole inxi: 3.3.27
Garuda (2.6.16-1):
System install date:     2023-05-27
Last full system update: 2023-06-06
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units:

actually I found solution there are commands like

startplasma-wayland and startplasma-x11.

1 Like

Don't forget to give yourself a "Solved", those help others find solutions via search.

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.