Can’t even load the live USB interface

Noob here, I wanted to try Garuda Dragonized but my pc cant even load the USB interface at the startup. Pc Specs Ryzen 7 5800 Gigabyte X570 Aorus Elite Amd 5700Xt 16Gb ram.

I tried switching usb sticks, disabling Secure Boot, resetting secure boot keys.

With Ubuntu everything load perfectly, but with any Garuda distro it doesn’t seem to load anything.

It just stays with the desktop background, I can't even open the terminal doing CTRL-ALT-T.

Am I missing some drivers? I tried to boot with Open source drivers and Nvidia ones too, but the result stays the same.

1 Like

Welcome to the Garuda forum :slight_smile:

Well have you checked the checksum of the ISO?
I had a very familiar issue on the computer of a friend of mine, after testing the check sum there is an error occurred. Hence we had to download the ISO again and then it worked, check sum fine and the installation ran through thoroughly without any issues.

All the best,

Bruce :shark:

1 Like

I was thinking about a problem with the ISO, so I tried downloading it again. I tried with Garuda Dr460nized Gaming Edition, with Garuda Dr460nized standard and even with Garuda Gnome but the problem remained the same across all versions.

Try Works fine here.


I’m not really sure this will help, but it’s so easy to try that it’s worth testing.
Try using the amdgpu.dpm=0 kernel boot parameter, e.g. like here:

Probably not, but, if you use two monitors, always connect only one for the moment.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.