Can’t boot into system and thrown into emergency shell

Hey, so I turned on my laptop today after successfully using it two days ago and now my laptop refuses to work. It has this loading screen forever and this error when pressing escape. I’ve searched for this problem but haven’t had any luck and can’t get a Garuda inxi prompt or anything. Any ideas? Thanks

Looks like your filesystem is corrupt.


Try How to recover from BTRFS errors | Support | SUSE

It worked for me :wink:

Good Luck!

(BTRFS seems like a pretty unstable filesystem. I don't like it's tendency to corrupt)


fstab maybe too, new_root???

Grub work?
Search also in forum for black screen.

Hard disks also break with ext4, I had just recently with two.


Thanks I’m reading through it but in all honesty I’m more confused after reading it than I was before lol. I’ll try and make sense of what I should do though

  1. Try to do the scrub
  2. Try the zero-log command (My previous saviour)

No clue about fstab as I haven’t done anything there with it recently other than update and use zoom. Snapshots don’t work either btw. Grub works as I have the grub menu to select Garuda or whatever from the menu. Thanks I’ll look a little more in depth although what I have looked at already doesn’t seem too relevant

Okay thanks I’ll give it a go. Guessing that means I’ll need a usb rescue stick so that’s hassle lol. I’ll go try a scrub then whatever that zero log command is lol

The suse wiki explains the commands in the Situtation section


So I’m really confused what happened lol but everything is fixed lol. Did a scrub which gave the summary of error summary csum=170 with 170 uncorrectable problems. Didn’t know if that would have helped so I did the btrfs rescue zero log command and that ran without issue once I unmourned the partition after chrooting in. Weirdly though I was getting errors when trying to update the system or install packages through chroot as it couldn’t reach the mirrors apparently. Figuring nothing would have fixed it I just gave it a reboot in case and it booted up normally and updated fine! So thanks a lot I appreciate it and especially your help @UltraBlack


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.