Can pamac-all be installed to replace pamac-aur

Hi there, I run Garuda XFCE and i am generally happy with it. I have a quick question. If I wanted to replace my pamac-aur with pamac-all whats the easiest way of doing that?

Use pamac and see what happend.

3 Likes

pamac-all conflicts with pamac-aur and several other "flavours", so installing it you will be asked to confirm that pamac-aur will be removed and press Y.
https://aur.archlinux.org/packages/pamac-all
PS1: the title says "on top of", the post "replace": I assumed the latter was the intended action
PS2: please consider that the use of GUI tool for searching packages and maybe install a single one could be OK. But our strongly-suggested tool for updating your system is garuda-update

PS3: welcome to the forum!!! (last but not least)

4 Likes

If you are using anyone of the pamac for installing packages, you will see breakage sooner or later.

4 Likes

Thank you for your response. I tried installing pamac-all using pamac itself but the build process failed because it says it cant find some dependency i think it was snapd.glib or something similar. here is the output of the .build file:

conf = configuration_data()
conf.set('bindir', join_paths(get_option('prefix'), get_option('bindir')))

subdir('config')
subdir('dbus')
subdir('mime')
subdir('polkit')
subdir('systemd')

now im having errors installing anything:

==> Starting build()...
error: failed to determine cargo home: could not find cargo home dir
==> ERROR: A failure occurred in build().
    Aborting...
Finished with result: exit-code
Main processes terminated with: code=exited/status=4
Service runtime: 2.235s
CPU time consumed: 1.670s
[[email protected] ~]$ rua
bash: rua: command not found

I dont think I understand what you are saying.

I moved it to #issues-assistance:aur-snaps-flatpaks-other
Ask the developer, please
#Applications / pamac · GitLab

3 Likes

You can also try following the comments in the AUR link, there seem to be workarounds but probably not so trivial.
Also installing with a AUR helper like paru or even better building manually might be needed.
I've no experience with pamac but I do know it always created a lot of issues here in the past.
If your system is currently broken for any installation you should consider restoring the latest working snapshot...

5 Likes

So yeah turns out pamac-all itself has a problem. Anyway, I just wanted to say that I have since started using bauh which I find to be a very nice package manager that connects to everything.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.