Can not install appropriate driver for RTX4080

Hello Garuda Forum.
I maybe have a big Problem, or it is just my personal perception.
But first my grauda-inxi:

  Kernel: 6.1.21-1-lts arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
    root=UUID=188e7b32-8e99-4142-a534-c5aa2ee178e8 rw rootflags=subvol=@
    quiet quiet nvidia-drm.modeset=1 rd.udev.log_priority=3
    vt.global_cursor_default=0 loglevel=3 ibt=off
  Desktop: KDE Plasma v: 5.27.3 tk: Qt v: 5.15.8 wm: kwin_x11 dm: SDDM
    Distro: Garuda Linux base: Arch Linux
  Type: Desktop Mobo: ASRock model: A520M-ITX/ac serial: <filter>
    UEFI: American Megatrends LLC. v: P1.80 date: 08/09/2021
  Info: model: AMD Ryzen 7 3700X socket: AM4 bits: 64 type: MT MCP arch: Zen 2
    gen: 3 level: v3 note: check built: 2020-22 process: TSMC n7 (7nm)
    family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 32 MiB desc: 2x16 MiB
  Speed (MHz): avg: 3600 min/max: 2200/4426 boost: enabled
    base/boost: 3600/4400 scaling: driver: acpi-cpufreq governor: performance
    volts: 1.1 V ext-clock: 100 MHz cores: 1: 3600 2: 3600 3: 3600 4: 3600
    5: 3600 6: 3600 7: 3600 8: 3600 9: 3600 10: 3600 11: 3600 12: 3600
    13: 3600 14: 3600 15: 3600 16: 3600 bogomips: 115026
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
  Device-1: NVIDIA AD103 [GeForce RTX 4080] driver: nvidia v: 530.41.03
    alternate: nouveau,nvidia_drm non-free: 525.xx+
    status: current (as of 2023-02) arch: Lovelace code: AD1xx
    process: TSMC n4 (5nm) built: 2022-23+ pcie: gen: 3 speed: 8 GT/s
    lanes: 16 link-max: gen: 4 speed: 16 GT/s ports: active: none
    off: DP-3,HDMI-A-1 empty: DP-1,DP-2 bus-ID: 06:00.0 chip-ID: 10de:2704
    class-ID: 0300
  Device-2: Logitech BRIO Ultra HD Webcam type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 3- chip-ID: 046d:085e
    class-ID: 0102 serial: <filter>
  Display: x11 server: X.Org v: 21.1.7 with: Xwayland v: 23.1.0
    compositor: kwin_x11 driver: X: loaded: nvidia gpu: nvidia,nvidia-nvswitch
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 4920x2160 s-dpi: 120 s-size: 1041x457mm (40.98x17.99")
    s-diag: 1137mm (44.76")
  Monitor-1: DP-3 mapped: DP-4 note: disabled pos: primary,top-right
    model: Dell G3223Q serial: <filter> built: 2022 res: 3840x2160 dpi: 137
    gamma: 1.2 size: 710x400mm (27.95x15.75") diag: 813mm (32") ratio: 16:9
    modes: max: 3840x2160 min: 640x480
  Monitor-2: HDMI-A-1 mapped: HDMI-0 note: disabled pos: bottom-l
    model: Dell P2219H serial: <filter> built: 2019 res: 1080x1920 hz: 60
    dpi: 103 gamma: 1.2 size: 267x476mm (10.51x18.74") diag: 546mm (21.5")
    ratio: 16:9 modes: max: 1920x1080 min: 640x480
  API: OpenGL v: 4.6.0 NVIDIA 530.41.03 renderer: NVIDIA GeForce RTX
    4080/PCIe/SSE2 direct-render: Yes
  Device-1: NVIDIA driver: snd_hda_intel v: kernel pcie: bus-ID: 3-1.2:5
    gen: 3 chip-ID: 1038:1216 speed: 8 GT/s class-ID: 0300 lanes: 16
    serial: <filter> link-max: gen: 4 speed: 16 GT/s bus-ID: 06:00.1
    chip-ID: 10de:22bb class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: ASRock
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 08:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-3: SteelSeries ApS SC2 USB Headset type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Device-4: Logitech BRIO Ultra HD Webcam type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 3- chip-ID: 046d:085e
    class-ID: 0102 serial: <filter>
  Sound API: ALSA v: k6.1.21-1-lts running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.67 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASRock driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: f000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Broadcom BCM4360 802.11ac Wireless Network Adapter vendor: Apple
    driver: wl v: kernel modules: bcma pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    bus-ID: 05:00.0 chip-ID: 14e4:43a0 class-ID: 0280
  IF: wlp5s0 state: dormant mac: <filter>
  Device-3: ASIX AX88179 Gigabit Ethernet type: USB driver: ax88179_178a
    bus-ID: 4-1.4:5 chip-ID: 0b95:1790 class-ID: ff00 serial: <filter>
  IF: enp8s0f3u1u4 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-1: Apple Bluetooth Host Controller type: USB driver: btusb v: 0.8
    bus-ID: 1-9.3:7 chip-ID: 05ac:828d class-ID: fe01
  Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
  Local Storage: total: 968.8 GiB used: 368.5 GiB (38.0%)
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Transcend model: TS1TMTE220S
    size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 42A0S63A temp: 32.9 C scheme: GPT
  SMART: yes health: PASSED on: 284d 17h cycles: 4,424
    read-units: 49,589,408 [25.3 TB] written-units: 56,643,765 [29.0 TB]
  ID-2: /dev/sda maj-min: 8:0 type: USB vendor: Patriot model: N/A
    size: 7.46 GiB block-size: physical: 512 B logical: 512 B type: N/A
    serial: <filter> rev: PMAP scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: Lexar
    model: USB Flash Drive size: 7.47 GiB block-size: physical: 512 B
    logical: 512 B type: SSD serial: <filter> rev: 1100 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  ID-1: / raw-size: 470.09 GiB size: 470.09 GiB (100.00%)
    used: 368.49 GiB (78.4%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p7
    maj-min: 259:7
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 14.6 MiB (2.9%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-3: /home raw-size: 470.09 GiB size: 470.09 GiB (100.00%)
    used: 368.49 GiB (78.4%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p7
    maj-min: 259:7
  ID-4: /var/log raw-size: 470.09 GiB size: 470.09 GiB (100.00%)
    used: 368.49 GiB (78.4%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p7
    maj-min: 259:7
  ID-5: /var/tmp raw-size: 470.09 GiB size: 470.09 GiB (100.00%)
    used: 368.49 GiB (78.4%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p7
    maj-min: 259:7
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-2: swap-2 type: zram size: 31.28 GiB used: 1.2 MiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 48.4 C mobo: N/A gpu: nvidia temp: 38 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
  Processes: 382 Uptime: 13m wakeups: 0 Memory: 31.28 GiB
  used: 5.58 GiB (17.8%) Init: systemd v: 253 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: pm: pacman
  pkgs: 1753 libs: 537 tools: octopi,paru Shell: garuda-inxi (sudo)
  default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.25
Garuda (2.6.16-1):
  System install date:     2023-03-24
  Last full system update: 2023-03-27
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut nvidia-dkms
  Windows dual boot:       No/Undetected
  Failed units:

I obviously searched here for help but i can not find a solution to my specific problem. Searched the wiki but nothing there also.
Maybe i'm just not experienced to Arch since im coming from Fedora in combination with Radeon cards. But:

I searched the Nvidia Page for the best and appropriate driver for my RTX 4080 FE since i have some Problems here and there using either Wayland with Gnome or KDE after standby (Just cursor and black screen). Xorg works fine. But Xorg is no option, need Wayland because of non global fractional scaling. Using one 4K and one 1080p Monitor. Scaling to 100% is not good on the 4K and 125% is too big on the 1080p.
Got there because i was curious and just wanted to install the driver directly provided by Nvidia. And here the problem begins.
As you can see now and automatically the driver version installed is 530.41.03 whereas my card is explicitly not mentioned on the Nvidia compatibility chart.
Nvidia says i should use either the or driver. As those are the only drivers directly mention my card.
But anyways, if i install one of those drivers i'm only greeted with the old but gold "loading initial ramdisk" and i only can revert what i had done. Use Snapper and go back or reinstall 530.41.03 with pacman -S nvidia-dkms.
After this everything is working.

There is only one thing that bothers me and i can think of be the problem and that is the screen-"photo" i would like to attach here (but as a new user i can not). It tells me during installation that the driver is already part of the Kernel i chose: "exactly matches what is already found in kernel 6.1.21-1-lts" multiple times. And of course it is already the LTS Kernel because i read somewhere that the zen Kernel can be problematic with Nvidia drivers.
So yes, even with the "wrong" drivers my card is working okayisch, but it bothers me that there is a better driver and i simply can not use it...

Would be great if someone can point out what i'm missing here.

There is a separate package for use with the LTS kernel, have you tried that yet?

sudo pacman -S nvidia-lts

It may be worth trying other kernels as well, in addition to LTS and Zen.

My understanding is using Nvidia on Wayland is still sort of a “beta” experience, so getting everything working exactly how it should may or may not be possible.


Okay, i'll try. I hope it is okay that i uninstall garuda-nvidia-config together with nvidia-dkms because it is a dependency. Then i can install nvidia-lts.

EDIT: Could not get it to work, to install nvidia-lts i had to uninstall nvidia-dkms and garuda-nvidia-config. After installing nvidia-lts i simply get to the point "loading initial ramdisk" and nothing happens.

But i have to admit, fiddling with it is really fun because of snapper tools and the possibility to simply revert anything i did. Great job guys to include such a great tool for beginners. Feels like you can not break the installation.

So where we are at it, what is the advantage of nvidia-dkms and why can't i simply use the normal nvidia package with the zen kernel? what is this garuda-nvidia-config package all about?
It's getting late here and i'm trying to get some sleep. But tomorrow i'm really excited to try out my luck uninstalling this nvidia-dkms and use nvidia instead. Or is this generally a bad idea? As long as i'm using something out of the repo it should be fine i think. But i really want to use the 525.xx version of the driver and i don't know how...

The main benefit of DKMS packages is they get automatically updated when the kernel is updated. That can be a very helpful feature on rolling release distributions, where the kernel updates land as soon as they are available.

From Wikipedia:

Dynamic Kernel Module Support (DKMS) is a program/framework that enables generating Linux kernel modules whose sources generally reside outside the kernel source tree. The concept is to have DKMS modules automatically rebuilt when a new kernel is installed.

I don’t know. Have you tried the “regular” kernel instead?

sudo pacman -S linux linux-headers

Okay, sounds like i should simply just rely on dkms driver support and don't mind any further. Less pain in the future. But is seems quite odd that dkms uses a driver versin for my card which is the only version not mentioned by nvidia for compatibility with my card. The older version and the new beta version (which are those i mentioned earlier and which i downloaded directly from nvidia) are compatible.
So i guess i just wait until a newer version is out and gets updated automatically.

@screwb0x did you ever get 4080 working with garuda? I am stuck at

Loading initial ramdisk ...

it would be great if you got it working. I don't see a light at the end of tunnel as of now.

A post was split to a new topic: Driver for RTX4080