Can not boot from the installation image on MacBook

I have this (with 4GB RAM)

I tried to boot the (Xfce Edition) installation image from USB by starting and keeping Alt key pressed, but the USB device is not listed. I tried Arch installation image, too, and it could be selected and booted. But how to boot the Garuda image? I just used dd to make the installation device from the .iso file.

BTW the wiki tells to use nvidia-390xx driver for old NVIDIA graphics cards, but my hardware works by nvidia-340. Is that an issue?

I'm not a Mac user, but at least I can leave you the wiki guide:


It does not help. I could boot another, regular PC by the USB drive, though.

I found a trick that worked: I pressed Alt and kept it down until I saw symbol for the hard drive of the Macbook. Then I (removed and) inserted the USB drive and voila, its symbol appeared.

1 Like

I suppose I should boot with open source drivers due to the old NVIDIA graphics card. At least it doesn't seem to be able to show desktop with proprietary drivers.

So I did. With free drivers I get the Xfce desktop, but with something wrong with window borders. I wonder why is that, but it got better once I switched Window Manager theme to something else (and back to default) .

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.