Can I install Garuda with AMD RAID?

The page says to use AHCI in BIOS but I want to use an RCRAID array and partition for Windows and Linux respectively for the use. I have a 999GB AMD RAID 0 array and would like to use 799 GB for Linux where I intend to play games and leave 200 GB for Windows. I also use a separate NVME for the system files so the RAID is on /home

I may have to compile my own Kernel to have AHCI as a module so I can blakclist it but I wonder if BTRFS needs AHCI and that's why it's mentioned on the page.

Maybe this can be achieved with DM-RAID and software RAID on Windows?

It looks if FakeRAID, this can be done by DM-RAID. I just need to delete the AMD RAID from windows because it makes the partition in a way that Linux can't see but Windows can see the Linux partitions.

So I set CSM on BIOS and boot up LIve session:

pacman -S dmraid
dmraid -ay

Then the RAID should appear.

And run the installer and make my 799 GB partition to leave unallocated space for the windows 200 GB partition

chroot the installed system and install dmraid and add the module dm-raid to /etc/modules then run mkinitcpio -P

And it should be ready to boot with Home on the separate RAID disk.


NOTE it didn't se th array, I'll research this for the future

Did you read this


I have never tried this myself but do you also need the dkms modules for rcraid?


My question is given that Garuda says to use AHCI I mean. I just got to work on it and tried that. First, thing is if the Zen Kernel has AHCI as module or built in, AFAIK Arch vanilla has it as a moduel and that's why it works on Arch so things may differ form Garuda to Arch due to the Kernel. I need to compile the driver and unload AHCI to be able to install RC-RAID and see the disk, then chroot into the new system and compiled there too.

With dmraid it didn't work so maybe I have hardware RAID not FakeRAID.

I didi again a BTRFS RAID but the installation was rocky, the installer didn't see the two drives and DF didn't see 999. I booted and added the disk to the raid and repaired it. Good to go for the moment.


I found this piece of info:

Here are some examples of FakeRAID controllers: Intel Rapid Storage, JMicron JMB36x RAID ROM, AMD RAID, ASMedia 106x, and NVIDIA MediaShield.


So I am going for this Wiki article

IMO, stay away from any sort of FakeRAID or BIOS-based RAID when using Linux. Usually, consumer mainboards do not come with real RAID.
Instead, use the Linux tools that are available (see Wiki link above) in plain AHCI-SATA mode.
BTRFS RAID 0/1 worked very well in my tests a few years ago, but the disks were exclusively used for Linux.
Having both Linux and Windows on the same array of disks is more tricky, and very probably impossible with BTRFS (although there is a Windows driver for BTRFS).


Yeah. I think I will.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.