Calamares Stuck on module

Hi folks,

Trying to install latest dragonised from Garuda, all seems to be well but calamares gets stuck on 'waiting for 1 module' (currently over 10,000 seconds :confused:

sudo calamares -debug
13:15:18 [6]: void Calamares::RequirementsChecker::reportprogress()
      Remaining modules: 1

Does this for proprietary and open source drivers too.

Any thoughts?

Welcome :slight_smile:

Please post the full ISO name and where you download the ISO.
Did you check the file with



sudo -E calamares [-d]

You can post the garuda-inxi output as text from live ISO.


So I used the Garuda downloader and rufus to write the iso, garuda-dr460nized-gaming-linux-zen-220329.iso

╭─[email protected] in ~ 
╰─λ inxi
CPU: 12-core AMD Ryzen 9 5900X (-MT MCP-) speed/min/max: 3598/2200/5073 MHz
Kernel: 5.16.16-zen1-1-zen x86_64 Up: 5m Mem: 5082.3/32086.6 MiB (15.8%)
Storage: 0/1.85 TiB Procs: 447 Shell: fish inxi: 3.3.14
McFly: Importing shell history for the first time. This may take a minute or two...done.

╭─[email protected] in ~ took 1s
╰─λ garuda-inxi
Kernel: 5.16.16-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_GB keytable=gb
tz=Europe/London misobasedir=garuda
misolabel=GARUDA_DR460NIZEDGAMING_WHITETAI quiet systemd.show_status=1
driver=nonfree nouveau.modeset=0 i915.modeset=1 radeon.modeset=1
Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop Mobo: Micro-Star model: MAG X570 TOMAHAWK WIFI (MS-7C84)
v: 1.0 serial: <superuser required> UEFI: American Megatrends LLC. v: 1.81
date: 08/05/2021
Info: model: AMD Ryzen 9 5900X bits: 64 type: MT MCP arch: Zen 3
family: 0x19 (25) model-id: 0x21 (33) stepping: 0 microcode: 0xA201016
Topology: cpus: 1x cores: 12 tpc: 2 threads: 24 smt: enabled cache:
L1: 768 KiB desc: d-12x32 KiB; i-12x32 KiB L2: 6 MiB desc: 12x512 KiB
L3: 64 MiB desc: 2x32 MiB
Speed (MHz): avg: 3637 high: 4535 min/max: 2200/5073 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3630 2: 3600
3: 3596 4: 3599 5: 3593 6: 3599 7: 3599 8: 3597 9: 3598 10: 3596 11: 3597
12: 3594 13: 3595 14: 3594 15: 3596 16: 3595 17: 3599 18: 3619 19: 3592
20: 4535 21: 3597 22: 3595 23: 3601 24: 3593 bogomips: 177610
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: always-on, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: NVIDIA GA102 [GeForce RTX 3080] vendor: Micro-Star MSI
driver: nvidia v: 510.54 alternate: nouveau,nvidia_drm pcie: gen: 4
speed: 16 GT/s lanes: 16 bus-ID: 2d:00.0 chip-ID: 10de:2206
class-ID: 0300
Display: x11 server: X.Org v: compositor: kwin_x11 driver: X:
loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x2160 s-dpi: 139 s-size: 702x392mm (27.64x15.43")
s-diag: 804mm (31.65")
Monitor-1: DP-0 res: 3840x2160 hz: 60 dpi: 140
size: 697x392mm (27.44x15.43") diag: 800mm (31.48") modes: N/A
OpenGL: renderer: NVIDIA GeForce RTX 3080/PCIe/SSE2
v: 4.6.0 NVIDIA 510.54 direct render: Yes
Device-1: Creative Labs driver: snd_hda_intel v: kernel bus-ID: 26:00.0
chip-ID: 1102:0010 class-ID: 0403
Device-2: NVIDIA GA102 High Definition Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 2d:00.1 chip-ID: 10de:1aef class-ID: 0403
Device-3: C-Media Blue Snowball type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 5-1:2 chip-ID: 0d8c:0005
class-ID: 0300 serial: <filter>
Sound Server-1: ALSA v: k5.16.16-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.48 running: yes
Device-1: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8169
v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 port: f000 bus-ID: 27:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp39s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-4:3 chip-ID: 8087:0029 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: down bt-service: N/A
rfk-block: hardware: no software: no address: <filter>
Local Storage: total: 1.85 TiB used: 0 KiB (0.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: WDS100T1X0E-00AFY0 size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 613200WD temp: 41.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:3 vendor: Western Digital
model: WDS100T1X0E-00AFY0 size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 613200WD temp: 46.9 C scheme: MBR
ID-3: /dev/sda maj-min: 8:0 type: USB vendor: Kingston
model: DataTraveler 3.0 size: 28.88 GiB block-size: physical: 512 B
logical: 512 B type: N/A serial: <filter> rev: PMAP scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Message: No partition data found.
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.33 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0

Now getting stuck on two modules

14:09:19 [6]: void Calamares::RequirementsChecker::reportProgress()
Remaining modules: 2

Interestingly, KDE Partition Manager detects my 2x SN850 nvme's just fine but just sits there ticking when you apply actions to them.

Some folks recently ran into a Calamares bug related to partitioning on KDE (I kind of forget the specifics). Here are a few posts that might be worth a read through:

I think this was the workaround that ended up working for a few people:

1 Like

Thanks for the links @BluishHumility - sadly I've already tried this.

I added this into grub: nvme_core.default_ps_max_latency_us=5500

Now getting

3:51:30 [6]: void PartitionCoreModule::doInit()
.. node     capacity        name    prettyName 
.. "/dev/nvme0n1" 1000202273280 DevName$7d7274b7 DevNamePretty$39aa651a 
.. "/dev/nvme1n1" 1000202273280 DevName$7d7274b7 DevNamePretty$7096183d 
.. 2 devices detected. 
13:51:30 [6]: void Config::xkbApply()
xkbmap selection changed to:  "us" - "" 
13:51:31 [6]: OsproberEntryList PartUtils::runOsprober(DeviceModel*)
os-prober gave no output. 
13:51:31 [2]: void PartitionCoreModule::scanForEfiSystemPartitions()
WARNING: system is EFI but no EFI system partitions found. 
13:51:31 [6]: void Calamares::RequirementsChecker::addCheckedRequirements(Calamares::Module*)
Got 1 requirement results from "partition" 
13:51:31 [6]: void ChoicePage::updateDeviceStatePreview()
Updating partitioning state widgets. 
13:51:31 [6]: void ChoicePage::setupActions()
Setting up actions for "/dev/nvme0n1" with 0 entries. 
..  Can not resize "/dev/nvme0n1" , filesystem "unknown" does not support resize. 
..  Checking if "/dev/nvme0n1" can be replaced. 
..  Partition "/dev/nvme0n1" authorized for replace install. 
.. contains replaceable "unallocated" 
13:51:31 [6]: ChoicePage::setupActions()::<lambda()>
Setting texts for 0 osprober entries 
13:51:31 [6]: void ChoicePage::setupActions()
No partitions available for resize-action. 
13:51:31 [2]: void ChoicePage::setupActions()
WARNING: System is EFI but there's no EFI system partition, DISABLING alongside and replace features. 
13:51:31 [6]: void ChoicePage::continueApplyDeviceChoice()
Previous device -1 new device 0 
13:51:31 [6]: void ChoicePage::applyActionChoice(InstallChoice)
Prev -1 InstallChoice Config::NoChoice "none" 
13:51:31 [6]: bool ChoicePage::calculateNextEnabled() const
No partitioning choice 
13:51:31 [6]: void ChoicePage::updateActionChoicePreview(InstallChoice)
Updating partitioning preview widgets. 
13:51:31 [6]: void Calamares::RequirementsChecker::reportProgress()
Remaining modules: 1 

so still stuck. I get the same behaviour in Manjaro too so I'm sure it's calamares/kde related

Are you setting up custom partitions in the installer?

If so, can you set up the partitioning in parted (or gparted or whatever) outside of Calamares, and see if you have better luck?

I'm able to sort the partitions manually now, but calamares won't allow me to click next from the initial language screen as its waiting for the welcome module (whatever that is)

Even tried non KDE versions of garuda and getting same issues

OK, so hows this for very definition of FML..........

Did lots of googling, nothing.

Went onto the MSI website and had a look at BIOS' and noticed the latest available was in fact a beta version which just so happened to be installed on my motherboard (MAG Tomahawk WiFi X570). Flashed the latest non-beta BIOS and gave it a try.

Here are the specifics of each try I then performed:

Garuda Dr460 - All GB settings - Prop Drivers - FAIL
Garuda Dr460 - All GB settings - Community Drivers - FAIL
Garuda LXQt - All GB settings - Prop Drivers - FAIL
Garuda LXQt - All GB settings - Community Drivers - FAIL
Pop_OS (for giggles) - All GB settings - FAIL
Manjaro KDE Plasma - All GB settings - Prop Drivers - FAIL
Manjaro KDE Plasma - All GB settings - Community Drivers - FAIL
Manjaro XFCE - All GB settings - Prop Drivers - FAIL
Manjaro XFCE - All GB settings - Community Drivers - FAIL

Then for some reason (frustration), with Manjaro XFCE I got set sick of setting the language so I just smashed enter, so all US settings with Prop drivers....... it only went and worked! Installed Manjaro, updated it, ran various hardware tests, everything good.

So, as I reallllllllly want to use Garuda, re-ran Dr460, all US, prop drivers - and here I am updating this post from within my newly installed OS.

I have no idea :confused:

Don't use BETA BIOS'
Don't set GB language

Thanks @BluishHumility @SGS for trying. Bizarre one this

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.