Busted UPDATE, again

Updates have been problematic for this installation since the GRUB-update fiasco of like two months ago. Rather than complain, I welcomed the unbootable system as an opportunity to discover the true cause: in my case, dkms kernel modules installed from the AUR left my dkms a mess. Shame on me: the warnings about installing software from the AUR were understood, yet disregarded...

Yet this one is different, the relevant line from the garuda-inxi output below is found almost at the bottom: "warning: database file for 'blackarch' does not exist (use '-Sy' to download)"

I did rm -f /var/lib/pacman/sync/* and then a pacman -Syy, to no avail. garuda-update also bombs out prematurely citing it could not find the blackarch database file, and I find this:

failed retrieving file 'blackarch.db' from ftp.halifax.rwth-aachen.de : SSL certificate problem: unable to get local issuer certificate

Any ideas?

Thank you in advance,

F.

System:
  Kernel: 5.19.10-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=883ccf96-53da-47d2-9f53-f8a03613715c rw [email protected]
    rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=37d19283-24e5-428b-9c98-210ea4124ef4 loglevel=2 audit=0
    pci=pcie_bus_perf,realloc acpi_irq_balance tsc=unstable clocksource=hpet
    pcie_aspm=off nowatchdog cpuidle.off=1 powersave=off preempt=full
    mitigations=off nr_cpus=4 max_cpus=4 maxcpus=4 quiet splash
  Desktop: sway v: 1.7 info: waybar dm: greetd Distro: Garuda Linux
    base: Arch Linux
Machine:
  Type: Desktop System: HP product: HP All-in-One 24-dd0xxx v: N/A
    serial: <filter> Chassis: type: 13 serial: <filter>
  Mobo: HP model: 86F3 v: 00100 serial: <filter> UEFI: AMI v: F.32
    date: 08/06/2021
CPU:
  Info: model: AMD Ryzen 3 3250U with Radeon Graphics socket: FP5 bits: 64
    type: MT MCP arch: Zen/Zen+ note: check gen: 1 level: v3 built: 2019
    process: GF 12nm family: 0x17 (23) model-id: 0x18 (24) stepping: 1
    microcode: 0x8108109
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 192 KiB desc: d-2x32 KiB; i-2x64 KiB L2: 1024 KiB desc: 2x512 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 2600 min/max: 1400/2600 boost: enabled
    base/boost: 2600/3500 scaling: driver: acpi-cpufreq governor: performance
    volts: 1.2 V ext-clock: 100 MHz cores: 1: 2600 2: 2600 3: 2600 4: 2600
    bogomips: 20761
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Vulnerable
  Type: spec_store_bypass status: Vulnerable
  Type: spectre_v1 status: Vulnerable: __user pointer sanitization and
    usercopy barriers only; no swapgs barriers
  Type: spectre_v2 status: Vulnerable, IBPB: disabled, STIBP: disabled,
    PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
    vendor: Hewlett-Packard driver: amdgpu v: kernel arch: GCN-5 code: Vega
    process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
    ports: active: eDP-1 empty: HDMI-A-1 bus-ID: 02:00.0 chip-ID: 1002:15d8
    class-ID: 0300
  Device-2: Chicony HP Webcam type: USB driver: uvcvideo bus-ID: 1-6:5
    chip-ID: 04f2:b6c4 class-ID: 0e02 serial: <filter>
  Display: server: Xwayland v: 22.1.3 compositor: sway v: 1.7 driver:
    gpu: amdgpu note:  X driver n/a display-ID: :1
  Monitor-1: eDP-1 model: HP ALL-in-One serial: <filter> built: 2019
    res: 1920x1080 dpi: 93 gamma: 1.2 size: 527x297mm (20.75x11.69")
    diag: 605mm (23.8") ratio: 16:9 modes: max: 1920x1080 min: 640x480
  Message: GL data unavailable for root.
Audio:
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 02:00.1 chip-ID: 1002:15de class-ID: 0403
  Device-2: AMD Family 17h/19h HD Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 02:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound Server-1: ALSA v: k5.19.10-zen1-1-zen running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: PulseAudio v: 16.1 running: no
  Sound Server-4: PipeWire v: 0.3.57 running: yes
Network:
  Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
    vendor: Hewlett-Packard driver: rtw_8821ce v: N/A modules: rtw88_8821ce
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 01:00.0
    chip-ID: 10ec:c821 class-ID: 0280
  IF: wlp1s0 state: up mac: <filter>
Bluetooth:
  Device-1: Realtek Bluetooth 4.2 Adapter type: USB driver: btusb v: 0.8
    bus-ID: 1-4:3 chip-ID: 0bda:b00a class-ID: e001 serial: <filter>
  Report: hciconfig ID: hci0 rfk-id: 1 state: up address: <filter>
    bt-v: 2.1 lmp-v: 4.2 sub-v: 7644 hci-v: 4.2 rev: 829a
  Info: acl-mtu: 1021:8 sco-mtu: 255:12 link-policy: rswitch hold sniff
    park link-mode: peripheral accept service-classes: rendering, capturing,
    object transfer, audio, telephony
Drives:
  Local Storage: total: 931.51 GiB used: 93.63 GiB (10.1%)
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD10EZEX-60WN4A1 family: Blue size: 931.51 GiB block-size:
    physical: 4096 B logical: 512 B sata: 3.1 speed: 6.0 Gb/s type: HDD
    rpm: 7200 serial: <filter> rev: 1A03 temp: 47 C scheme: GPT
  SMART: yes state: enabled health: PASSED on: 294d 16h cycles: 473
Partition:
  ID-1: / raw-size: 889.65 GiB size: 889.65 GiB (100.00%) used: 93.63 GiB
    (10.5%) fs: btrfs block-size: 4096 B dev: /dev/sda1 maj-min: 8:1
  ID-2: /boot/efi raw-size: 500 MiB size: 499 MiB (99.80%) used: 608 KiB
    (0.1%) fs: vfat block-size: 512 B dev: /dev/sda4 maj-min: 8:4
  ID-3: /home raw-size: 889.65 GiB size: 889.65 GiB (100.00%) used: 93.63
    GiB (10.5%) fs: btrfs block-size: 4096 B dev: /dev/sda1 maj-min: 8:1
  ID-4: /var/log raw-size: 889.65 GiB size: 889.65 GiB (100.00%) used: 93.63
    GiB (10.5%) fs: btrfs block-size: 4096 B dev: /dev/sda1 maj-min: 8:1
  ID-5: /var/tmp raw-size: 889.65 GiB size: 889.65 GiB (100.00%) used: 93.63
    GiB (10.5%) fs: btrfs block-size: 4096 B dev: /dev/sda1 maj-min: 8:1
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 5.71 GiB used: 583 MiB (10.0%)
    priority: 100 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 23.8 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda3 maj-min: 8:3
Sensors:
  System Temperatures: cpu: 55.0 C mobo: N/A gpu: amdgpu temp: 55.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 235 Uptime: 1d 1h 45m wakeups: 0 Memory: 5.71 GiB used: 2.33 GiB
  (40.8%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: 5771 pm: pacman pkgs: 5744
  libs: 447 tools: octopi,pamac,paru,pikaur,trizen,yay pm: flatpak pkgs: 27
  Shell: Bash (sudo) v: 5.1.16 running-in: alacritty inxi: 3.3.21
warning: database file for 'blackarch' does not exist (use '-Sy' to download)
Garuda (2.6.7-1):
  System install date:     2022-08-02
  Last full system update: 2022-09-15
  Is partially upgraded:   Yes
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:
1 Like

Please try a

garuda-update remote fix
2 Likes

Having the same issue still getting the same error on the "ftp.halifax.rwth-aachen.de mirror" after running "garuda-update remote fix".

I'm not a blackarch user (nor this is officially supported in the forum), anyway I think you could try commenting in your

/etc/pacman.d/blackarch-mirrorlist

the affected mirror, to avoid using it, which should be something like this line

DE|https://ftp.halifax.rwth-aachen.de/blackarch/$repo/os/$arch|RWTH-Aachen
5 Likes

Same issue was happpening to me, did as filo said, commented out bad mirror, uncommented 2 USA mirrors. Ran yay, then garuda-update, then updated my mirrors again. remote fix did not work initially for me either.

1 Like

Just a hint :wink:: to update also AUR packages you can use

garuda-update -a 

avoiding the additional yay/paru. See:

6 Likes

TY filo for quick solution.


Steps I took to help new users

Ctrl+Alt+T to open terminal

sudo nano /etc/pacman.d/blackarch-mirrorlist

Enter password
Ctrl+w to search
type hali and [enter]

Put a # in front of the one without a #

Alt+/ to the bottom of the file
delete the # from the last line
(for me http://mirrors.ocf.berkeley.edu/blackarch/$repo/os/$arch)

Ctrl+s to save
Ctrl+x to exit

run update with

upd

Update finished without issue

I am still new to linux figured some more detailed instructions might help someone. If I got something wrong please let me know.

3 Likes

Bro, it worked for me, thanks for the simple instructions. YOU'RE A LIFE SAVER!

actually no need to ever use garuda-update, yay will update everything, re-reading that I don't know why I did garuda-update. yay is by far my favorite electronic program/command/whatever it is in existence.

Believe me, garuda-update can be a life saver, and anyway is the method we suggest for updating. Then it's up to the users...
Give a look at the wiki article and check how many useful things it does.

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.