Bugs encounters | Samba | Bottles | Dolphin

I have started using Garuda KDE since august 2022 it functioned perfectly . i used it to run windows 11 in vmware and shared a folder with it out of the box and without any problems but sins march 2023
the situwation became a problimatic the system boot was a hit and miss .

1 - I tryed snapper it broke the mounted system drive path and got stuck in a boot loop ?

I do not like tinkering with things i do not understand for fear of doing more damage , I reinstalled the system three times and did an update and each time the second thing happend .

2 - i can not install bottles from the system pacman or octopi some packges were blocked ?

sudo pacman -S bottles
[sudo] password for mrwan:
resolving dependencies...
looking for conflicting packages...

Packages (11) fvs-0.3.4-1.1  gtksourceview5-5.6.2-1  libportal-0.6-1  libportal-gtk4-0.6-1  patool-1.12-5.1
python-orjson-3.8.7-1  python-pathvalidate-2.5.2-1  python-pycurl-7.45.2-1
python-steamgriddb-1.0.5-1.1  vkbasalt-cli-3.1.1-1  bottles-2:51.5-1

Total Installed Size:  11.37 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
python-steamgriddb-1.0.5-1.1-any is up to date
error: failed retrieving file 'python-steamgriddb-1.0.5-1.1-any.pkg.tar.zst.sig' from r2.garudalinux.org : Therequested URL returned error: 404
warning: failed to retrieve some files
error: failed to commit transaction (failed to retrieve some files)
Errors occurred, no packages were upgraded.

3 - samba share no longer work with windows vm ?

all configraions and on line selutions failed I am not the tecnicaly a linux hacker so I can't find the source of the problim .

4 -the follwing dolphin root actions are no longer function ?

  • open dolphin as root .
  • move & rename .

I think this update wase carless and wase pushed too soon .

This one is because you tried to install software without updating first. Always update the system before installing software.

I update first before installing anything not from the destro maintainers I am not the only one having problems with the mirrors ?

I really don't wont to be of those how jump the sinking ship before knowing about the problems and if its possible to fix them.

It doesn't matter where the software comes from. You need to update first before installing anything using pacman or something that calls pacman.


Works beautifully on my 9 machines.

Since this is not a Garuda package, it may have been affected by the major Plasma 5.27 update. As it's often the case, such major Plasma upgrades may cause glitches or breakages in 3rd party packages. Especially on less maintained packages like this one. https://store.kde.org/p/998469/

Launching Dolphin from the terminal and looking at the output when trying to Open in File Manager, it can't find kdesudo, which doesn't exist anyway and not sure it was there prior to 5.27. In the end, if Plasma devs decided to remove something (binary, link, library, etc.) that Root Actions was using, what do you want Garuda to do about that?

Installs like a glove for me!

╰─λ paru -Qi python-steamgriddb
Name            : python-steamgriddb
Version         : 1.0.5-1.1
Description     : Python API wrapper for SteamGridDB.com
Architecture    : any
URL             : https://github.com/ZebcoWeb/python-steamgriddb
Licenses        : MIT
Groups          : None
Provides        : None
Depends On      : python-requests
Optional Deps   : None
Required By     : bottles
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 149.84 KiB
Packager        : UFSCar HPC Builder <[email protected]>
Build Date      : Sat 24 Dec 2022 05:22:58 AM EST
Install Date    : Mon 13 Mar 2023 07:00:26 PM EDT
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : Signature

Also plz do not double post the same issue in various threads. This was opened 5 days ago by you:

For any follow-up on that bottles installation failure, use that thread and not this one. Now we got replies about it here and some other replies about it in the other thread. Quite confusing to follow for other users who may have the same issue as you, don't you think?

I have no answer for this, sorry.

Plz keep those comments for yourself. This is not how you will get help, my friend.

  1. That's your fault, if it's working, and you don't know what you're doing, expect things to break.
  2. Yes, it's an issue for some people, we will look into it. It appears that the .sign request is being redirected to R2 and thus failing (it shouldn't be redirected there).

The other things were already answered, it appears that you were playing with things that you don't know and broke your OS in the path. Good time to learn.



I take back what I sed about samba, I did find the problem

is between VMWare and the firewall.

disabling the firewall got the share working and fixed it by deleting all rules and instating them again.

still, when an update breaks something I go for the distro first to know if the changes need new configurations.

This topic has been opened in the Issues & Assistance category, but honestly it's more of a whinge than an earnest attempt to reach out for help so I have moved it to a more suitable category.

No garuda-inxi posted (again), a smattering of very vague issues with no evidence of any noteworthy troubleshooting effort on your part, and now it sounds like some things have been solved but it's not even clear what. I think the community was very generous to reach out to you at all on this one, but enough is enough.

Next time, one issue per topic and follow the issue template when you post.