Bug report: Garuda-settings-manager kernel tool error

Hi team,

I just tried to install a new kernel using the garuda-settings-manager kernel tool and received an error. Looks like the tool is somewhat broken at present.

Installing kernels manually works as expected.

Full output below. It's worth noting that I was only installing linux, linux-zen and linux-lts were both already installed. I'm not sure why it's trying to reinstall those.

The following packages will be installed:

resolving dependencies...
warning: linux-zen-5.13.13.zen1-1 is up to date -- reinstalling
warning: linux-lts-5.10.62-1 is up to date -- reinstalling
looking for conflicting packages...
Packages (4) linux-5.13.13.arch1-1 linux-headers-5.13.13.arch1-1 linux-lts-5.10.62-1 linux-zen-5.13.13.zen1-1
Total Installed Size: 473.61 MiB
Net Upgrade Size: 260.04 MiB
:: Proceed with installation? [Y/n]
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Running pre-transaction hooks...
(1/2) Creating Timeshift snapshot before upgrade...
E: Commands listed below are not available on this system:
* rsync
* /sbin/blkid
* df
* mount
* umount
* fuser
* crontab
* cp
* rm
* touch
* ln
* sync
Please install required packages and try running TimeShift again
** (process:40773): CRITICAL **: 21:12:11.889: app_lock_remove: assertion 'self != NULL' failed
Unable to run timeshift-autosnap! Please close Timeshift and try again. Script will now exit...
Errors occurred, no packages were upgraded.
error: command failed to execute correctly
error: failed to commit transaction (failed to run transaction hooks)
Done ...

This system is pretty stock without a lot of customisation. inxi output below.

System:    Kernel: 5.13.13-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0  
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=af89e1f6-ec67-403f-a804-7eab8b05887e  
rw [email protected] nvme_load=YES quiet splash rd.udev.log_priority=3
vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1
resume=UUID=f7556e6d-8e49-4017-a0eb-d973f4bc5089 loglevel=3 mem_sleep_default=deep
Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM  
Distro: Garuda Linux base: Arch Linux  
Machine:   Type: Laptop System: Dell product: XPS 13 9305 v: N/A serial: <filter> Chassis: type: 10  
serial: <filter>  
Mobo: Dell model: 09DGPY v: A00 serial: <filter> UEFI: Dell v: 1.0.9 date: 07/20/2021  
Battery:   ID-1: BAT0 charge: 36.9 Wh (74.5%) condition: 49.5/52.0 Wh (95.2%) volts: 8.0 min: 7.6  
model: LGC-LGC6.73 DELL H754V0C type: Li-ion serial: <filter> status: Discharging  
CPU:       Info: Quad Core model: 11th Gen Intel Core i5-1135G7 bits: 64 type: MT MCP arch: Tiger Lake  
family: 6 model-id: 8C (140) stepping: 1 microcode: 88 cache: L2: 8 MiB  
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 38707  
Speed: 1110 MHz min/max: 400/2400 MHz Core speeds (MHz): 1: 1110 2: 1336 3: 891 4: 479 5: 993  
6: 806 7: 1045 8: 1310  
Vulnerabilities: Type: itlb_multihit status: Not affected  
Type: l1tf status: Not affected  
Type: mds status: Not affected  
Type: meltdown status: Not affected  
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp  
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization  
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling  
Type: srbds status: Not affected  
Type: tsx_async_abort status: Not affected  
Graphics:  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Dell driver: i915 v: kernel  
bus-ID: 0000:00:02.0 chip-ID: 8086:9a49 class-ID: 0300  
Device-2: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo bus-ID: 3-3:3  
chip-ID: 0c45:6723 class-ID: 0e02  
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: intel  
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1  
Screen-1: 0 s-res: 5760x2160 s-dpi: 96 s-size: 1520x570mm (59.8x22.4") s-diag: 1623mm (63.9")  
Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 168 size: 290x160mm (11.4x6.3") diag: 331mm (13")  
Monitor-2: DP3 res: 3840x2160 hz: 30 dpi: 163 size: 600x340mm (23.6x13.4") diag: 690mm (27.2")  
OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 21.2.1 direct render: Yes  
Audio:     Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Dell driver: snd_hda_intel v: kernel  
alternate: snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3 chip-ID: 8086:a0c8 class-ID: 0403  
Sound Server-1: ALSA v: k5.13.13-zen1-1-zen running: yes  
Sound Server-2: JACK v: 1.9.19 running: no  
Sound Server-3: PulseAudio v: 15.0 running: yes  
Sound Server-4: PipeWire v: 0.3.34 running: no  
Network:   Device-1: Intel Wi-Fi 6 AX200 vendor: Rivet Networks driver: iwlwifi v: kernel port: efa0  
bus-ID: 0000:a4:00.0 chip-ID: 8086:2723 class-ID: 0280  
IF: wlp164s0 state: up mac: <filter>  
Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 bus-ID: 2-3.3:4  
chip-ID: 0bda:8153 class-ID: 0000 serial: <filter>  
IF: enp0s13f0u3u3 state: down mac: <filter>  
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-1:2 chip-ID: 8087:0029  
class-ID: e001  
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>  
RAID:      Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd v: 0.6 port: 3000  
bus-ID: 0000:00:0e.0 chip-ID: 8086.9a0b rev: class-ID: 0104  
Drives:    Local Storage: total: 476.94 GiB used: 181.06 GiB (38.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: KIOXIA model: KXG60ZNV512G NVMe 512GB
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD
serial: <filter> rev: 10604107 temp: 44.9 C scheme: GPT
Partition: ID-1: / raw-size: 459.78 GiB size: 459.78 GiB (100.00%) used: 181.03 GiB (39.4%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 29.2 MiB (11.4%) fs: vfat
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 459.78 GiB size: 459.78 GiB (100.00%) used: 181.03 GiB (39.4%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 459.78 GiB size: 459.78 GiB (100.00%) used: 181.03 GiB (39.4%)
fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 459.78 GiB size: 459.78 GiB (100.00%) used: 181.03 GiB (39.4%)
fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 16.9 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p3
maj-min: 259:3
ID-2: swap-2 type: zram size: 15.36 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 46.0 C mobo: N/A
Fan Speeds (RPM): cpu: 0 fan-2: 0
Info:      Processes: 306 Uptime: 20m wakeups: 448 Memory: 15.36 GiB used: 7.34 GiB (47.8%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1485 lib: 379
Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06
1 Like

Cannot replicate :slightly_frowning_face:

A couple of people received this error while trying to install drivers, but it seems like they both ended up using a workaround rather than finding a solution: Can't install NVIDIA drivers (Timeshift error), Freeze during installation using propietary drivers - #6 by Skyxel

The error itself is caused by a Timeshift module, not within Garuda Settings.

So first of all I wold try creating a snapshot manually and see if it gives the same error.

Sorry it's not much help, but maybe a small step in the right direction.