Can't install NVIDIA drivers (Timeshift error)

Each time i try and install the bumblebee 390xx drivers from system settings i get this error:

:: Running pre-transaction hooks...
(1/2) Creating Timeshift snapshot before upgrade...
E: Commands listed below are not available on this system:

 * rsync
 * /sbin/blkid
 * df
 * mount
 * umount
 * fuser
 * crontab
 * cp
 * rm
 * touch
 * ln
 * sync

Please install required packages and try running TimeShift again

** (process:98798): CRITICAL **: 13:43:43.833: app_lock_remove: assertion 'self != NULL' failed
Unable to run timeshift-autosnap! Please close Timeshift and try again. Script will now exit...
error: command failed to execute correctly
error: failed to commit transaction (failed to run transaction hooks)
Errors occurred, no packages were upgraded.
Error: pacman failed!
Error: script failed!


Done ...

Running timeshift from the terminal, I get this:

(timeshift-gtk:13728): Gtk-WARNING **: 13:18:39.364: Theme parsing error: gtk-dark.css:6342:10: 'height' is not a valid property name

** (timeshift-gtk:13728): WARNING **: 13:18:39.430: Unable to connect to dbuus-launch --autolaunch=2a701ab4cd434134a9f091f3e4f09671 --binary-syntax --clwith code 1
App config loaded: /etc/timeshift/timeshift.json
Mounted '/dev/sda3' at '/run/timeshift/backup'

(timeshift-gtk:13728): GLib-GIO-CRITICAL **: 13:18:40.514: g_dbus_connectionDBUS_CONNECTION (connection)' failed

(timeshift-gtk:13728): GLib-GIO-CRITICAL **: 13:18:40.514: g_dbus_connectionDBUS_CONNECTION (connection)' failed

(timeshift-gtk:13728): GLib-GIO-CRITICAL **: 13:18:40.514: g_dbus_connectionDBUS_CONNECTION (connection)' failed

Prior to this I had just installed the drivers, and uninstalled video-linux, ran nvidia-xconfig, and rebooted, only for my laptop to hang indefinitely at startup (not even getting to the login screen). So i loaded into and restored a snapshot and it booted fine, but got the aforementioned error when trying to install the drivers again.

Specs
As well as an NVIDIA MX130 discrete gpu
I dual boot Garuda and Windows 10

Let me guess: you somehow forced installation to an ext4 root partition despite Garuda using BTRFS by default?

2 Likes

Nope, Both root and home are formatted to btrfs

1 Like

The output from lsblk --fs

NAME   FSTYPE FSVER LABEL    UUID                                 FSAVAIL FSUSE% MOUNTPOINT
sda
├─sda1 vfat   FAT32 NO_LABEL A652-4860                             299.8M     0% /boot/efi
├─sda2 swap   1              d289e906-2084-4e30-8e50-96d1c6110abe                [SWAP]
├─sda3 btrfs                 7bd63d2f-b315-433b-8851-b0e7864f36f1   38.6G    34% /run/timeshift/backup
├─sda4 btrfs                 3d1f5cf1-1691-4c9c-aa1f-251385b0c1eb  530.4G     7% /home
├─sda5 vfat   FAT32          2236-E994
├─sda6
├─sda7 ntfs                  3EEA3AD0EA3A83E5                        131G    56% /run/media/unequalbiscuit/3EE
└─sda8 ntfs                  C6B21DBFB21DB4C1

Maybe :slight_smile: ten chars.

killall Timeshift does nothing.. Even did a full restart, Is there something I'm not doing right?

Upgrade your system first

sudo pacman -Syu

Then

sudo mhwd -a pci nonfree 0300
5 Likes

You must have done something blunder with your system. Can you show your zsh hostory / fish histrory?

Thanks! That seems to have worked, but installed "nvidia-prime-render-offload" drivers instead, Which I'm assuming isn't too different from bumblebee

Nevermind, tried to restart and once again it's stuck at boot. It showed the loading screen for a bit, then I got sent back to the screen you see immediately after the grub menu (the one with the kernel version written), it's stopped there for roughly 10 minutes, then another loading screen, and it's been stuck for closer to 30 with nothing on the screen but "[FAILED] Failed to start Samba NMB Daemon." Windows disappeared from the grub menu as well.

Edit: Now 40 minutes

And this will keep going like this.

Welcome to Garuda!
Would you like a cup of tea?

This is a support forum, not your neighbor friend.
You are required to read the introduction pages when you register.
You should have at least do the minimum... read instructions at Garuda wiki about how to ask for support and what you should provide in your topic.

Please, sir, go for a ride at Garuda wiki and read for a couple of hours (or less, if you can read efficiently and quickly).

4 Likes

Right.. Sorry bout that, I'm just a bit panicked as I've done more than a few school projects on there, and don't want to have to do a clean install, I'll make sure to follow the wiki guide next time.

Again, this is out of the distro's control. If you want to not be in a panic situation then you (and others) need to learn to start doing backups. We can not come to your home and do your backups for you. Always keep important projects backed up on a drive separate from your OS drive (preferably an external drive).

I have been working on a Garuda project for months and I would be loath to lose my work. For this reason I have it stored on a separate internal drive as well as I back it up to 2 external USB drives for extra redundant safety.

I'm sorry that I'm not sounding very sympathetic to your situation, but we all make the bed we lie in. Perhaps it's time you started making backups of your projects before disaster strikes, because after the fact recovery is far more complicated and can not be relied upon.

4 Likes

So what's the problem? Just reboot in Live media and open your home folder and copy the projects from where you have saved them to some other partition(that 131 G ntfs partition, maybe). Be sure to make at least 2 copies of important stuff in the other partition.

This will save your project and you can do clean install.
Win win situation

4 Likes