BTRFS Issues

Hi all,
I have had some issues with my laptop 5 days ago. I don’t remember doing anything peculiar before that, but it had been running for a few days (not continually).
I noticed it was taking time to go to sleep, so I tried to perform a reboot; then, the main grub entry I usually selected to boot into Garuda Linux was not there anymore. I booted into one of the snapshots I had and tried to restore, but it seemed to have no effects whatsoever. I tried a bunch of different things (it went worse at some point, no theme for grub ? No shutdown/reboot except with --force --force) but ended up repairing the grub menu, effectively restoring it to its “normal” state.
My laptop runs fine now, except that timeshift does not work anymore.
Let me clarify :

$ sudo timeshift --list --snapshot-device /dev/sda6

Mounted '/dev/sda6' at '/run/timeshift/155651/backup'
Device : /dev/sda6
UUID   : 66e9d8cf-32cd-4a0b-8442-2e159dd095fa
Path   : /run/timeshift/155651/backup
Mode   : BTRFS
Status : Selected snapshot device is not a system disk
Select BTRFS system disk with root subvolume (@)

No snapshots found

Booting from GRUB into a snapshot works

I had never tried Snapper Tools before, but there is nothing to create/restore, the create button does nothing, and clicking settings opens a pop-up saying something like “failed to load settings”.

I have checked the state of my btrfs from a live-booted Garuda:

[root@garuda-dr460nized garuda]# sudo btrfs check /dev/sda6

Opening filesystem to check...
Checking filesystem on /dev/sda6
UUID: 66e9d8cf-32cd-4a0b-8442-2e159dd095fa
[1/7] checking root items
[2/7] checking extents
[3/7] checking free space cache
[4/7] checking fs roots
root 257 inode 14602024 errors 1, no inode item
unresolved ref dir 9058071 index 75 namelen 36 name 0e3ef88c-5a3a-4def-a50c-aaba6bce83f9 filetype 2 errors 5, no dir item, no inode ref
unresolved ref dir 9058071 index 75 namelen 36 name 165dba37-eb77-42ea-8f40-ff94c3327c2f filetype 2 errors 2, no dir index
ERROR: errors found in fs roots
found 260101132288 bytes used, error(s) found
total csum bytes: 202373056
total tree bytes: 7059308544
total fs tree bytes: 6444089344
total extent tree bytes: 371851264
btree space waste bytes: 1252651084
file data blocks allocated: 4330142789632

I have not tried to --repair because it is not advised to be run without proper guidance.

Here is some more disk info:

$ mount | grep btrfs

/dev/sda6 on / type btrfs (rw,noatime,compress=zstd:3,ssd,discard=async,space_cache,subvolid=1222,subvol=/time
/dev/sda6 on /home type btrfs (rw,noatime,compress=zstd:3,ssd,discard=async,space_cache,subvolid=257,subvol=/@
/dev/sda6 on /root type btrfs (rw,noatime,compress=zstd:3,ssd,discard=async,space_cache,subvolid=258,subvol=/@
/dev/sda6 on /srv type btrfs (rw,noatime,compress=zstd:3,ssd,discard=async,space_cache,subvolid=259,subvol=/@s
/dev/sda6 on /var/cache type btrfs (rw,noatime,compress=zstd:3,ssd,discard=async,space_cache,subvolid=260,subv
/dev/sda6 on /var/log type btrfs (rw,noatime,compress=zstd:3,ssd,discard=async,space_cache,subvolid=261,subvol
/dev/sda6 on /var/tmp type btrfs (rw,noatime,compress=zstd:3,ssd,discard=async,space_cache,subvolid=262,subvol
/dev/sda6 on /run/BtrfsAssistant/66e9d8cf-32cd-4a0b-8442-2e159dd095fa type btrfs (rw,relatime,compress=zstd:3,
/dev/sda6 on /run/timeshift/162895/backup type btrfs (rw,relatime,compress=zstd:3,ssd,discard=async,space_cach

After all that, I am wondering if :

  • I am currently running some sort of snapshot ?
  • I could --repair my way out of this ?
    If not,
  • Should I start clean and reinstall a fresh Garuda ?

Thanks for reading !

Here is the required system info:

$ sudo garuda-inxi

Kernel: 6.6.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: hpet available: acpi_pm
parameters: BOOT_IMAGE=/timeshift-btrfs/snapshots/2023-11-16_19-04-09/@/boot/vmlinuz-linux-zen
root=UUID=66e9d8cf-32cd-4a0b-8442-2e159dd095fa rw
rootflags=subvol=timeshift-btrfs/snapshots/2023-11-16_19-04-09/@ quiet
splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3 ibt=off
Console: pty pts/2 wm: kwin_x11 DM: SDDM Distro: Garuda Linux
base: Arch Linux
Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X412DA_R424DA
v: 1.0 serial: <filter>
Mobo: ASUSTeK model: X412DA v: 1.0 serial: <filter>
UEFI: American Megatrends v: X412DA.316 date: 10/08/2021
ID-1: BAT0 charge: 23.6 Wh (98.7%) condition: 23.9/37.1 Wh (64.3%)
volts: 7.8 min: 7.8 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
status: not charging cycles: 979
Info: model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx socket: FP5
bits: 64 type: MT MCP arch: Zen/Zen+ note: check gen: 1 level: v3
note: check built: 2019 process: GF 12nm family: 0x17 (23)
model-id: 0x18 (24) stepping: 1 microcode: 0x8108109
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 384 KiB desc: d-4x32 KiB; i-4x64 KiB L2: 2 MiB desc: 4x512 KiB L3: 4 MiB
desc: 1x4 MiB
Speed (MHz): avg: 2100 min/max: 1400/2100 boost: enabled
base/boost: 2100/3700 scaling: driver: acpi-cpufreq governor: performance
volts: 1.2 V ext-clock: 100 MHz cores: 1: 2100 2: 2100 3: 2100 4: 2100
5: 2100 6: 2100 7: 2100 8: 2100 bogomips: 33537
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Device-1: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
vendor: ASUSTeK driver: amdgpu v: kernel arch: GCN-5 code: Vega
process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
ports: active: eDP-1 empty: HDMI-A-1 bus-ID: 02:00.0 chip-ID: 1002:15d8
class-ID: 0300 temp: 58.0 C
Device-2: IMC Networks USB2.0 HD UVC WebCam driver: uvcvideo type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-2.1:3
chip-ID: 13d3:56d3 class-ID: 0e02 serial: <filter>
Display: server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: fbdev,modesetting
alternate: vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 mapped: eDP model: BOE Display 0x07f6 built: 2018
res: 1920x1080 hz: 60 dpi: 158 gamma: 1.2 size: 309x174mm (12.17x6.85")
diag: 355mm (14") ratio: 16:9 modes: max: 1920x1080 min: 640x480
API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
device: 1 drv: swrast surfaceless: drv: radeonsi x11: drv: radeonsi
inactive: gbm,wayland
API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.2.1-arch1.2
glx-v: 1.4 direct-render: yes renderer: AMD Radeon Vega 8 Graphics (raven
LLVM 16.0.6 DRM 3.54 6.6.2-zen1-1-zen) device-ID: 1002:15d8
memory: 1.95 GiB unified: no
API: Vulkan v: 1.3.269 layers: 3 device: 0 type: integrated-gpu name: AMD
Radeon Vega 8 Graphics (RADV RAVEN) driver: mesa radv v: 23.2.1-arch1.2
device-ID: 1002:15d8 surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
(LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM
16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 02:00.1
chip-ID: 1002:15de class-ID: 0403
Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: snd_pci_acp3x
v: kernel alternate: snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x,
snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps, snd_sof_amd_renoir,
snd_sof_amd_rembrandt, snd_sof_amd_vangogh pcie: gen: 3 speed: 8 GT/s
lanes: 16 bus-ID: 02:00.5 chip-ID: 1022:15e2 class-ID: 0480
Device-3: AMD Family 17h/19h HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 02:00.6 chip-ID: 1022:15e3 class-ID: 0403
API: ALSA v: k6.6.2-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: JACK v: 1.9.22 status: off tools: N/A
Server-2: PipeWire v: 0.3.85 status: n/a (root, process) with:
1: pipewire-pulse status: active 2: wireplumber status: active
tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 bus-ID: 01:00.0 chip-ID: 8086:24fd class-ID: 0280
IF: wlp1s0 state: up mac: <filter>
Device-1: Intel Bluetooth wireless interface driver: btusb v: 0.8 type: USB
rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-2.2:4
chip-ID: 8087:0a2b class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: <filter> bt-v: 4.2 lmp-v: 8
status: discoverable: no pairing: no
Local Storage: total: 465.76 GiB used: 242.6 GiB (52.1%)
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WDS500G2B0B-00YS70 family: WD Blue / Red / Green SSDs
size: 465.76 GiB block-size: physical: 512 B logical: 512 B sata: 3.3
speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: 00WD temp: 33 C
scheme: GPT
SMART: yes state: enabled health: PASSED on: 156d 2h cycles: 3042
ID-1: / raw-size: 106.17 GiB size: 265.87 GiB (250.40%)
used: 242.55 GiB (91.2%) fs: btrfs block-size: 4096 B dev: /dev/sda6
maj-min: 8:6
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
used: 49.9 MiB (19.5%) fs: vfat block-size: 512 B dev: /dev/sda1
maj-min: 8:1
ID-3: /home raw-size: 106.17 GiB size: 265.87 GiB (250.40%)
used: 242.55 GiB (91.2%) fs: btrfs block-size: 4096 B dev: /dev/sda6
maj-min: 8:6
ID-4: /var/log raw-size: 106.17 GiB size: 265.87 GiB (250.40%)
used: 242.55 GiB (91.2%) fs: btrfs block-size: 4096 B dev: /dev/sda6
maj-min: 8:6
ID-5: /var/tmp raw-size: 106.17 GiB size: 265.87 GiB (250.40%)
used: 242.55 GiB (91.2%) fs: btrfs block-size: 4096 B dev: /dev/sda6
maj-min: 8:6
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 17.51 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8 dev: /dev/zram0
System Temperatures: cpu: 57.8 C mobo: N/A gpu: amdgpu temp: 57.0 C
Fan Speeds (rpm): cpu: 3000
Processes: 290 Uptime: 7m wakeups: 0 Memory: total: 20 GiB note: est.
available: 17.51 GiB used: 4 GiB (22.8%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 alt: 12
clang: 16.0.6 Packages: pm: dpkg pkgs: 0 pm: pacman pkgs: 2602 libs: 553
tools: pamac,paru Shell: garuda-inxi (sudo) default: Bash v: 5.2.21
running-in: konsole inxi: 3.3.31
Garuda (2.6.19-2):
System install date:     2021-10-27
Last full system update: 2023-11-24
Is partially upgraded:   No
Relevant software:       timeshift(custom) NetworkManager mkinitcpio
Windows dual boot:       Yes
Failed units:            adsl.service postgresql.service systemd-networkd-wait-online.service

Yes, you are currently booted off a snapshot. You need to restore the snapshot from Timeshift before rebooting.

If you are thinking of btrfs check --repair, that is not appropriate for this situation. That is for dealing with a damaged filesystem, where what you have is more of a configuration issue.

Dealer’s choice. :sunglasses:


Okay, thank you. I don’t know how on earth I branched into a snapshot but at least it worked ! Will do a reinstall when I’m done switching computers

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.