Btrfs assistant won't open in Garuda Welcome Menu


I have a question regarding opening BTRFS Assistant from the garuda welcome menu. when I try to open the application there it tells me i have to be the root user? however I can open the assistant from the command line and the application launcher just not from the garuda welcome menu. How can I fix this issue? I looked in the forum but I did not found any solution on it. could it be a bug?

3 Likes

That is because the way that Btrfs Assistant is opened changed and Garuda Welcome will need to be updated to reflect that.

Thanks for finding that.

5 Likes

no problem my friend

@dalto hey did you fix the issue already?? I noticed on the gitlab repo, you added a commit already

I did fix the issue right after you reported it. However, I didn't release a new version so the fix won't show up until someone does that.

That isn't an application I generally work on so I don't know what the process for a release on that one it.

3 Likes

Just update PKGBUILD and create a tag with the pkgver

Looks like @TNE updated it

6 Likes

Ihave not been able to start btrfs-assistant either. Previous post gave me an idea and here is the output after i clicked btrfs assistant in welcome.

[email protected] in ~
λ garuda-welcome
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.

(garuda-welcome:60767): Gtk-WARNING **: 07:14:35.391: Theme parsing error: gtk.css:5822:26: '-shadow' is not a valid color name

(garuda-welcome:60767): Gtk-WARNING **: 07:14:35.392: Theme parsing error: gtk.css:5825:14: not a number

(garuda-welcome:60767): Gtk-WARNING **: 07:14:35.392: Theme parsing error: gtk.css:5826:13: not a number

(garuda-welcome:60767): Gtk-WARNING **: 07:14:35.392: Theme parsing error: gtk.css:5827:11: Expected a length
QMetaObject::connectSlotsByName: No matching signal for on_buttonBigbluebutton_clicked()
"btrfs"
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
Failed to create wl_display (No such file or directory)
qt.qpa.plugin: Could not load the Qt platform plugin "wayland" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.

/usr/bin/btrfs-assistant: line 22: 60808 Aborted (core dumped) btrfs-assistant-bin ${params}

[email protected] in ~ took 21s
λ

That is a different issue.

Can we see the output of pacman -Q | grep -E "btrfs|welcome"

[email protected] in ~
λ pacman -Q | grep -E "btrfs|welcome"
btrfs-assistant-git 1.1.r24.g9af48e2-1
btrfs-progs 5.16.2-1
btrfsmaintenance 0.5-2
garuda-welcome 1.0.15-1
grub-btrfs 4.11-2
os-prober-btrfs 1.79-3

[email protected] in ~ took 12ms
λ

We should start by updating your system to get the latest version of the welcome application.

I get the same results after garuda update. I hadnt used the assistant for awhile but my settings are ok. I was just trying to help a bit. :slight_smile:

So I did this.

[email protected] in ~ as :mage: took 7s
[:zap:] × sudo btrfs-assistant
Failed to create wl_display (No such file or directory)
qt.qpa.plugin: Could not load the Qt platform plugin "wayland" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.

/usr/bin/btrfs-assistant: line 22: 66357 Aborted (core dumped) btrfs-assistant-bin ${params}

[email protected] in ~ as :mage: took 78ms
[:zap:] ×

Are you using sway? If not, what is your DE?

Hello again, I am using DE: GNOME 41.5 (Wayland) on 2 different machines and btrfs is not starting up on either. Both are up to date.

ps It has been apx. 2 months since I unset the defrag inbtrfs for SSDs.

I tested on Wayland Gnome a few days ago and was working fine. Let me stand up another VM and test again.

Seems to be working here:

Hi, I did a fresh install on an external ssd from an older iso image.
[email protected] in ~
λ sudo btrfs-assistant
[sudo] password for arthur:
("btrfs", "", "/")
("btrfs", "", "/home")
("btrfs", "", "/srv")
("btrfs", "", "/root")
("btrfs", "", "/var/cache")
("btrfs", "", "/var/log")
("btrfs", "", "/var/tmp")
("btrfs", "", "/tmp/{5d1243a5-db17-4646-b242-ef3848f1536d}")

[email protected] in ~ as :mage: took 30s

This worked until I closed the assistants gui.

Btrfs asst. works now after this latest update. good workings !

1 Like

Yes The update did fix on my end too, that's awesome. the garuda dev team does get things done quick. I'm impressed

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.