BTRFS assistant help

Hello.
So Its been few days now I have been using Garuda Linux and have pretty much set it up as to me liking so thought of taking a backup just in case. But found out that my BTRFS assistant does'nt have the Snapper and Snapper settings tabs in it. Also when I try to open BTRFS assistant through Garuda welcome > BTRFS asst > It say s- Application must run as super user so I manually type it in krunner and open it but those tabs are missing.

System:
Kernel: 5.17.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=0b3ee793-04a5-4396-a397-8dbad9c6feeb rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=684fccb6-7d6a-4eda-8875-5b25dc60d985 loglevel=3 i8042.nokbd
Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Hewlett-Packard product: HP Pavilion g6 Notebook PC
v: 0884110000385910000610100 serial: <superuser required> Chassis: type: 10
serial: <superuser required>
Mobo: Hewlett-Packard model: 183E v: 56.32 serial: <superuser required>
UEFI: Insyde v: F.22 date: 11/22/2012
Battery:
ID-1: BAT0 charge: 15.6 Wh (100.0%) condition: 15.6/15.6 Wh (100.0%)
volts: 12.3 min: 10.8 model: Hewlett-Packard Primary type: Li-ion
serial: N/A status: full
CPU:
Info: model: Intel Core i3-3110M bits: 64 type: MT MCP arch: Ivy Bridge
family: 6 model-id: 0x3A (58) stepping: 9 microcode: 0x21
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 1294 high: 1494 min/max: 1200/2400 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 1494 2: 1198 3: 1197
4: 1288 bogomips: 19156
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel 3rd Gen Core processor Graphics vendor: Hewlett-Packard
driver: i915 v: kernel ports: active: LVDS-1 empty: DP-1,HDMI-A-1,VGA-1
bus-ID: 00:02.0 chip-ID: 8086:0166 class-ID: 0300
Device-2: AMD Thames [Radeon HD 7500M/7600M Series]
vendor: Hewlett-Packard driver: radeon v: kernel alternate: amdgpu pcie:
gen: 1 speed: 2.5 GT/s lanes: 8 link-max: gen: 2 speed: 5 GT/s lanes: 16
bus-ID: 01:00.0 chip-ID: 1002:6840 class-ID: 0300
Device-3: Suyin HP TrueVision HD Integrated Webcam type: USB
driver: uvcvideo bus-ID: 2-1.5:3 chip-ID: 064e:e263 class-ID: 0e02
serial: <filter>
Display: x11 server: X.Org v: 1.21.1.3 compositor: kwin_x11 driver: X:
loaded: intel,radeon unloaded: modesetting alternate: fbdev,vesa gpu: i915
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
s-diag: 414mm (16.31")
Monitor-1: LVDS-1 mapped: LVDS1 model: LG Display 0x034d built: 2012
res: 1366x768 hz: 60 dpi: 102 gamma: 1.2 size: 340x190mm (13.39x7.48")
diag: 395mm (15.5") ratio: 16:9 modes: 1366x768
OpenGL: renderer: Mesa Intel HD Graphics 4000 (IVB GT2)
v: 4.2 Mesa 22.0.0 compat-v: 3.1 direct render: Yes
Audio:
Device-1: Intel 7 Series/C216 Family High Definition Audio
vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
chip-ID: 8086:1e20 class-ID: 0403
Sound Server-1: ALSA v: k5.17.1-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.49 running: yes
Network:
Device-1: Ralink RT3290 Wireless 802.11n 1T/1R PCIe vendor: Hewlett-Packard
driver: rt2800pci v: 2.3.0 pcie: gen: 1 speed: 2.5 GT/s lanes: 1
bus-ID: 07:00.0 chip-ID: 1814:3290 class-ID: 0280
IF: wlo1 state: down mac: <filter>
Device-2: Realtek RTL810xE PCI Express Fast Ethernet
vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 08:00.0 chip-ID: 10ec:8136
class-ID: 0200
IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>
Bluetooth:
Device-1: Ralink RT3290 Bluetooth vendor: Hewlett-Packard driver: N/A pcie:
gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 07:00.1 chip-ID: 1814:3298
class-ID: 0d11
Report: bt-service: enabled,stopped note: tool can't run
Drives:
Local Storage: total: 931.51 GiB used: 8.52 GiB (0.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM024 HN-M101MBB
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: 0001
scheme: GPT
Partition:
ID-1: / raw-size: 915.01 GiB size: 915.01 GiB (100.00%)
used: 8.52 GiB (0.9%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
used: 576 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 915.01 GiB size: 915.01 GiB (100.00%)
used: 8.52 GiB (0.9%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
ID-4: /var/log raw-size: 915.01 GiB size: 915.01 GiB (100.00%)
used: 8.52 GiB (0.9%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
ID-5: /var/tmp raw-size: 915.01 GiB size: 915.01 GiB (100.00%)
used: 8.52 GiB (0.9%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.66 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
ID-2: swap-2 type: partition size: 16 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/sda2 maj-min: 8:2
Sensors:
System Temperatures: cpu: 62.0 C mobo: N/A gpu: radeon temp: 54.5 C
Fan Speeds (RPM): N/A
Info:
Processes: 230 Uptime: 25m wakeups: 1 Memory: 7.66 GiB
used: 2.74 GiB (35.8%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 Packages: pacman: 1349 lib: 349 Shell: fish v: 3.4.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.14
Garuda (2.5.6-2):
System install date:     2022-04-01
Last full system update: 2022-04-01 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper (maybe)
Failed units:            bluetooth-autoconnect.service

So what I thought of reinstalling BTRFS assitant again through OCTOPI and here is the error

Installing selected packages...

****    
warning: grub-btrfs-4.11-2 is up to date -- reinstalling
warning: btrfs-assistant-1.1-1 is up to date -- reinstalling
warning: btrfs-progs-5.16.2-1 is up to date -- reinstalling
warning: os-prober-btrfs-1.79-3 is up to date -- reinstalling
warning: btrfsmaintenance-0.5-2 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...
Packages (5) btrfs-assistant8;5;243m-1.1-1 btrfs-progs8;5;243m-5.16.2-1 btrfsmaintenance8;5;243m-0.5-2 grub-btrfs8;5;243m-4.11-2 os-prober-btrfs8;5;243m-1.79-3
Download Size: 0.97 MiB
Installed Size: 5.79 MiB
Net Upgrade Size: 0.00 MiB

:: Retrieving packages...

(1/5) btrfs-progs-5.16.2-1-x86_64
(2/5) grub-btrfs-4.11-2-any
(3/5) os-prober-btrfs-1.79-3-x86_64
checking keys in keyring
checking package integrity
checking for file conflicts
checking available disk space

:: Processing package changes...

(1/5) reinstalling btrfs-progs
(2/5) reinstalling grub-btrfs
(3/5) reinstalling btrfs-assistant
(4/5) reinstalling os-prober-btrfs
(5/5) reinstalling btrfsmaintenance

:: Running post-transaction hooks...

Enabling os-prober...
Reloading system manager configuration...
Reloading device manager configuration...
Arming ConditionNeedsUpdate...
Updating linux initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux-zen.preset: 'default'
-> -k /boot/vmlinuz-linux-zen -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-zen.img
==> Starting build: 5.17.1-zen1-1-zen
-> Running build hook: [base]
-> Running build hook: [udev]
-> Running build hook: [autodetect]
-> Running build hook: dconf]
-> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: xhci_pci
-> Running build hook: [keyboard]
-> Running build hook: [keymap]
-> Running build hook: onsolefont]
-> Running build hook: [plymouth]
-> Running build hook: [resume]
-> Running build hook: [filesystems]
-> Running build hook: [grub-btrfs-overlayfs]
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-zen.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux-zen.preset: 'fallback'
-> -k /boot/vmlinuz-linux-zen -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-zen-fallback.img -S autodetect
==> Starting build: 5.17.1-zen1-1-zen
-> Running build hook: [base]
-> Running build hook: [udev]
-> Running build hook: dconf]
-> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: aic94xx
==> WARNING: Possibly missing firmware for module: bfa
==> WARNING: Possibly missing firmware for module: qed
==> WARNING: Possibly missing firmware for module: qla1280
==> WARNING: Possibly missing firmware for module: qla2xxx
==> WARNING: Possibly missing firmware for module: wd719x
==> WARNING: Possibly missing firmware for module: xhci_pci
-> Running build hook: [keyboard]
-> Running build hook: [keymap]
-> Running build hook: onsolefont]
-> Running build hook: [plymouth]
-> Running build hook: [resume]
-> Running build hook: [filesystems]
-> Running build hook: [grub-btrfs-overlayfs]
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-zen-fallback.img
==> Image generation successful
Refreshing PackageKit...
Foreign/AUR package notification
=> No foreign/AUR packages found.
Updating icon theme caches...
Orphaned package notification...
=> No orphans found.
Checking for .pacnew and .pacsave files...
m.pac* files found:
/etc/paru.conf.pacnew
mPlease check and merge
Updating the desktop file MIMtype cache...
Syncing all file systems...

Command finished OK!

has this has to something to do with the missing snapper tabs and settings.
Also below is the ss of the BTRFS assitant how it looks for me.

How? Install at 2022-04-01

On fresh install, you have no snapshots until you reboot. Or look again after your system update.

There is no error.
There are warnings for reinstalling.

4 Likes

Quick update after reinstalling it through octopi the snapper and snapper settings tabs are back. I'll check and try to backup hope it works.

But I'm now curious about the warning it gave me though while reinstalling. Any explanation for that

Just a hint.
What can one say to this?


2 Likes

Now I'm not able to select config in-order to create snap ?

Before you open a new help request, read relevant sections of the Arch and Garuda wiki.
Thoroughly search your issue and any error messages in the forum and on the web.

This is regarding the same BTRFS assitant and I was following

As shown here select root in config and proceed new snapshot but it doesnt allow me to select config why so?

check this.

2 Likes

Really thanks for helping me out here I'm pretty new to Linux just been a week now so have no knowledge of how things work still learning.
So I just checked the above post regarding the upcoming BTRFS so does that mean the one which I have is having some issues what exactly I'm extremely sorry for such stupid questions again.

What I'm looking for is how to use BTRFS assitant to take backup

  1. Should I first create a config in snapper settings as it doesn't allow me to select it.

    I haven't set it up I've just literally opened the asst. and trying to create snap
    How does it work ?

It would be great If you tell me the steps to use BTRFS asst please

So should I install and use Timeshift in the meanwhile ?

Here is what I did now created a config named it backup kept the rest settings as it is just changed the frequency of the backup. Now it lets me select the config and create a snapshot.
Also is there any settings I should change or enable please lemme know

Below is the snapshot I tried creating so is this how it's supposed to look but it doesn't show the size of the backup. Have I done it correctly?

If you can browse the snapshot as shown in your screenshot then it definitely worked.

Please keep in mind that a snapshot is not a backup in the fullest sense of the word. A snapshot will allow you to recover data from a prior point of time if it is changed. However, if you have hardware failure or filesystem corruption, it provides no protection from that because a snapshot lives inside the same filesystem.

As for the size, this is a big advantage of snapshots. Not only do they happen almost instantly, but they only use space for the amount of data that is unique to that snapshot. In other words, when you first take a snapshot, they are consuming almost no space. Later, after data has changed, they will slowly start consuming some space but only for the data that uniquely lives in that snapshot.

3 Likes

Yes, I'm able to browse through the drop-down and it has several folders and files.

So correct me if i've got it wrong ..does it work like a Create Restore point that we do in Windows. Where restoring to the previous selected point goes back to the earlier state say if we install something that messes up and we restore it's back to where we initially started . Sorry again i'ma just trying to understand the concept.

Yes, you could look at it that way. It is quite a bit more encompassing than a restore point though. The subvolume you snapshot can be restored to an identical state in it's entirety. Also, as you have seen you can easily browse through and restore individual files.

2 Likes

Is correct to set

backup path : / ?

  1. With this configuration BTRFS assistant create a .snapshot into / (the root)
    i.e. It create /.snapshot folder. Is it a rigth configuration?

  2. When I update the system (pacman -Syy) or I install a new package (pacman -S < new package >) pacman automaticaly create a new snapshot into
    /run/timeshift/backup/timeshift-btrfs/snapshots/

Is this the right folder for Backup path ?

Thanks,
hexis_nou

Yes.

:thinking:
While there is no reason you can't use both Snapper and Timeshift, they do the same thing so it doesn't make much sense. This is why you are getting snapshots in two different locations.

I would recommend either switching to Snapper or sticking with Timeshift and removing Snapper.

4 Likes

Thank you.
As I imagined I was a bit confused. Some days ago the upper pannel bar and button docker latte bar dissaperead. All my desktop configuration dissaperead. So I created a new configuration. I don't why, but now I have BTRFS assistant launcher instead of timeshit launcher in docker latte bar... and I did not understand to use an other program. Now I have discovered that BTRFS assistant ! = Timeshit.

Now I will try to understand how use snapper to create snapshot with snapper before pacman upgrade.
Any suggestion?

However, thank you very much for your patience!

You could install snapper-support. I believe that will replace timeshift with everything you need to automate snapper snapshots.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.