BTRFS Assistant - Call for testing

Yea, I realized when I saw the last time his ran.

Mine had hourlys going back 3ish days, but system hadn't missed a cleanup timer.
I dunno, it's fine since I resaved settings. I only mentioned here because "testing" and "thought" he was having similar issue.
Apologies for the (hopefully) false alarm and thanks for the help. :kissing_heart:

Ok so I just installed this to check it out, and I really like that it is its own application now and such, but I noticed unlike Garuda assistant it does not ask for a password. This seems like a pretty powerful tool to not need to ask for root privilege and instead just have it automatically.

It should ask for a password when you launch it via the desktop. If you launch it manually by running btrfs-assistant directly, it should fail to launch and tell you need to run it as root.

hmm then I am not sure what I did wrong then because for me it just automatically opens as root with no mention of a password through application dashboard. I know its opening up as a root application because it is not themed.

It is calling pkexec. Do you have some custom polkit rules?

This is what you should see:
image

Not that I know of. How do I check?

Do you have any files in /etc/polkit-1/rules.d

there was one named 49-nopasswd-live.rules that contains:

/* Stop asking the user for a password while they are in a live session
*/
polkit.addRule(function(action, subject) {
if (subject.user == "garuda")
{
return polkit.Result.YES;
}
});

but I am not in a live session nor is my username garuda.

You probably should delete that.

Done and still nothing. I tried deleting pkexec from kde menu editor and then I get "the must be run as a superuser" box just to see what happens, and then I tried typing in pkexec into terminal and the password box pops up so that also works, but pkexec btrfs-assistant by its self no password box lol.

Just did a roll back, and when booting into a snapshot, instead of the expected dialog asking if I'd like to restore it, I got one that simply says "The application must be run as root." with an option to click OK. After launching Btrfs Assistant manually and authenticating, however, the normal restore dialog appeared and I was able to restore with no issue.

OK, we found the rule that is causing this.

Yes, we are looking at that. The issue is the app is run as root so it can't take you to that menu until after it launches. We will either change the way it runs or pop a message box before launching the application.

4 Likes

So I found a bug? And in turn helped? yay!

2 Likes

Unable to launch latest version.
Only the last line should be relevant, the rest have always been there (having just checked with previous post here).

QMetaObject::connectSlotsByName: Connecting slot on_comboBox_btrfsdevice_activated() with the first of the following compatible signals: ("activated(int)", "activated(QString)")
QMetaObject::connectSlotsByName: No matching signal for on_checkBox_show_subvolume_clicked(bool)
QMetaObject::connectSlotsByName: Connecting slot on_comboBox_snapper_configs_activated() with the first of the following compatible signals: ("activated(int)", "activated(QString)")
QMetaObject::connectSlotsByName: Connecting slot on_comboBox_snapper_config_settings_activated() with the first of the following compatible signals: ("activated(int)", "activated(QString)")
QMetaObject::connectSlotsByName: No matching signal for on_checkBox_snapper_advanced_clicked(bool)
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
btrfs-assistant: Unexpected value after '--xdg-desktop'.

This occurs after authentication password submitted.
if I launch with sudo, it launches fine.

The latest version is a test version to fix a bug in i3wm, dmenu and rofi.

Nice that you have the same issue as me :slight_smile:

1 Like

I just wanted to report my previous issue with the not asking for a password is gone, it now has the pop-up showing up.

So should we remove this one if we have it installed? I tried to update my sytem, and it caused a conflict between it and the non git version when I tried to update the system.

Yes, you can remove it now

1 Like

Btfs-Assistant is instandly crashing for me (Since it was created): https://termbin.com/y7ff
Now that I have this problem snapshots are not working.
What should I do?

I just finished the next phase of development on BTRFS Assistant and it is ready for public testing.

Most of the changes are behind the scenes:

  • Significant code refactor to streamline and improve code and improve error handling
  • Added a configuration file to hold key values
  • Added more complete support for Btrfs maintenance which changed the layout of the UI and brought some new functionality
  • Made Btrfs maintenance an optional dependency

If you would like help with the testing effort, btrfs-assistant-git in the AUR will install the new version.

Please be careful with using this version on a production machine because the backend changes that were made could potentially have broken something I didn't surface in my testing.

As always, thanks for your assistance.

7 Likes