Browser sound keeps jumping back to 100%

Shortly after landing on the desktop and after the initial updates I launched Opera and adjusted it's volume to 60%, but after a second or two it's jumped back to 100%. I thought it might be something to do with JamesDPS cause Operas icon under had a lock on it that I've never seen before, so I uninstalled JamesDPS, logged out, ran Opera upon login and the lock on Opera's icon is now gone when I click the volume control app in the systray. However that did not fix Opera's sound jumping back to 100%. I just tested with Vivaldi and the sound is doing the exact same as with Opera. I have not had this issue with any other OS so I have to figure it is a Garuda issue. Any suggestions? Thanks

╭─[email protected] in ~  
╰─λ garuda-inxi
System:
Kernel: 5.17.4-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=4006dde4-6bac-4717-80cf-77ccd2da5135 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 wm: kwin_x11 vt: 1
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: ASUSTeK model: ROG STRIX B450-F GAMING v: Rev 1.xx
serial: <superuser required> UEFI: American Megatrends v: 4204
date: 01/28/2021
Battery:
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M325
serial: <filter> charge: 55% (should be ignored) rechargeable: yes
status: discharging
Device-2: hidpp_battery_1 model: Logitech Wireless Keyboard K360
serial: <filter> charge: 100% (should be ignored) rechargeable: yes
status: discharging
CPU:
Info: model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2
family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 32 MiB desc: 2x16 MiB
Speed (MHz): avg: 3604 high: 3885 min/max: 2200/4208 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3599 2: 3590
3: 3598 4: 3612 5: 3431 6: 3369 7: 3597 8: 3594 9: 3597 10: 3885 11: 3824
12: 3560 bogomips: 86400
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Retpolines, IBPB: conditional, STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA TU116 [GeForce GTX 1650 SUPER] vendor: eVga.com.
driver: nvidia v: 510.60.02 alternate: nouveau,nvidia_drm pcie: gen: 1
speed: 2.5 GT/s lanes: 8 link-max: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 08:00.0 chip-ID: 10de:2187 class-ID: 0300
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 2560x1080 s-dpi: 97 s-size: 670x283mm (26.38x11.14")
s-diag: 727mm (28.63")
Monitor-1: HDMI-0 res: 2560x1080 hz: 60 dpi: 97
size: 673x284mm (26.5x11.18") diag: 730mm (28.76") modes: N/A
OpenGL: renderer: NVIDIA GeForce GTX 1650 SUPER/PCIe/SSE2
v: 4.6.0 NVIDIA 510.60.02 direct render: Yes
Audio:
Device-1: NVIDIA TU116 High Definition Audio vendor: eVga.com.
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 8
link-max: lanes: 16 bus-ID: 08:00.1 chip-ID: 10de:1aeb class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0b:00.4 chip-ID: 1022:1487 class-ID: 0403
Sound Server-1: ALSA v: k5.17.4-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.50 running: yes
Network:
Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 03:00.0
chip-ID: 8086:1539 class-ID: 0200
IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 20.7 TiB used: 11.54 TiB (55.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: WD Blue SN570 500GB size: 465.76 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 234100WD temp: 33.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: MZNTY128HDHP-000L1
size: 119.24 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 3L0Q scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: Seagate
model: Expansion HDD size: 7.28 TiB block-size: physical: 4096 B
logical: 512 B type: N/A serial: <filter> rev: 1801 scheme: GPT
ID-4: /dev/sdc maj-min: 8:32 type: USB vendor: Seagate
model: ST330006 51NS size: 2.73 TiB block-size: physical: 4096 B
logical: 512 B type: N/A serial: <filter> rev: 7101 scheme: GPT
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
ID-5: /dev/sdd maj-min: 8:48 type: USB vendor: Seagate
model: ST8000AS0002-1NA17Z size: 7.28 TiB block-size: physical: 4096 B
logical: 512 B type: HDD rpm: 5980 serial: <filter> scheme: GPT
ID-6: /dev/sde maj-min: 8:64 type: USB vendor: PNY model: USB 3.0 FD
size: 115.38 GiB block-size: physical: 512 B logical: 512 B type: N/A
serial: <filter> rev: PMAP scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
ID-7: /dev/sdf maj-min: 8:80 type: USB vendor: Seagate
model: ST3000DM 001-1E6166 size: 2.73 TiB block-size: physical: 4096 B
logical: 512 B type: N/A serial: <filter> rev: 7101 scheme: GPT
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 20.7 GiB (17.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 20.7 GiB (17.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 20.7 GiB (17.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 20.7 GiB (17.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 23.45 GiB used: 2.2 MiB (0.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 42.0 C mobo: 32.0 C gpu: nvidia temp: 40 C
Fan Speeds (RPM): cpu: 1300 case-1: 0 case-2: 0 case-3: 0 gpu: nvidia
fan: 0%
Power: 12v: 9.97 5v: N/A 3.3v: N/A vbat: 3.18
Info:
Processes: 392 Uptime: 17m wakeups: 9 Memory: 23.45 GiB
used: 4.44 GiB (19.0%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 Packages: pacman: 1931 lib: 549 flatpak: 0 Shell: fish v: 3.4.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.15
Garuda (2.6.2-1):
System install date:     2022-04-27
Last full system update: 2022-04-27
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:            bluetooth-autoconnect.service

These kind of statements are not useful when making a request for help, (as you should be well aware from interactions in the past). Please refrain from making such accusatory statements unless you have verifiable proof to back it up.

Don't start returning to your old ways or this won't be profitable for anyone.

2 Likes

Fair enough I'll clarify. I've haven't run into this issue in other OS installs including past Garuda installs. The current issue seems to be a Garuda issue or something that comes with Garuda. We can eliminate JamesDSP cause I uninstalled it to see if maybe it was the problem and the problem persist.

Now a question about the lock icon that JamesDSP puts on the Opera and Vivaldi volume slider. Is it for locking the volume where I have it set at for them?

This is not entirely true, because of its relative newness I'm not familiar with where any/all config files could be present. Depending on how you uninstalled the program there could still be a leftover config file or a change that was not reverted that is causing issues.

I've have seen JamesDSP before installing for a friend who wanted Garuda. This same ISO actually and his hardware is the same as mine and he never got the issue. I'm going to test with FireDragon to see if possibly a Chromium based browser issue, cause everything else that I've set the volume for keeps my settings.

Good day,

Just did a fresh install with the new ISO, landed on the desktop, whet through the setup assistant, rebooted, launched Vivaldi and Opera adjusted their volume, browsed a bit in each, checked their volume setting and they were where I set them at, closed both, relaunch each and volume for both of them back at 100%. As I said before there is something that doesn't like my sound hardware or my sound hardware doesn't like something. Is there something I can run or install and run to maybe see what is causing the browser's volume to be increased? Thanks

EDIT:

Just tested Firedragon and on launch it's set to 63%. I adjusted it down to 38%, closed and relaunched and it was back at 63%.

OK did one more trouble shooting step and that was to replace pipewire witrh paulseaudio to see if maybe that was the issue. It's not cause I did the same test mentioned above and got the same results.

Are all your web browsers configured to load the same website at launch? Also have you tested the audio output that it is actually outputting 100% and not displaying artificial unit.

Vivaldi opens 4 pages at launch, Opera and Firefox only open two. If by artificial unit you mean a false reading? If so I know it's correct cause I can distinctly here the volume difference. When I launch the browser.

YATZEE!! looks like after switch from pipewire to pulse all I needed was a restart. I just launched Vivaldi, adjusted the volume, checked a few sites, closed and relaunched Vivaldi and the volume stayed at the level I put it at. Just did the same with Opera and same results. At this point I have to figure it's something with the hardware pipewire doesn't like. Fixed now. Appreciate the input from both of you.

2 Likes

Awesome glad its working!

2 Likes

Cool beans. You just learned the first rule of trouble-shooting. May it serve you well! :smiley: :happy_dance:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.