Brightness to decrease to bare minimum

I want to decrease the brightness to very less for night time reading. I can change the colour to yellow night mode. But I want to decrease the brightness very much to almost 2-3%

In Windows earlier it can be done with Adrenaline GUI by AMD
I searched everywhere. "Radeon profiles" I found. Is there any way to decrease it very much for nightime
Hardware button minimum 1 is also too much. so i can't use control from panel on monitor

I know we need to give up some convenience in linux. But I am asking any way to acheive desired result in linux also
Monitor S22E360
GPU AMD RX580 4GB Sapphire

System:
Kernel: 5.18.11-hardened1-1-hardened arch: x86_64 bits: 64 compiler: gcc
v: 12.1.0 parameters: pti=on page_alloc.shuffle=1
BOOT_IMAGE=/@/boot/vmlinuz-linux-hardened
root=UUID=10b3e5d1-0274-4dc2-aaa2-ae6daa1710d0 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 amdgpu.dc=0
Console: pty pts/1 wm: kwin_x11 DM: SDDM Distro: Garuda Linux
base: Arch Linux
Machine:
Type: Desktop Mobo: Micro-Star model: B450M PRO-VDH (MS-7A38) v: 4.0
serial: <filter> UEFI: American Megatrends v: M.C0 
CPU:
Info: model: AMD Ryzen 5 1600 socket: AM4 bits: 64 type: MT MCP arch: Zen
built: 2017-19 process: GF 14nm family: 0x17 (23) model-id: 1 stepping: 1
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB
L3: 16 MiB desc: 2x8 MiB
Speed (MHz): avg: 3343 high: 3400 min/max: N/A base/boost: 3400/3700
volts: 1.2 V ext-clock: 100 MHz cores: 1: 3400 2: 3400 3: 3400 4: 3400
5: 3400 6: 3400 7: 2721 8: 3400 9: 3400 10: 3400 11: 3400 12: 3400
bogomips: 81626
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Retpolines, IBPB: conditional, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
vendor: Sapphire driver: amdgpu v: kernel arch: GCN 4 process: GF 14nm
built: 2016-20 pcie: gen: 3 speed: 8 GT/s lanes: 16 ports:
active: HDMI-A-1 empty: DP-1, DP-2, DVI-D-1, HDMI-A-2 bus-ID: 29:00.0
chip-ID: 1002:67df class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: HDMI-A-1 mapped: HDMI-A-0 model: Samsung S22E360
serial: <filter> built: 2016 res: 1920x1080 hz: 60 dpi: 102 gamma: 1.2
size: 477x268mm (18.78x10.55") diag: 547mm (21.5") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
OpenGL: renderer: AMD Radeon RX 580 Series (polaris10 LLVM 14.0.6 DRM
3.46 5.18.11-hardened1-1-hardened)
v: 4.6 Mesa 22.1.3 direct render: Yes
Audio:
Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
vendor: Sapphire driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s
lanes: 16 bus-ID: 29:00.1 chip-ID: 1002:aaf0 class-ID: 0403
Device-2: AMD Family 17h HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 2b:00.3 chip-ID: 1022:1457 class-ID: 0403
Sound Server-1: ALSA v: k5.18.11-hardened1-1-hardened running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.55 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: f000 bus-ID: 25:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp37s0 state: up speed: 100 Mbps duplex: full mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
Bluetooth:
Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
driver: btusb v: 0.8 bus-ID: 1-9:2 chip-ID: 0a12:0001 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Drives:
Local Storage: total: 1.36 TiB used: 56.25 GiB (4.0%)
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Crucial model: CT500P1SSD8
size: 465.76 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: P3CR010
temp: 44.9 C scheme: GPT
SMART: yes health: PASSED on: 316d 2h cycles: 3,357
read-units: 46,447,210 [23.7 TB] written-units: 40,472,303 [20.7 TB]
ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD10EZEX-00MFCA0 family: Blue size: 931.51 GiB block-size:
physical: 4096 B logical: 512 B sata: 3.1 speed: 6.0 Gb/s type: HDD
rpm: 7200 serial: <filter> rev: 1A01 temp: 30 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 322d 21h cycles: 3406
Partition:
ID-1: / raw-size: 375.53 GiB size: 375.53 GiB (100.00%)
used: 56.22 GiB (15.0%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p5
maj-min: 259:5
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
used: 25.5 MiB (26.6%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
maj-min: 259:1
ID-3: /home raw-size: 375.53 GiB size: 375.53 GiB (100.00%)
used: 56.22 GiB (15.0%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p5
maj-min: 259:5
ID-4: /var/log raw-size: 375.53 GiB size: 375.53 GiB (100.00%)
used: 56.22 GiB (15.0%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p5
maj-min: 259:5
ID-5: /var/tmp raw-size: 375.53 GiB size: 375.53 GiB (100.00%)
used: 56.22 GiB (15.0%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p5
maj-min: 259:5
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.58 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 45.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 1682
Info:
Processes: 331 Uptime: 1m wakeups: 0 Memory: 15.58 GiB
used: 2.08 GiB (13.3%) Init: systemd v: 251 default: graphical
tool: systemctl Compilers: gcc: 12.1.0 clang: 14.0.6 Packages: pacman: 1721
lib: 430 Shell: garuda-inxi (sudo) default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.19
Garuda (2.6.5-1):
System install date:     2022-05-25
Last full system update: 2022-07-18
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Yes
Snapshots:               Snapper
Failed units:            dev-binderfs.mount anbox-container-manager.service

Usually the easiest brightness controls are on your monitor, but i'm aware that some restrict the backlight intensity to between certain values/percentages. Does yours it go down low enough to be satisfactory? I'm assuming not if you're posting here, but i figured i'd ask to get it out of the way.

1 Like

The ArchWiki article on this topic is plenty robust; have a read through and take a crack at some of the interventions they suggest. If you get stumped, update the thread with what you have tried so far so we can take a look.

https://wiki.archlinux.org/title/backlight

1 Like

$ yay xbacklight

optional:

$xbacklight -list-devices
$ sudo xbacklight -set 10

if you see

No outputs have backlight property

then try xacpilight, if that fails --
this often will only work on laptop (DM0) screens I've found, and at least the 3 I've tried it on, it only will allow -set x=5*2 so only 5-10-15-20%+ you can go over 100 too. remember led strips themselves are only translucent :slight_smile:

$xbacklight -set 5

if that fails, then try launching Garuda assistant,click qwikaccess, then you can sometimes get the display practically down to its bare minimum brightness+, which youre not crazy, is dimmer 5% and is likely the minimum power the backlights can take.

source: used to work in led industry although not stamped lcd like tv and computer screens.

Obviously No

It is computer screen. Samsung 22 inch monitor ss22e360. connected using HDMI from graphics card as no integrated graphics on ryzen 1600

Ok assuming you meant somewhere to say that no software fix is working for you still, are you sure the monitor is set to 0 brightness? Contrast under 80 begins to desaturate images too much, but will lower the overall lumens a small amount in addition. Other settings that can allow even lower brightness: color mode: manual - set R/G/B all to 0, on most monitors this will be as low as the gamut allows without completely blacking the screen. Remember there's actually a backlight but also the individual LEDs have a, in simple terms, an opacity-gradient curve to them as well (OLEDs used to claim glory of the greatest contrast ratios until pure RGB laser cluster projectors frrom Barco came around.)

I want to reemphasize that all Monitor settings have been tried completely and thoroughly from panel control buttons. Brightness 0 Contrast 0 RGB 0 Color tone etc have been checked. The way to decrease it was with AMD Adrenaline GUI software in Windows. So I am not sure if there is any open source stuff on Linux or not for achieving similar function

sudo xbacklight -set 5
No outputs have backlight property

xacpilight
xacpilight: command not found

What about using the brightness controls found from Garuda Welcome > Qwikaccess? For some reason these seem to allow only my laptop screen, and not an HDMI-connected display to reach brightness levels even below xbacklight -set 5. Also, have you tried installing the package 'screen', and seeing if that enables xbacklight to work?

Ok So the Qwikaccess package was missing for my system. I installed it. It is doing the job but not perfectly, colours are a little washed. But it is OK for me.

The problem now is it interferes with my Reading mode yellow. It keep switching reading mode on and off on its own. and also makes it more yellow/ decrease the color temperature

BUT IT Does decrease the brightness to more less like I wanted

Ok, what GPU are you using? If NVIDIA, try running

sudo nvidia-settings

Then find your monitor and look for something to the effect of 'color correction' and either increase the saturation slightly (or digitall vibrance if that's an option), you can also try setting the gamma >1.00. Remember to hit the "Confirm selection button" it's on like a 10 second timer. Also take note that if you power cycle the monitor, these settings will reset (I believe you could save an xconfig file for a permanent change). Glad I could help!

That's why we always want to have the garuda-inxi, so we don't have to guess.

2 Likes

GPU AMD RX580 4GB Sapphire

I think this is the only way

No offense intended here sir, but was it you, or the Pre-formatted Text (Ctrl+E) terminal output forum function that highlighted the 470?

We can see that, while inxi is certainly useful (and serial-skimmers/ADD mess' like myself end up asking dumb questions.... unless one were to know that/if GF 14nm, gen 3, speed 8 GT/s, and 16 lanes is specific to only the RX580, then his inxi served only to show he
s using an AMD Sapphire Ellesmere chip GPU...

@johnson

Qwikaccess certainly can lower the brightness, but it's going to wash out the colors unless we can increase the saturation and simultaneously lower the gamma. Do you see those options in the AMDCCCLE, or AMD Catalyst Control Center Linux Edition?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.