Bootloader problems

See first I tried to install garuda dual booting with windows ( including the bootloader)
But in the end, it would fail saying that bootloader would not install
Then I installed it without the bootloader
It then installed without a problem
But I was not able to boot into Garuda Linux
This is the live version of it
Please, someone, help me

try to use the install bootloader option in garuda boot repair.

Really @goyal why not @dr460nf1r3 ?

1 Like

i had the same issue. using ext4 fixed it for me. but i think the garuda boot repair will work.

Maybe, he is afraid of fire :rofl:

2 Likes

I did it but then this error

2020-11-28_18-22

I checked it was fine!


Please do not post pictures for a short text in the size of 1.9 MiB with the dimensions of 4160x3120 pixels.
greetings SGS

@goyal
Please, do not post pictures from Terminal output.
Copy and paste the text.
Howto

2 Likes

Some research resulted in this being a partition problem.
Multiple sources mention that GRUB doesnt have enough space to install, a possible solution would be resizing your first partition and leaving 1MB space in front of it. :thinking:

3 Likes

Weird. I finally got him to install bootloader by changing btrfs to ext4 and installing bootloader on system partition. Like with other threads I tried all permutations and combinations for him and this finally worked. Might be a btrfs issue. And it having troubles housing the bootloader.

Possibly correct, but it would help if there were more actual info, like

sudo fdisk -l

Not all cases are the same. Each mistake has a personality :stuck_out_tongue_winking_eye:

4 Likes

It mostly happens with people trying to dual boot I guess. It didn't happen to me in solo boot(technically not but erase disk on one disk). So could be btrfs acting weird in dual boots.

According to the posted error message (and no other info), this is at Archwiki

Old BTRFS prevents installation

If a drive is formatted with BTRFS without creating a partition table (eg. /dev/sdx), then later has partition table written to, there are parts of the BTRFS format that persist. Most utilities and OS's do not see this, but GRUB will refuse to install, even with --force

# grub-install: warning: Attempting to install GRUB to a disk with multiple partition labels. 
      This is not supported yet.. 
# grub-install: error: filesystem `btrfs' does not support blocklists.

You can zero the drive, but the easy solution that leaves your data alone is to erase the BTRFS superblock with wipefs -o 0x10040 /dev/sdx

3 Likes