Bootloader installation error when trying to install Garuda

I'm trying to install Garuda on my system and have done it successfully about a month ago but this time it keeps failing and gives this error

**Bootloader installation error **
Details:
The bootloader could not be installed. The installation command

grub-install --target=i386-pc --recheck --force /dev/sdc
returned error code 1.

I've been trying to resolve this since last night so here's few things that I've tried so far

  • Reinstalling after clearing partition(had to get gparted because windows wasn't allowed to clear garuda partition)

  • Clearing Garuda from the bootloader using this article because I thought clearing the bootloader would allow it to be reinstalled properly... It didnt work and now I have a ghost Garuda boot option when starting up and selecting it does nothing. I have a pic of it but not allowed to upload here yet because of new account.

  • Using Garuda Boot repair app from the live version to reinstall grub - This kept failing with error "cannot create chroot" ..I'm not sure what that means. I tried repairing it by selecting the partition created for Garuda instead and it succeeded but it still wont boot into the os. Honestly this one may just be due to the os not being installed correctly in the first place.

Let me know what I can do in this situation. I've never used Linux before this so have no idea what half of the errors mean but Garuda looks approachable enough to make me try moving away from windows.

I'm using the latest dr460nized gaming iso if that makes any difference.

Please boot from the live USB and provide your

garuda-inxi

and

lsblk -f
1 Like

Why?
You do not need install a rolling release more than one time.

If you clearing=remove grub with a win app, there is nothing on disk to repair from Garuda live ISO. It's just away.

garuda-inxi 
System:
Kernel: 5.18.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
misobasedir=garuda misolabel=GARUDA_DR460NIZEDGAMING_TALON quiet
systemd.show_status=1 driver=nonfree nouveau.modeset=0 i915.modeset=1
radeon.modeset=1
Desktop: KDE Plasma v: 5.25.3 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: Micro-Star model: B350 TOMAHAWK (MS-7A34) v: 1.0
serial: <superuser required> UEFI-[Legacy]: American Megatrends v: 1.M0
date: 01/23/2019
CPU:
Info: model: AMD Ryzen 7 1800X bits: 64 type: MT MCP arch: Zen
built: 2017-19 process: GF 14nm family: 0x17 (23) model-id: 1 stepping: 1
microcode: 0x8001137
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 768 KiB desc: d-8x32 KiB; i-8x64 KiB L2: 4 MiB desc: 8x512 KiB
L3: 16 MiB desc: 2x8 MiB
Speed (MHz): avg: 2962 high: 3033 min/max: 2200/3600 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 2963 2: 2963
3: 3033 4: 2955 5: 2973 6: 2960 7: 2840 8: 2962 9: 2976 10: 2964 11: 2963
12: 2974 13: 2972 14: 2967 15: 2965 16: 2966 bogomips: 115184
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Retpolines, IBPB: conditional, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GP104 [GeForce GTX 1060 6GB] vendor: Gigabyte
driver: nvidia v: 515.57 alternate: nouveau,nvidia_drm non-free: 515.xx+
status: current (as of 2022-06) arch: Pascal process: TSMC 16nm
built: 2016-21 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3
speed: 8 GT/s bus-ID: 1c:00.0 chip-ID: 10de:1b83 class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 81 s-size: 602x343mm (23.70x13.50")
s-diag: 693mm (27.28")
Monitor-1: DP-0 res: 1920x1080 hz: 60 dpi: 82
size: 598x336mm (23.54x13.23") diag: 686mm (27.01") modes: N/A
OpenGL: renderer: NVIDIA GeForce GTX 1060 6GB/PCIe/SSE2
v: 4.6.0 NVIDIA 515.57 direct render: Yes
Audio:
Device-1: NVIDIA GP104 High Definition Audio vendor: Gigabyte
driver: snd_hda_intel bus-ID: 3-4:4 v: kernel chip-ID: 1038:12b3 pcie:
gen: 3 class-ID: 0300 speed: 8 GT/s lanes: 16 bus-ID: 1c:00.1
chip-ID: 10de:10f0 class-ID: 0403
Device-2: AMD Family 17h HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 1e:00.3 chip-ID: 1022:1457 class-ID: 0403
Device-3: SteelSeries ApS Arctis 1 Wireless type: USB
driver: hid-generic,snd-usb-audio,usbhid
Sound Server-1: ALSA v: k5.18.12-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.55 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: f000 bus-ID: 19:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp25s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
driver: btusb v: 0.8 bus-ID: 1-3:2 chip-ID: 0a12:0001 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 8.43 TiB used: 0 KiB (0.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: WDS200T1X0E-00AFY0 size: 1.82 TiB block-size: physical: 512 B
logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 614900WD temp: 45.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST4000NE0025-2EW107
size: 3.64 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: EN02 scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 vendor: SanDisk model: SSD PLUS 240GB
size: 223.58 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 00RL scheme: GPT
ID-4: /dev/sdc maj-min: 8:32 vendor: Western Digital *(**Trying to install here**)*
model: WD10EZEX-08WN4A0 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
rev: 1A02 scheme: GPT
ID-5: /dev/sdd maj-min: 8:48 vendor: Seagate model: ST2000DM008-2FR102
size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: 0001 scheme: GPT
ID-6: /dev/sde maj-min: 8:64 type: USB vendor: Kingston
model: DataTraveler 3.0 size: 28.82 GiB block-size: physical: 512 B
logical: 512 B type: N/A serial: <filter> scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
Message: No partition data found.
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.57 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 44.2 C mobo: N/A gpu: nvidia temp: 58 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
Processes: 309 Uptime: 3m wakeups: 0 Memory: 15.57 GiB
used: 3.17 GiB (20.4%) Init: systemd v: 251 default: graphical
tool: systemctl Compilers: gcc: 12.1.0 Packages: pacman: 1800 lib: 507
Shell: fish v: 3.4.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.19
warning: database file for 'garuda' does not exist (use '-Sy' to download)
warning: database file for 'core' does not exist (use '-Sy' to download)
warning: database file for 'extra' does not exist (use '-Sy' to download)
warning: database file for 'community' does not exist (use '-Sy' to download)
warning: database file for 'multilib' does not exist (use '-Sy' to download)
warning: database file for 'chaotic-aur' does not exist (use '-Sy' to download)
Garuda (2.6.5-1):
System install date:     2022-07-28
Last full system update: 2022-07-28 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       <superuser required>
Snapshots:               Snapper
Failed units:            
McFly: Importing shell history for the first time. This may take a minute or two...done.
> lsblk -f
NAME FSTYPE FSVER LABEL                  UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
loop0
squash 4.0                                                                     0   100% /run/miso/sfs/livefs
loop1
squash 4.0                                                                     0   100% /run/miso/sfs/mhwdfs
loop2
squash 4.0                                                                     0   100% /run/miso/sfs/desktopfs
loop3
squash 4.0                                                                     0   100% /run/miso/sfs/rootfs
sda                                                                                          
├─sda1
│                                                                                            
└─sda2
ntfs         Big Boi NAS            26045ED9045EAB95                                    
sdb                                                                                          
├─sdb1
│    ntfs         Recovery               EE9A6FEE9A6FB22F                                    
├─sdb2
│    vfat   FAT32                        2670-9307                                           
├─sdb3
│                                                                                            
└─sdb4
ntfs                                782275D422759838                                    
sdc                                                                                          
├─sdc1
│
├─sdc2
│    btrfs                               43727342-3098-437b-a041-36f3978843c7
└─sdc3
ntfs         1T                     940A94200A93FE04
sdd
├─sdd1
│
└─sdd2
ntfs         2T                     48726621726613CA
sde  iso966 Jolie GARUDA_DR460NIZEDGAMING_TALON
2022-07-17-09-17-44-00                     0   100% /run/miso/bootmnt
├─sde1
│    iso966 Jolie GARUDA_DR460NIZEDGAMING_TALON
│                                        2022-07-17-09-17-44-00
└─sde2
vfat   FAT12 MISO_EFI               04A6-82CE
zram0
[SWAP]
nvme0n1

├─nvme0n1p1
│
└─nvme0n1p2
ntfs         2T M2                  928655FF8655E46F

because during last week I had cleared and removed the harddisk it was installed on

Is this reffering to the thing I did using that article? if thats the case then I dont understand why I still see an option to boot Garuda under that drive when opening the boot menu on startup. Not that it runs anyway but it could be preventing the install I guess? I can show you the pic when I'm eligible to upload or will try getting an imgur link

Check your BIOS.
Did you boot in Legacy mode or with CSM enabled?
Try to go full UEFI.

3 Likes

Stop booting in CSM/bios. The year is 2022 :stuck_out_tongue:

3 Likes

Sorry I'm not sure what this means, could you please explain?

Booting USB in UEFI and trying install now

CSM is Compatibility Support Module. You can read about it here

3 Likes

Apparantly the installation-script tries to install using CSM-mode. If not, the grub-command would be "grub-install --target=x86_64-efi", not "grub-install --target=i386-pc", as in your case.

That's also clear from your inxi:

Type: Desktop Mobo: Micro-Star model: B350 TOMAHAWK (MS-7A34) v: 1.0
serial: <superuser required> UEFI-[Legacy]: American Megatrends v: 1.M0
date: 01/23/2019

The "UEFI-[Legacy]" shows that. Otherwise there would be just "UEFI".

Boot into BIOS and search for the option to turn off CSM/legacy-mode. With an MSI-mainboard it should be under "Advanced -> Windows OS options" or something similar.

The option you see when booting the PC is a non-active entry from before. It doesn't mean anything anymore. When I was distrohopping I had multiple of those entries with no functionality whatsoever.

BTW, I would also considering updating your BIOS. https://www.msi.com/Motherboard/b350-tomahawk/support

Edit: I looked it up. The option to only use UEFI should be under "Settings -> Boot -> Boot Mode Select".

2 Likes

That worked! Many Thanks!

and thank you all for clearing up what CSM/UEFI is, I've disabled legacy+uefi and switched to only uefi now.

I see the latest update is a beta version, dont wanna risk anything so will wait for a stable one. But thanks for the reminder

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.