Bootloader install failed

This is my second time installing Garuda . No issues faced first time .
I have tried installing in brtfs and ext4 partitions but still the same error . Boot loader install failed error code 1 . I also tried to install grub with chroot grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Garuda --force
but gives no free space error but the partitions are fresh and empty . EFI partition too . Tried repairing with Garuda Boot repair software but it also gives error . My system is UEFI only and no CSM .
My efi partition , swap partition and root or / partition is on a ssd but home partition is on a hdd .

Kernel: 6.5.9-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: acpi_pm
parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
misobasedir=garuda root=miso:LABEL=GARUDA_DR460NIZEDGAMING_RAPTOR quiet
systemd.show_status=1 ibt=off driver=free nouveau.modeset=1
i915.modeset=1 radeon.modeset=1
Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: Dell product: Vostro 3491 v: N/A
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: Dell model: 073DJG v: A00 serial: <superuser required> UEFI: Dell
v: 1.28.0 date: 11/06/2023
ID-1: BAT0 charge: 25.8 Wh (100.0%) condition: 25.8/42.0 Wh (61.4%)
volts: 12.7 min: 11.4 model: SMP DELL VM73297 type: Li-poly serial: <filter>
status: full
Info: model: Intel Core i3-1005G1 bits: 64 type: MT MCP arch: Ice Lake
gen: core 10 level: v4 note: check built: 2019-21 process: Intel 10nm
family: 6 model-id: 0x7E (126) stepping: 5 microcode: 0xC2
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 160 KiB desc: d-2x48 KiB; i-2x32 KiB L2: 1024 KiB desc: 2x512 KiB
L3: 4 MiB desc: 1x4 MiB
Speed (MHz): avg: 1150 high: 3400 min/max: 400/3400 scaling:
driver: intel_pstate governor: powersave cores: 1: 400 2: 400 3: 400 4: 3400
bogomips: 9523
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel Iris Plus Graphics G1 vendor: Dell driver: i915 v: kernel
arch: Gen-11 process: Intel 10nm built: 2019-21 ports: active: eDP-1
empty: HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:8a56 class-ID: 0300
Device-2: Microdia [] driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s
lanes: 1 mode: 2.0 bus-ID: 1-6:4 chip-ID: 0c45:671e class-ID: 0e02
Display: x11 server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
s-diag: 414mm (16.31")
Monitor-1: eDP-1 model: AU Optronics 0xb68d built: 2019 res: 1366x768
hz: 60 dpi: 112 gamma: 1.2 size: 309x173mm (12.17x6.81") diag: 354mm (13.9")
ratio: 16:9 modes: 1366x768
API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
device: 1 drv: swrast surfaceless: drv: iris x11: drv: iris
inactive: gbm,wayland
API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.2.1-arch1.2
glx-v: 1.4 direct-render: yes renderer: Mesa Intel UHD Graphics (ICL GT1)
device-ID: 8086:8a56 memory: 14.99 GiB unified: yes
API: Vulkan v: 1.3.269 layers: 9 device: 0 type: integrated-gpu name: Intel
UHD Graphics (ICL GT1) driver: mesa intel v: 23.2.1-arch1.2
device-ID: 8086:8a56 surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
(LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM
16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Device-1: Intel Ice Lake-LP Smart Sound Audio vendor: Dell
driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_icl
bus-ID: 00:1f.3 chip-ID: 8086:34c8 class-ID: 0403
API: ALSA v: k6.5.9-zen2-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.83 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Dell driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
port: 3000 bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp1s0 state: down mac: <filter>
Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
vendor: Dell driver: ath10k_pci v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 bus-ID: 02:00.0 chip-ID: 168c:0042 class-ID: 0280
IF: wlp2s0 state: down mac: <filter>
Device-1: Qualcomm Atheros [] driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-10:5 chip-ID: 0cf3:e009
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.2
lmp-v: 8 status: discoverable: no pairing: no class-ID: 7c010c
Local Storage: total: 1.42 TiB used: 152.51 GiB (10.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: WD Blue SN570 500GB SSD size: 465.76 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 234110WD temp: 39.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 5400 serial: <filter> fw-rev: 1002 scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 vendor: SanDisk model: USB 3.2Gen1
size: 57.3 GiB block-size: physical: 512 B logical: 512 B type: USB rev: 3.2
spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: N/A serial: <filter>
fw-rev: 1.00 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Message: No partition data found.
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.35 GiB used: 46.8 MiB (0.3%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4
dev: /dev/zram0
ID-2: swap-2 type: partition size: 4.44 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p8 maj-min: 259:2
System Temperatures: cpu: 66.0 C mobo: 45.0 C
Fan Speeds (rpm): cpu: 3444
Processes: 187 Uptime: 12m wakeups: 2 Memory: total: 16 GiB note: est.
available: 15.35 GiB used: 2.36 GiB (15.4%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1812 libs: 524 tools: octopi,paru Shell: fish v: 3.6.1
running-in: konsole inxi: 3.3.30
warning: database file for 'garuda' does not exist (use '-Sy' to download)
warning: database file for 'core' does not exist (use '-Sy' to download)
warning: database file for 'extra' does not exist (use '-Sy' to download)
warning: database file for 'community' does not exist (use '-Sy' to download)
warning: database file for 'multilib' does not exist (use '-Sy' to download)
warning: database file for 'chaotic-aur' does not exist (use '-Sy' to download)
Garuda (2.6.17-1):
System install date:     2024-02-15
Last full system update: 2024-02-15 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       <superuser required>
Failed units:            snapper-cleanup.service

Since when does an installation on ext4 work with Garuda calamares?
Calamares does everything automatically.
Install Garuda with the live ISO from the terminal

sudo -E calamares -D8

and post the log if errors occur.

Install “normal” dragon, not gaming, use garuda-gamer after install, gaming is sometimes buggy.

Same error with btrfs

I forgot to mention that I got same error in non gaming edition and I have verified sha256 and I am using custom partitioning method


ok will try and reply

No pics from terminal!!!

Maybe use LTS version.

Same error as visible in the photo and this time I used Replace partition option . It created a btrfs and efi partition on its own from a given partition .
And in LTS version LTS kernel is there right ? Any other differences ?


 Target cmd: ("grub-install", "--target=x86_64-efi", "--efi-directory=/boot/efi", "-bootloader-id-Garud

a", "--force") Exit code: 1 output: Installing for x86_64-efi platform.

Could not prepare Boot variable: No space left on device

grub-install: error: efibootmgr failed to register the boot entry: Input/output error.

WARNING: [PYTHON JOB]: "Command 'grub-install-target-x86_64-efi-efi-directory=/boot/efi-bootloader-id-Ga

ruda-force' returned non-zero exit status 1."

[PYTHON JOB]: "stdout: Installing for x86_64-efi platform.\nCould not prepare Boot variable: No space left on d evice\ngrub-install: error: efibootmgr failed to register the boot entry: Input/output error.

[PYTHON JOB]: "stderr: None"

18:45:30 [6]: virtual void Calamares :: JobThread :: run()

Skipping non-emergency job "postcfg"

Skipping non-emergency job "Unmount file systems."

18:45:30 [1]: void Calamares:: ViewManager::onInstallationFailed(const QString&, const QString&) ERROR: Installation failed: "Bootloader installation error"

message: "Bootloader installation error"

details: The bootloader could not be installed. The installation command <pre>grub-install-target-x

86_64-efi-efi-directory=/boot/efi -bootloader-id=Garuda -force</pre> returned error code 1. 18:45:30 [6]: void Calamares:: ViewManager::onInstallationFailed(const QStrings, const QStrings)

Calamares will quit when the dialog closes.

18:45:30 [6]: void Config:: doNotify(bool, bool) Notification not sent; completion: failed

Same error on LTS version

It says you have no space left in your efi directory. Check


and remove old os entries that you have uninstalled. Remember to be a little careful here don’t touch anything you don’t recognize.
It’s very easy to use efibootmgr read it’s man or search web.

I have created a totally new EFI 300MB partition and gave it /boot/efi mountpoint and boot flag. It has a lot of space . I mentioned the same in my post too

but gives no free space error but the partitions are fresh and empty . EFI partition too

Forgive me I can see how my statement can create confusion. I meant the efi variables in nvram. It’s present on motherboard. That’s what the efibootmgr affects. This is different from the FAT32 /boot/efi partition of your disk.

I removed unwanted boot entries ( there were only 2 unwanted )but I have had a lot of entries in the past with no issues . There is only 1 boot entry now which is windows boot manager but still same issue .

Solution : Garuda Installation failed, bootloader installation error - #25 by FOUR_7777

Follow steps 6-9 in chroot from live usb . step 8 may give error ( ignore it) . Then after reboot do step 1-5 ( using chroot from live usb ) . Then do step 8 and 9 using ( chroot ) . If garuda doesn’t boot reinstall it . This time you wont get any error .

This worked for me .

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.