Booting problem on lenovo thinkbook

ı have a lenovo thinkbook 15 g2 ARE notebook and ı wanted to install a linux distribution. I tried to install garuda kde. I downloaded garuda-dr460nized-linux-zen-220329.iso.
I flashed it using 3 programme (rufus, balena and ventoy ) but ı can't boot it.
bios mode: UEFİ
secure boot disabled
also ı have an old notebook which support uefi and when ı use the flashed usb with this laptop ı can boot and installed garuda

ı faced this problem with ventoy garuda os booting problem
it gets stuck on the same screen it never starts

with balena etcher I faced an error

Also when tried other linux distributions ı could not boot. I gues this problem is about my bios setting.

Have you tried using a different USB drive?

1 Like

Welcome :slight_smile:
Fastboot is off too?

Check arch wiki for your Lenovo model. You need maybe the correct name.


Did you check sha256sum?

Oops , red mark is wrong.

1 Like

yes ı have two usb drive and ı tried

there is an information about my notebook model in arch wiki "Tested Mar 2021 with Linux 5.10.19" Laptop/Lenovo - ArchWiki
also in my bios settings there is no option about fast boot
ı don't know about sha256sum.

Have you checked this setting in the BIOS?

1 Like

Unfortunately, the bios in the itl model and mine are different.

You disable fastboot in Windows.


This should be done when you download an ISO to confirm it downloaded intact--sometimes it does not (packet loss, or otherwise).

1 Like

I did it and disabled in windows but it didn't help

oh tanks for explaining but actually I don't think there is a problem with the iso file as I tried it on two different laptops using the same iso. I was able to successfully install on the old notebook.

1 Like

Does your BIOS have an "enable USB" option, or any option that mentions USB for that matter?

1 Like


yes and its enabled I can boot my computer via usb. I can also access the garuda os start screen. The trouble starts after this stage, I think there is a problem with the kernel, I haven't been able to solve it yet. all other linux distributions do not boot in the same way.

This seems very unlikely to me. I think this hardware should be supported.

Let's back up a second:

Can you describe specifically the setting you changed? You have to change the default power management settings to do this correctly. This is a crucial detail.

1 Like

windows 11
control panel >>> hardware and sound >>> power options >>> system stettings
then clicked change setting that are currently unavailable
last turn off fast boot in the shut down settings

1 Like

That sounds right! Are you starting from a cold boot? (As opposed to a reboot)

There's gotta be something else in the BIOS. Any settings you are not sure what they are? Maybe you can snap a few photos of the options you have and link them in your photo bucket.

ı'll do it in a few minutes
edit:there is a power outage in the area where i live, i will try to get back as soon as possible

Another thing you could do is to try some kernel boot parameters. There might be many to try, you could start searching on the internet for booting problems with your model.
Push E in the open source driver GRUB line and add the boot parameter at the end of the line starting with linux.
I'd start with iommu=soft

1 Like

all my bios settings: bios - Google Drive