Booting and Calamares Issues Garuda Hyprland

If i choose pt keyboard or portuguese language the login always fails, but that doesn’t happen in english keyboard and us-english language. Im only able to enter the liveos envrioment that way. When i go to install the calamares installer doesn-t open.
Here is my garuda-inxi:

  Kernel: 6.5.9-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us
    tz=Europe/Lisbon misobasedir=garuda
    root=miso:LABEL=GARUDA_HYPRLAND_RAPTOR quiet systemd.show_status=1
    ibt=off driver=free nouveau.modeset=1 i915.modeset=1 radeon.modeset=1
  Desktop: Hyprland info: waybar vt: 1 dm: SDDM Distro: Garuda Linux
    base: Arch Linux
  Type: Laptop System: HP product: OMEN by HP Laptop 16-c0xxx v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: HP model: 8902 v: 89.62 serial: <superuser required> UEFI: AMI
    v: F.22 date: 10/12/2023
  ID-1: BAT0 charge: 61.3 Wh (100.0%) condition: 61.3/61.3 Wh (100.0%)
    volts: 17.0 min: 15.4 model: HP Primary type: Li-ion serial: <filter>
    status: full cycles: 72
  Info: model: AMD Ryzen 7 5800H with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 3 gen: 4 level: v3 note: check built: 2021-22
    process: TSMC n7 (7nm) family: 0x19 (25) model-id: 0x50 (80) stepping: 0
    microcode: 0xA50000F
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 545 high: 2729 min/max: 400/4463 scaling:
    driver: amd-pstate-epp governor: powersave cores: 1: 400 2: 400 3: 400
    4: 400 5: 400 6: 400 7: 2729 8: 400 9: 400 10: 400 11: 400 12: 400 13: 400
    14: 400 15: 400 16: 400 bogomips: 102212
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
  Device-1: AMD Navi 23 [Radeon RX 6600/6600 XT/6600M] vendor: Hewlett-Packard
    driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm)
    built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: none
    empty: DP-1,HDMI-A-1 bus-ID: 03:00.0 chip-ID: 1002:73ff class-ID: 0380
  Device-2: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
    vendor: Hewlett-Packard driver: amdgpu v: kernel arch: GCN-5 code: Vega
    process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s ports: active: eDP-1 empty: DP-2
    bus-ID: 09:00.0 chip-ID: 1002:1638 class-ID: 0300 temp: 47.0 C
  Device-3: Chicony [] driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s
    lanes: 1 mode: 2.0 bus-ID: 1-3:2 chip-ID: 04f2:b735 class-ID: fe01
    serial: <filter>
  Display: wayland server: v: with: Xwayland v: 23.2.2
    compositor: Hyprland driver: X: loaded: amdgpu unloaded: modesetting,radeon
    alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: 1
  Monitor-1: eDP-1 model: BOE Display 0x0aae built: 2021 res: 1920x1080
    hz: 144 dpi: 137 gamma: 1.2 scale: 1 size: 355x200mm (13.98x7.87")
    diag: 407mm (16") ratio: 16:9 modes: max: 1920x1080 min: 640x480
  API: Vulkan v: 1.3.269 layers: 3 device: 0 type: integrated-gpu name: AMD
    Radeon Graphics (RADV RENOIR) driver: mesa radv v: 23.2.1-arch1.2
    device-ID: 1002:1638 surfaces: xcb,xlib,wayland device: 1
    type: discrete-gpu name: AMD Radeon RX 6600M (RADV NAVI23)
    driver: mesa radv v: 23.2.1-arch1.2 device-ID: 1002:73ff
    surfaces: xcb,xlib,wayland device: 2 type: cpu name: llvmpipe (LLVM
    16.0.6 256 bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM 16.0.6)
    device-ID: 10005:0000 surfaces: xcb,xlib,wayland
  API: EGL Message: EGL data requires eglinfo. Check --recommends.
  Device-1: AMD Navi 21/23 HDMI/DP Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 03:00.1 chip-ID: 1002:ab28 class-ID: 0403
  Device-2: AMD Renoir Radeon High Definition Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 09:00.1 chip-ID: 1002:1637
    class-ID: 0403
  Device-3: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Hewlett-Packard
    driver: snd_rn_pci_acp3x v: kernel alternate: snd_pci_acp3x, snd_pci_acp5x,
    snd_pci_acp6x, snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps,
    snd_sof_amd_renoir, snd_sof_amd_rembrandt pcie: gen: 3 speed: 8 GT/s
    lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 09:00.5
    chip-ID: 1022:15e2 class-ID: 0480
  Device-4: AMD Family 17h/19h HD Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 09:00.6 chip-ID: 1022:15e3
    class-ID: 0403
  API: ALSA v: k6.5.9-zen2-1-zen status: kernel-api tools: N/A
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 0.3.83 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: f000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: eno1 state: down mac: <filter>
  Device-2: Realtek RTL8852AE 802.11ax PCIe Wireless Network Adapter
    vendor: Hewlett-Packard driver: rtw89_8852ae v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 05:00.0 chip-ID: 10ec:8852
    class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  Device-1: Realtek [] driver: btusb v: 0.8 type: USB rev: 1.0 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 1-4:3 chip-ID: 0bda:2852 class-ID: e001
    serial: <filter>
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.2
    lmp-v: 11 status: discoverable: no pairing: no class-ID: 6c010c
  Local Storage: total: 2.82 TiB used: 0 KiB (0.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Seagate
    model: XPG GAMMIX S70 BLADE size: 1.86 TiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 3.2.F.83 temp: 36.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:4 vendor: Micron
    model: MTFDHBA1T0TDV-1AZ1AABHA size: 953.87 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: HPS0032 temp: 31.9 C scheme: GPT
  ID-3: /dev/sda maj-min: 8:0 vendor: SMI (STMicroelectronics) model: USB
    size: 29.3 GiB block-size: physical: 512 B logical: 512 B type: USB rev: 3.0
    spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: N/A serial: <filter>
    fw-rev: 1100 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Message: No partition data found.
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 30.7 GiB used: 0 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
  System Temperatures: cpu: 63.5 C mobo: N/A
  Fan Speeds (rpm): fan-1: 0 fan-2: 0
  GPU: device: amdgpu temp: 50.0 C mem: 50.0 C fan: 0 watts: 5.00
    device: amdgpu temp: 47.0 C
  Processes: 365 Uptime: 23m wakeups: 2 Memory: total: 32 GiB note: est.
  available: 30.7 GiB used: 4.4 GiB (14.4%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
  pm: pacman pkgs: 1239 libs: 356 tools: paru,trizen Shell: fish v: 3.6.1
  running-in: alacritty inxi: 3.3.30
Garuda (2.6.17-1):
  System install date:     2023-12-07
  Last full system update: 2023-12-07 ↻
  Is partially upgraded:   Yes
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       <superuser required>
  Failed units:            snapper-cleanup.service

The calamares error:

Process 15873 (calamares) of user 0 dumped core.

Stack trace of thread 15873:
#0  0x00007f2ffab7e83c n/a ( + 0x8e83c)
#1  0x00007f2ffab2e668 raise ( + 0x3e668)
#2  0x00007f2ffab164b8 abort ( + 0x264b8)
#3  0x00007f2ffb0140c2 _ZNK14QMessageLogger5fatalEPKcz ( + 0xa00c2)
#4  0x00007f2ffb5eb402 _ZN22QGuiApplicationPrivate25createPlatformIntegrationEv ( + 0x13f402)
#5  0x00007f2ffb5eba79 _ZN22QGuiApplicationPrivate21createEventDispatcherEv ( + 0x13fa79)
#6  0x00007f2ffb20fc05 _ZN23QCoreApplicationPrivate4initEv ( + 0x29bc05)
#7  0x00007f2ffb5ebb26 _ZN22QGuiApplicationPrivate4initEv ( + 0x13fb26)
#8  0x00007f2ffc81ab9e _ZN19QApplicationPrivate4initEv ( + 0x175b9e)
#9  0x0000555eb3386eed _ZN20CalamaresApplicationC2ERiPPc (calamares + 0x17eed)
#10 0x0000555eb3384f95 main (calamares + 0x15f95)
#11 0x00007f2ffab17cd0 n/a ( + 0x27cd0)
#12 0x00007f2ffab17d8a __libc_start_main ( + 0x27d8a)
#13 0x0000555eb3385c55 _start (calamares + 0x16c55)

Stack trace of thread 15884:
#0  0x00007f2ffabf2f6f __poll ( + 0x102f6f)
#1  0x00007f2ff8f33276 n/a ( + 0xb8276)
#2  0x00007f2ff8ed3162 g_main_context_iteration ( + 0x58162)
#3  0x00007f2ffb25ef7c _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE ( + 0x2eaf7c)
#4  0x00007f2ffb20ee74 _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE ( + 0x29ae74)
#5  0x00007f2ffb06b4f6 _ZN7QThread4execEv ( + 0xf74f6)
#6  0x00007f2ffa13aa9a n/a ( + 0x18a9a)
#7  0x00007f2ffb06771a n/a ( + 0xf371a)
#8  0x00007f2ffab7c9eb n/a ( + 0x8c9eb)
#9  0x00007f2ffac007cc n/a ( + 0x1107cc)
ELF object binary architecture: AMD x86-64

I tried both rufus and etcher to install the bootable iso, same result.

Hi :slight_smile:
Maybe my script failed?

You can change the language after installed with en in .config/hypr/hyprland.conf

kb_layout =

but use at first a simple password like 123 to avoid keyboard problems.

It may no diff. but use ventoy :slight_smile:


thanks for reply, problem is the garuda installer (calamares) doesn’t open what shall i do for that? I used ventoy now the problem remains, and this re some errors in log:

IDK :frowning:
Can you use from terminal

sudo -E calamares -D8



Thanks it seems to be running in the terminal :wink: let me complete the installation and if everything goes well i will tell u to close the topic


After the installation, the login doesn’t work when enter my password and enter or log in with mouse it blackout for a second, and returns to the login area, and my password is only numbers :sob:
This is what happens:

It’s a shame, since there’s no Nvidia GPU involved, I don’t know where the problem is.
Please, try TTY3, login and use


if work, use upd in terminal.

1 Like

The output of tty3:

I checked if the hyperland was updated and it is…
Also checked the conf file for plugins it doesnt seem to have any

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.