Boot on Gigabyte ga-f2a88xn-wifi

Hello Community! So happy to be back into a linux distro after many, many years away.
I have a particular issue regarding my install.
My desktop won't load the live usb Garuda i've created. I have tried every option but once it gets past Ventoy nothing happens.

A buddy let me borrow his tower and I was able to successfully install Garuda and i'm typing in it now!
However when I attempt to put my HDD back into my tower it won't get past the first splash screen. I'm assuming it's most likely due to the video drivers.

He has an NVIDIA GTX as you should see in the output below.
I have an NVIDIA Quadro K1200

I thought about putting my GPU into his tower and re-installing and hoping the installer picks the right one but i'm not sure if that is a good option.

Has anyone had a similar experience?

Obligatory output - however keep in mind this is from my buddy's tower, not my own.:

Kernel: 6.2.13-zen-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=31ddc345-0928-456b-bf48-5c86e845ba38 rw rootflags=subvol=@
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.4 tk: Qt v: 5.15.9 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Type: Desktop System: Hewlett-Packard product: HP Compaq Elite 8300 CMT
v: N/A serial: <superuser required> Chassis: type: 3
serial: <superuser required>
Mobo: Hewlett-Packard model: 3396 serial: <superuser required>
UEFI: Hewlett-Packard v: K01 v02.05 date: 05/07/2012
Device-1: hidpp_battery_0 model: Logitech Wireless Touch Keyboard K400
serial: <filter> charge: 55% (should be ignored) rechargeable: yes
status: discharging
Info: model: Intel Core i7-3770 bits: 64 type: MT MCP arch: Ivy Bridge
gen: core 3 level: v2 built: 2012-15 process: Intel 22nm family: 6
model-id: 0x3A (58) stepping: 9 microcode: 0x21
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 3252 high: 3400 min/max: 1600/3400 scaling:
driver: intel_cpufreq governor: performance cores: 1: 3400 2: 3400 3: 3400
4: 3400 5: 2247 6: 3372 7: 3400 8: 3400 bogomips: 54277
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
Vulnerabilities: <filter>
Device-1: NVIDIA TU116 [GeForce GTX 1650 SUPER] vendor: ASUSTeK
driver: nouveau v: kernel non-free: 530.xx+ status: current (as of 2023-03)
arch: Turing code: TUxxx process: TSMC 12nm FF built: 2018-22 pcie: gen: 1
speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s ports:
active: HDMI-A-1 empty: DP-1,DVI-D-1 bus-ID: 01:00.0 chip-ID: 10de:2187
class-ID: 0300 temp: 23.0 C
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
compositor: kwin_x11 driver: X: loaded: modesetting,nouveau
alternate: fbdev,nv,vesa dri: nouveau gpu: nouveau display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: HDMI-A-1 mapped: HDMI-1 model: Samsung S23B300 serial: <filter>
built: 2012 res: 1920x1080 hz: 60 dpi: 96 gamma: 1.2
size: 510x287mm (20.08x11.3") diag: 585mm (23") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
API: OpenGL v: 4.3 Mesa 23.0.3 renderer: NV168 direct-render: Yes
Device-1: Intel 7 Series/C216 Family High Definition Audio
vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
chip-ID: 8086:1e20 class-ID: 0403
Device-2: NVIDIA TU116 High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16
link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.1 chip-ID: 10de:1aeb
class-ID: 0403
API: ALSA v: k6.2.13-zen-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.70 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel 82579LM Gigabit Network vendor: Hewlett-Packard
driver: e1000e v: kernel port: f040 bus-ID: 00:19.0 chip-ID: 8086:1502
class-ID: 0200
IF: eno1 state: down mac: <filter>
Device-2: Realtek RTL88x2bu [AC1200 Techkey] type: USB driver: rtw_8822bu
bus-ID: 2-1.2:4 chip-ID: 0bda:b812 class-ID: 0000 serial: <filter>
IF: wlp0s26u1u2 state: up mac: <filter>
Local Storage: total: 524.5 GiB used: 7.4 GiB (1.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 EVO 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 3B6Q scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: SanDisk model: Cruzer Glide
size: 58.73 GiB block-size: physical: 512 B logical: 512 B type: N/A
serial: <filter> rev: 1.00 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
ID-1: / raw-size: 465.46 GiB size: 465.46 GiB (100.00%) used: 7.4 GiB (1.6%)
fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 7.4 GiB (1.6%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 7.4 GiB (1.6%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 7.4 GiB (1.6%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.56 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 42.0 C mobo: N/A gpu: nouveau temp: 23.0 C
Fan Speeds (RPM): N/A gpu: nouveau fan: 820
Processes: 246 Uptime: 8m wakeups: 2 Memory: 15.57 GiB
used: 1.95 GiB (12.5%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 1783
libs: 517 tools: octopi,paru Shell: fish v: 3.6.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.26
Garuda (2.6.16-1):
System install date:     2023-09-02
Last full system update: 2023-09-02
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       Probably (Run as root to verify)
Failed units:

Is it the same Ventoy stick you used to install on your friend’s computer?

Check that your computer is ready to take the installation:

  • Disable fastboot and secure boot. It may not be possible to disable the latter explicitly - try clearing the secure boot keys instead. Check the manual of your device/motherboard for further info.
  • Make sure that your device’s SATA controller is set to AHCI mode in your device’s setup utility. Otherwise, the Linux kernel may not be able to detect your drive.
  • If your firmware supports UEFI then configure your device to use UEFI only in its setup utility. UEFI is much preferred over BIOS whenever possible.


What splash screen do you see? Are you getting to Grub?

If you are getting to Grub, try booting the fallback image. If you are not, it is probably because that computer does not have any EFI variables for this installation, or secure boot is enabled, or it is a BIOS machine, etc etc.

I don’t think so, the drivers have not been installed yet according to that inxi. It’s running the GPU on the drivers built in to the kernel, which should be fine for either GPU.


Thank you for the quick reply.

Yes, it is the same live USB, I have confirmed on my BIOS that fastboot is disabled, secureboot isn't an option i can disable and I am using AHCI mode

I am getting to grub, I have attempted the failover boot, but it will give me the starting line at the top then a few lines down there are two blinking underscores. It sits on this screen, I have left it for a few hours and went about my day and came back to the same screen.

Interestingly the live usb does the about the same thing. I can pick normal mode or grub2 mode then i have the option of open source or nvidia drivers and both give me just about the same screen in the above line.
I have previously used ubuntu on this machine but it's been many, many years.

Disabling secure boot is not optional I’m afraid. You won’t be able to get past the bootloader if secure boot is enabled.

If it does not appear you can disable secure boot, you may need to clear the secure boot keys as mentioned here:

1 Like

I've cleared the secure boot keys and the issue remains.
I can get to the screen saying Loading ramdisk...

It will remain here indefinitely.

Now that the secure boot keys have been cleared, test again booting to the live environment with the Ventoy stick.

1 Like

Thank you, stepping away for dinner I will test this when I return.

Tested again, same issue. I have played with the BIOS settings a bit, my motherboard has some weird windows 8 configurations in particular. I've tried every option and unfortunately the issue remains.

I'm really hoping i can find someone with something that may helps before i go the route of replacing the motherboard and maybe processor with it.

I now believe it's a bios issue based on the comment that drivers are not even loaded.

I attempted to load into Garuda Recovery and got the following:

0.375983 ERROR: Unable to locate IOAPIC for GSI 56
AMD-Vi: IOMMU0: Failed to initializa IOMU Hardware (error-19)
ohci-pci 0000:00:13.0: frame counter not updating; disabled
ohci-pci 0000:00:13.0: HC died; cleaning up
usb 1-1: device descriptor read/64, error-110
ata3: softreset failed (1st FID failed)

At this point it loops at the error-110

If you have an IOMMU configuration option, experiment with enabling/disabling it to see if it affects the boot process.

That is certainly possible. Check to see if there is an update for the BIOS available from the vendor’s website.

Another thing to try is a different USB drive. I realize the one you have is working fine on your friend’s machine, but oddly sometimes certain USB sticks will work as boot media for some computers but not others for no obvious reason.


Issue is resolved.

I disabled IOMMU and it worked.

If anyone has Gigabyte ga-f2a88xn-wifi motherboard and runs into this problem this worked for me.

Happy you got it solved.
I marked the suggestion above as "solution", because this is usually what we do, rather than marking the "implementati on".

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.