Boot from usb issue

Hello !

I installed garuda for the first time two month ago to try it.

but i want to remove it and back to windows, but the problem is i can't access the boot menu i pressed keys from F1 to F12 & del,Esc, End , nothing happend couldn't boot from the usb.

I tried to change garuda boot options but it didn't save the changes .

I'm not new to linux and still learning about it, it may be silly question but thanks in advance!

  Kernel: 6.4.3-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=9f0aeda6-d708-4bfa-9d37-db4adab4ee08 rw rootflags=subvol=@
    quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
  Desktop: GNOME v: 44.3 tk: GTK v: 3.24.38 wm: gnome-shell dm: GDM v: 44.1
    Distro: Garuda Linux base: Arch Linux
  Type: Desktop Mobo: Gigabyte model: PA65-UD3-B3 serial: <superuser required>
    BIOS: Award v: F6 date: 04/28/2011
  Info: model: Intel Core i7-2600 bits: 64 type: MT MCP arch: Sandy Bridge
    gen: core 2 level: v2 built: 2010-12 process: Intel 32nm family: 6
    model-id: 0x2A (42) stepping: 7 microcode: 0x2F
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 3524 high: 3800 min/max: 1600/3800 scaling:
    driver: intel_cpufreq governor: performance cores: 1: 3800 2: 3800 3: 1597
    4: 3800 5: 3800 6: 3800 7: 3800 8: 3800 bogomips: 54281
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: AMD Cedar [Radeon HD 5000/6000/7350/8350 Series] vendor: Hightech
    Information System driver: radeon v: kernel alternate: amdgpu
    arch: TeraScale-2 code: Evergreen process: TSMC 32-40nm built: 2009-15
    pcie: gen: 2 speed: 5 GT/s lanes: 16 ports: active: VGA-1
    empty: DVI-I-1,HDMI-A-1 bus-ID: 01:00.0 chip-ID: 1002:68f9 class-ID: 0300
    temp: 58.5 C
  Display: wayland server: v: with: Xwayland v: 23.1.2
    compositor: gnome-shell driver: gpu: radeon display-ID: 0
  Monitor-1: VGA-1 model: Dell E1914H serial: <filter> built: 2014
    res: 1366x768 dpi: 85 gamma: 1.2 size: 410x230mm (16.14x9.06")
    diag: 470mm (18.5") ratio: 16:9 modes: max: 1366x768 min: 720x400
  API: OpenGL v: 4.5 Mesa 23.1.3 renderer: AMD CEDAR (DRM 2.50.0 /
    6.4.3-zen1-1-zen LLVM 15.0.7) direct-render: Yes
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
    vendor: Gigabyte 6 driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:1c20 class-ID: 0403
  Device-2: AMD Cedar HDMI Audio [Radeon HD 5400/6300/7300 Series]
    vendor: Hightech Information System driver: snd_hda_intel v: kernel pcie:
    gen: 2 speed: 5 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 1002:aa68
    class-ID: 0403
  API: ALSA v: k6.4.3-zen1-1-zen status: kernel-api with: aoss
    type: oss-emulator tools: N/A
  Server-1: PipeWire v: 0.3.73 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Ralink RT2561/RT61 802.11g PCI driver: rt61pci v: 2.3.0
    bus-ID: 06:03.0 chip-ID: 1814:0301 class-ID: 0280
  IF: wlp6s3 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: de00 bus-ID: 08:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp8s0 state: down mac: <filter>
  IF-ID-1: wlp7s0u1 state: up mac: <filter>
  Local Storage: total: 988.82 GiB used: 84.89 GiB (8.6%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: SanDisk model: USB 3.2Gen1
    size: 57.3 GiB block-size: physical: 512 B logical: 512 B type: USB rev: 2.1
    spd: 480 Mb/s lanes: 1 mode: 2.0 speed: 3.0 Gb/s tech: N/A
    serial: <filter> fw-rev: 1.00
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WD10EARS-00MVWB0 size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 3.0 Gb/s tech: N/A serial: <filter> fw-rev: AB51
    scheme: MBR
  ID-1: / raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
    used: 80.41 GiB (8.6%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
  ID-2: /home raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
    used: 80.41 GiB (8.6%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
  ID-3: /var/log raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
    used: 80.41 GiB (8.6%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
  ID-4: /var/tmp raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
    used: 80.41 GiB (8.6%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 7.74 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 38.0 C mobo: N/A gpu: radeon temp: 58.5 C
  Fan Speeds (RPM): N/A
  Processes: 283 Uptime: 46m wakeups: 0 Memory: total: 8 GiB
  available: 7.74 GiB used: 2.99 GiB (38.7%) Init: systemd v: 253
  default: graphical tool: systemctl Compilers: gcc: 13.1.1 Packages:
  pm: pacman pkgs: 1365 libs: 463 tools: pamac,paru Shell: fish v: 3.6.1
  default: Bash v: 5.1.16 running-in: gnome-terminal inxi: 3.3.28
Garuda (2.6.16-1):
  System install date:     2023-06-17
  Last full system update: 2023-07-14
  Is partially upgraded:   Yes
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       <superuser required>
  Failed units:

restarted to try garuda boot menu i pressed C to access grub nothings happened, giving me the login screen.
Thanks again.

just boot to your UEFI settings from grub and make your USB the highest priority in boot order.

Thank you for giving Garuda Linux a try! We understand that it might not have been the right fit for everyone. We hope you had a decent experience exploring our community. Should you ever consider returning or have questions in the future, don't hesitate to reach out.


Thank you so much for the fast reply i really appreciate it. yes for sure !

Booting with Secure Boot Enabled | Solus Help Center (

not sure this would help, but for me this worked and I was able to register the cer file into my secure boot bios, so now that new solus 4.4 boots right into it, anyway this is not an arch linux, but maybe someway we will see arch linux using the same type of method, but I am not sure about all laptops and desktops, but I tried this on one laptop and two desktops and registering the .cer file has fixed at least these in able to boot with secure boot on, if that's something that might help you. both my desktop's are gigabyte pc's Z690 AORUS MASTER (rev. 1.x) running windows 11 for my epic games,
xbox games app in windows and ubisoft assassins creed games that I also play in windows, which can somewhat be used in linux but I only tested it in USB bootup live mode, I didn't install it on my newer pc for now I want to use just windows, for example my cooler master case, doesn't have any linux software for the LED lights on the case, and my older gigabyte is G1.Assassin 2 (rev. 1.0) Intel® X79 Chipset, that a few years old, this method for secure boot works for them and my laptop is an ASUS brand Republic of Gamers laptop. was able to run gnome solus with nvidia software mode feature in the bootloader, and plasma boots right into kde or plasma, and; budge Solus doesn't like my nvidia 3D card that iso didn't boot with rufus because of the rtx 2070 3D card in the G1.Assassin 2 (rev. 1.0) desktop.


Thank you so much!
everything helps , i have been using arch but didn't face much problems.
this pc just for testing new things and playing games , the main one is acer using arch on it.

I played on linux it's been great but some games won't even open or me have problems with it.
so for now better back to windows on this one, and keep linux on my laptop.
i didn't know about solus before but i will try it for sure.
thank you again for your time.

Solus and Arch-based sometimes don't play well together. The Solus distribution is new, has had a few internal problems, and has had a hard time keeping the doors open. That said, they have some very knowledgeable, hard-working folks on their team. They just released updated ISOs again after a dry spell.:slight_smile:

1 Like

I didn't know about solus until yesterday , still downloading it gonna try after it finished.
i tried many things but nothing works.
Thank you so much for the reply!

I installed Solus budgie , I only need to install windows now.
Thanks a lot !

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.