Boot error : "[TIME] Timed out waiting for device/dev/nvme1n1p3."

Here is the all error:

[TIME] Timed out waiting for device/dev/nvme1n1p3.
[DEPEND] Dependency failed for /mnt/data.
[DEPEND] Dependency failed for Local File Systems.
You are in emergency mode. After logging in, type "journalctl -xb" to view system logs, "systemctl reboot" to reboot, or 'exit"
to continue bootup.
Give root password for maintenance
(or press Control-D to continue):

I’m getting one of this error in my 4 or 5 boot try.

garuda-inxi :

Kernel: 6.8.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc avail: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=0e332757-bef1-44e8-9ff8-b2cf404aab56 rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.0.2 tk: Qt v: N/A info: frameworks v: 6.0.0
wm: kwin_wayland vt: 1 dm: SDDM Distro: Garuda base: Arch Linux
v: Type1Version serial: <superuser required> Chassis: Quanta type: 10
v: Type3Version serial: <superuser required>
Mobo: CASPER BILGISAYAR SISTEMLERI model: NLXB 001 v: Type2Version
serial: <superuser required> part-nu: EXCALIBUR G870 NLXB
uuid: <superuser required> UEFI: CASPER BILGISAYAR SISTEMLERI v: CQ111
date: 04/17/2023
ID-1: BAT0 charge: 56.7 Wh (99.5%) condition: 57.0/63.0 Wh (90.6%)
volts: 17.1 min: 15.1 model: CB Primary type: Li-ion serial: N/A
status: not charging
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M560
serial: <filter> charge: 55% (should be ignored) rechargeable: yes
status: discharging
Info: model: 12th Gen Intel Core i5-12450H bits: 64 type: MST AMCP
arch: Alder Lake gen: core 12 level: v3 note: check built: 2021+
process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 3
microcode: 0x432
Topology: cpus: 1x cores: 8 mt: 4 tpc: 2 st: 4 threads: 12 smt: enabled
cache: L1: 704 KiB desc: d-4x32 KiB, 4x48 KiB; i-4x32 KiB, 4x64 KiB
L2: 7 MiB desc: 4x1.2 MiB, 1x2 MiB L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 737 high: 3261 min/max: 400/4400:3300 scaling:
driver: intel_pstate governor: powersave cores: 1: 657 2: 611 3: 1123 4: 400
5: 400 6: 400 7: 3261 8: 400 9: 400 10: 400 11: 400 12: 400
bogomips: 59904
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel Alder Lake-P GT1 [UHD Graphics] vendor: QUANTA driver: i915
v: kernel alternate: xe arch: Gen-12.2 process: Intel 10nm built: 2021-22+
ports: active: eDP-1 empty: DP-1 bus-ID: 00:02.0 chip-ID: 8086:46a3
class-ID: 0300
Device-2: NVIDIA AD107M [GeForce RTX 4060 Max-Q / Mobile] vendor: QUANTA
driver: nvidia v: 550.67 alternate: nouveau,nvidia_drm non-free: 545.xx+
status: current (as of 2024-02) arch: Lovelace code: AD1xx
process: TSMC n4 (5nm) built: 2022+ pcie: gen: 1 speed: 2.5 GT/s lanes: 8
link-max: gen: 4 speed: 16 GT/s bus-ID: 01:00.0 chip-ID: 10de:28a0
class-ID: 0300
Device-3: Quanta USB webcam driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-6:3 chip-ID: 0408:209d
class-ID: 0e02 serial: <filter>
Display: wayland server: v: with: Xwayland v: 23.2.4
compositor: kwin_wayland driver: X: loaded: modesetting,nvidia
unloaded: nouveau alternate: fbdev,intel,nv,vesa dri: iris
gpu: i915,nvidia display-ID: 0
Monitor-1: eDP-1 res: 1920x1080 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
drv: nvidia device: 2 drv: iris device: 3 drv: swrast surfaceless:
drv: nvidia wayland: drv: iris x11: drv: iris inactive: gbm,device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 24.0.3-arch1.2
glx-v: 1.4 direct-render: yes renderer: Mesa Intel Graphics (ADL GT2)
device-ID: 8086:46a3 memory: 30.36 GiB unified: yes display-ID: :1.0
API: Vulkan v: 1.3.279 layers: 4 device: 0 type: integrated-gpu name: Intel
Graphics (ADL GT2) driver: mesa intel v: 24.0.3-arch1.2
device-ID: 8086:46a3 surfaces: xcb,xlib,wayland device: 1
type: discrete-gpu name: NVIDIA GeForce RTX 4060 Laptop GPU driver: nvidia
v: 550.67 device-ID: 10de:28a0 surfaces: xcb,xlib,wayland device: 2
type: cpu name: llvmpipe (LLVM 17.0.6 256 bits) driver: mesa llvmpipe
v: 24.0.3-arch1.2 (LLVM 17.0.6) device-ID: 10005:0000
surfaces: xcb,xlib,wayland
Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: QUANTA
driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl
bus-ID: 00:1f.3 chip-ID: 8086:51c8 class-ID: 0401
Device-2: NVIDIA vendor: QUANTA driver: snd_hda_intel v: kernel pcie:
gen: 4 speed: 16 GT/s lanes: 8 bus-ID: 01:00.1 chip-ID: 10de:22be
class-ID: 0403
API: ALSA v: k6.8.2-zen1-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 1.0.4 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:51f0 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
vendor: QUANTA RTL8111/8168/8411 driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 05:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp5s0 state: down mac: <filter>
Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-10:4 chip-ID: 8087:0026
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: <filter> bt-v: 5.2 lmp-v: 11
status: discoverable: no pairing: no
Local Storage: total: 1.36 TiB used: 912.97 GiB (65.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:5 vendor: Crucial model: CT500P3SSD8
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: P9CR30A temp: 37.9 C
scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Western Digital
model: WD BLACK SN770 1TB size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 731120WD temp: 34.9 C scheme: GPT
ID-1: / raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 30.06 GiB (6.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:7
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 584 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:6
ID-3: /home raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 30.06 GiB (6.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:7
ID-4: /var/log raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 30.06 GiB (6.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:7
ID-5: /var/tmp raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 30.06 GiB (6.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:7
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 31.09 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12 dev: /dev/zram0
System Temperatures: cpu: 43.0 C mobo: N/A
Fan Speeds (rpm): N/A
Memory: total: 32 GiB note: est. available: 31.09 GiB used: 4.12 GiB (13.3%)
Processes: 341 Power: uptime: 2m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 12.39 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: pm: pacman pkgs: 1432 libs: 415 tools: octopi,paru Compilers:
gcc: 13.2.1 Shell: garuda-inxi default: fish v: 3.7.0 running-in: konsole
inxi: 3.3.33
Garuda (2.6.23-1):
System install date:     2024-03-28
Last full system update: 2024-03-28
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       Probably (Run as root to verify)
Failed units:

If I be able to boot the system I’m using it problem-free.

Please edit your original request with proper formatting fields (use the text formatting function </> from the top text bar). The “” marks are not doing anything.


Please Share the output of journalctl -xb
there is a lot of outputs , share it here

Here is the journal. There is one boot with error and a boot without error.

The logs provided so far do not show any specific errors related to the timeout, everything seems just fine nothing really affect the booting process .

Use live ISO, check your /etc/fstab for nvme1n1p3.
Maybe the device is broken, not connected or it changed the UUID.

WD Black.

1 Like

Be sure the firmware for your drive and bios are both up to date. Testing other kernels is always best practice in situation like this as well.

I tend to stick with tried and trusted hardware. For that specific reason I have avoided nvme drives, simply because of their reputation for sometimes causing problems when using Linux.

I find it very doubtful that this is a Garuda specific issue that affects the typical Garuda user. Therefore, you may not find many users on the forum with experience with this matter that can offer advice.

NVME drives have been known to cause issues in the past with Linux. Your best bet to find a solution may simply be in depth searching online for related posts on this topic.

The Garuda wiki contains tips on how to find solutions to Linux issues that you may find helpful:

Good luck.

WD Black is the Windows installed disk. I’m using dual boot.

I tested Hardened and LTS kernels too.

I feel like this comment has been overlooked somehow. Did you try this?

Boot to the live environment with the USB stick you installed with and mount the disk Garuda is installed on. You don’t even need to chroot or anything, just click on it in the file explorer if you want.

Inside the disk you just mounted, open /etc/fstab and find the line which is mounting a disk on /mnt/data. Comment out the line, save the file, then reboot and test again.


I have tried all boot repairing tools. Still I’m getting random boor crashes.

If you wish to find a solution, answers such as above do not contain sufficient information to be helpful.

Exactly which tools did you try?

What commands have your run?

What outputs did you receive from any commands issued?

Answer all questions put to you. Don’t just cherry pick the questions you feel like replying to. I asked you earlier if your bios and your nvme drive’s firmware are up to date, are they?


Sounds like a windows issue.

Check this:
Boot your windows and open control panel → hardware and sound → power options → change what the power buttons do → change settings that are currently unavailable: uncheck turn on fast startup → save changes and close the control panel.
Always shut down windows by right-clicking on the windows button and selecting shutdown. Anything else is not a real shutdown.
BIOS: disable fastboot.
Try again.


Thank you so much. That solved the problem.

Windows probably didn’t unmount the partition properly.
A little tip: If you don’t need hibernate on windows, turn that off too. Boot windows and open cmd with admin rights:

powercfg.exe /hibernate off

And if you access the windows partition on linux and you have this problem when rebooting, then unmount it manually before shutting down linux, e.g. via terminal or in the file manager.

I disable my auto mount second (WD Black) disk settings in KDE Partition Manager and it’s booting much faster and still not giving any error.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.