Bluetooth work on Garuda Xfce

Hello,
I activate on my notebook (Lenovo Thinkpad), the small Bluetooth icon appears in the bar.
In the Garuda settings, I click on the Bluetooth adapter.
and activate Bluetooth.
After about 5 seconds, the Bluetooth icon disappears.
The Garuda Bluetooth Manager cannot even be started.
So there is no chance of pairing with the Bluetooth mouse..

garuda-inxi
System:
  Kernel: 5.15.79-1-lts arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
    root=UUID=8044bb41-5c2f-4a12-adca-63404e547740 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3
  Desktop: Xfce v: 4.16.1 tk: Gtk v: 3.24.34 info: xfce4-panel wm: xfwm
    v: 4.16.1 vt: 7 dm: LightDM v: 1.32.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: LENOVO product: 20KD001MMD v: ThinkPad A275
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 20KD001MMD serial: <superuser required> UEFI: LENOVO
    v: R0NET46W (1.24 ) date: 04/13/2021
Battery:
  ID-1: BAT0 charge: 18.3 Wh (98.9%) condition: 18.5/23.2 Wh (79.7%)
    volts: 12.2 min: 11.1 model: SANYO 45N1773 type: Li-ion serial: <filter>
    status: not charging cycles: 23
  ID-2: BAT1 charge: 19.9 Wh (100.0%) condition: 19.9/23.5 Wh (84.6%)
    volts: 12.7 min: 11.4 model: LGC 45N1127 type: Li-ion serial: <filter>
    status: charging cycles: 48
CPU:
  Info: model: AMD PRO A12-8830B R7 10 COMPUTE CORES 4C+6G bits: 64
    type: MT MCP arch: Excavator level: v3 note: check built: 2015
    process: GF 28nm family: 0x15 (21) model-id: 0x65 (101) stepping: 1
    microcode: 0x600611A
  Topology: cpus: 1x cores: 4 smt: enabled cache: L1: 320 KiB
    desc: d-4x32 KiB; i-2x96 KiB L2: 2 MiB desc: 2x1024 KiB
  Speed (MHz): avg: 2214 high: 2755 min/max: 1300/2500 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2166 2: 1416
    3: 2521 4: 2755 bogomips: 19962
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT vulnerable
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    disabled, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Wani [Radeon R5/R6/R7 Graphics] vendor: Lenovo driver: amdgpu
    v: kernel arch: GCN-3 code: Volcanic Islands process: TSMC 28nm
    built: 2014-19 ports: active: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 00:01.0
    chip-ID: 1002:9874 class-ID: 0300
  Device-2: Chicony Integrated Camera type: USB driver: N/A bus-ID: 1-1.3:3
    chip-ID: 04f2:b5ab class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.4 compositor: xfwm v: 4.16.1 driver: X:
    loaded: amdgpu unloaded: modesetting alternate: fbdev,vesa dri: radeonsi
    gpu: amdgpu display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP model: AU Optronics 0x226d built: 2015
    res: 1920x1080 hz: 60 dpi: 177 gamma: 1.2 size: 276x155mm (10.87x6.1")
    diag: 317mm (12.5") ratio: 16:9 modes: max: 1920x1080 min: 640x480
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo
    missing.
Audio:
  Device-1: AMD Kabini HDMI/DP Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel bus-ID: 00:01.1 chip-ID: 1002:9840 class-ID: 0403
  Device-2: AMD Family 15h Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel bus-ID: 00:09.2 chip-ID: 1022:157a class-ID: 0403
  Sound API: ALSA v: k5.15.79-1-lts running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.60 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: 1400 bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp1s0f0 state: down mac: <filter>
  Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:24fd
    class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
Bluetooth:
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-1.4.2:6 chip-ID: 8087:0a2b class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 3 state: up address: <filter>
Drives:
  Local Storage: total: 476.94 GiB used: 104.73 GiB (22.0%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix
    model: HFS512GD9TNG-L5B0B size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 80750C10 temp: 36.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 238.16 GiB size: 238.16 GiB (100.00%)
    used: 52.27 GiB (21.9%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
    used: 26.5 MiB (27.6%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 238.16 GiB size: 238.16 GiB (100.00%)
    used: 52.27 GiB (21.9%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-4: /var/log raw-size: 238.16 GiB size: 238.16 GiB (100.00%)
    used: 52.27 GiB (21.9%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-5: /var/tmp raw-size: 238.16 GiB size: 238.16 GiB (100.00%)
    used: 52.27 GiB (21.9%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 7.19 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 59.0 C mobo: 57.6 C gpu: amdgpu temp: 57.0 C
  Fan Speeds (RPM): fan-1: 4300
Info:
  Processes: 240 Uptime: 1h 44m wakeups: 3 Memory: 7.19 GiB
  used: 1.71 GiB (23.8%) Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1451
  libs: 393 tools: octopi,paru Shell: Bash v: 5.1.16
  running-in: xfce4-terminal inxi: 3.3.23
Garuda (2.6.9-1):
  System install date:     2022-11-17
  Last full system update: 2022-11-22
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper
  Failed units:     

does bluetoothctl give you an output?

 bluetoothctl
Agent registered
[CHG] Controller 38:BA:F8:58:E6:B5 Class: 0x00000000
[CHG] Controller 38:BA:F8:58:E6:B5 Powered: no
[CHG] Controller 38:BA:F8:58:E6:B5 Discovering: no
[DEL] Media /org/bluez/hci0 
	SupportedUUIDs: 0000110a-0000-1000-8000-00805f9b34fb
	SupportedUUIDs: 0000110b-0000-1000-8000-00805f9b34fb
[DEL] Controller 38:BA:F8:58:E6:B5 ralf-20kd001mmd [default]


If you dual boot with Windows make sure fast boot is disabled and bluetooth powersave is disabled in Windows.
If not working, try also disabling WiFi powersave in the Garuda Network Assistant and restart bluetooth

2 Likes

Sorry,
what do you mean with "Powersave" ?

Problem fixed!
I opened the Garuda Network Assistant.
There I could activate Bluetooth..
I tried to open the Garuda Bluetooth Manager
and it worked.
Now pairing is possible with my Bluetooth mouse.
Tjhank you for help.

Regards
Rallebiker

1 Like