Bluetooth Widget doesn't show devices after Sleep

The BlueTooth Widget in the Top Panel of the Dr460nized Latte Panel fails to show the list of devices after the system goes to sleep


Before Sleeping :point_down:t5:

Screenshot__10

After Sleeping :point_down:t5:

Screenshot__11

Even though some device(s) are still connected and can be viewed via System Settings :point_down:t5:


System Specs (Coppied from Garuda Assistant :wink:)

System:
  Kernel: 5.15.3-2-cacule x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-cacule
    root=UUID=59a5503e-fcee-4e1c-8787-e3f6172b5eaa rw [email protected] quiet splash
    rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1
    loglevel=3
  Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: LENOVO product: 80XH v: Lenovo ideapad 320-15ISK
    serial: <superuser required> Chassis: type: 10 v: Lenovo ideapad 320-15ISK
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: <superuser required> UEFI-[Legacy]: LENOVO
    v: 4WCN37WW date: 12/04/2017
Battery:
  ID-1: BAT0 charge: 4.9 Wh (24.3%) condition: 20.2/30.0 Wh (67.3%) volts: 7.1 min: 7.4
    model: LGC L16L2PB2 type: Li-poly serial: <filter> status: Discharging
CPU:
  Info: model: Intel Core i3-6006U bits: 64 type: MT MCP arch: Skylake family: 6
    model-id: 0x4E (78) stepping: 3 microcode: 0xEA
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache: L1: 128 KiB
    desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1720 high: 2000 min/max: 400/2000 scaling: driver: intel_pstate
    governor: powersave cores: 1: 1221 2: 1659 3: 2000 4: 2000 bogomips: 16013
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel HD Graphics 520 vendor: Lenovo driver: i915 v: kernel bus-ID: 00:02.0
    chip-ID: 8086:1921 class-ID: 0300
  Device-2: Syntek EasyCamera type: USB driver: uvcvideo bus-ID: 1-8:3 chip-ID: 174f:241a
    class-ID: 0e02
  Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver: loaded: intel
    unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3520x1080 s-dpi: 96 s-size: 928x285mm (36.5x11.2") s-diag: 971mm (38.2")
  Monitor-1: eDP1 res: 1920x1080 dpi: 143 size: 340x190mm (13.4x7.5") diag: 389mm (15.3")
  Monitor-2: HDMI1 res: 1600x900 hz: 60 dpi: 95 size: 430x240mm (16.9x9.4") diag: 492mm (19.4")
  Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel
    alternate: snd_soc_skl bus-ID: 00:1f.3 chip-ID: 8086:9d70 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.3-2-cacule running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.43 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169
    v: kernel port: 3000 bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp1s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  Device-2: Intel Dual Band Wireless-AC 3165 Plus Bluetooth driver: iwlwifi v: kernel
    bus-ID: 02:00.0 chip-ID: 8086:3166 class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
Bluetooth:
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus-ID: 1-7:2
    chip-ID: 8087:0a2a class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 7 state: up address: <filter>
Drives:
  Local Storage: total: 938.92 GiB used: 75.18 GiB (8.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10SPZX-24Z10T0 size: 931.51 GiB
    block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
    rev: 1A01 scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Generic model: SD MMC MS PRO size: 7.4 GiB
    block-size: physical: 512 B logical: 512 B type: SSD serial: <filter> rev: 1.00 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
  ID-1: / raw-size: 589.23 GiB size: 589.23 GiB (100.00%) used: 75.18 GiB (12.8%) fs: btrfs
    dev: /dev/sda4 maj-min: 8:4
  ID-2: /home raw-size: 589.23 GiB size: 589.23 GiB (100.00%) used: 75.18 GiB (12.8%) fs: btrfs
    dev: /dev/sda4 maj-min: 8:4
  ID-3: /var/log raw-size: 589.23 GiB size: 589.23 GiB (100.00%) used: 75.18 GiB (12.8%)
    fs: btrfs dev: /dev/sda4 maj-min: 8:4
  ID-4: /var/tmp raw-size: 589.23 GiB size: 589.23 GiB (100.00%) used: 75.18 GiB (12.8%)
    fs: btrfs dev: /dev/sda4 maj-min: 8:4
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 45.0 C pch: 43.5 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 251 Uptime: 10h 51m wakeups: 40607 Memory: 7.55 GiB used: 2.89 GiB (38.2%)
  Init: systemd v: 250 tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1684
  lib: 373 Client: Unknown Client: garuda-assistant inxi: 3.3.12

Lenovo is usually pretty good about providing bios updates, but yours is quite old. You definitely want to check for a bios update.

The next thing is your kernel. Whenever you experience bluetooth issues it is best to test at least three alternate kernels (especially as your kernel is not standard and appears outdated).

I would test at least the following kernels:

linux-zen
linux
linux-lts
linux-mainline

Have you tried fully updating your system and then shutting your computer off and unplugging it, (do not do a warm reboot).

Also test out installing the linux-firmware-git package, then do a cold boot after installation.

You should also check if changing your sleep state settings in your bios helps improve matters. You should also search the internet to see if you find any kernel parameters for your laptop model that may help.

If none of those actual fixes help, then the workaround of writing a systemd suspend service will usually correct this type of issue. I wrote a Bluetooth suspend/hibernate service on the forum about a week ago for someone. So if you do a bit of searching you should find it easily enough.

Good luck.

2 Likes

I posted questions/suggestions three days ago in an effort to help you. I now see you were online yesterday, but still no response to my post. If you desire assistance you need to provide full feedback to all questions and suggestions put to you.


Try these commands after resuming:

systemctl stop bluetooth
sudo modprobe -r btusb
sudo modprobe btusb
systemctl start bluetooth

Then test your BT.


Also, be sure to add the following setting if it isn't already present in /etc/bluetooth/main.conf.

Add the following near the bottom in the [Policy] section:

[Policy]
AutoEnable=true

Save the change, then restart the bluetooth service:

systemctl restart bluetooth

LINKS:

https://wiki.archlinux.org/index.php/Bluetooth

https://wiki.archlinux.org/index.php/Bluetooth#Troubleshooting

https://wiki.archlinux.org/index.php/bluetooth_headset


This will be my last post until you start providing proper feedback.

Your post will likely be binned if if you have not provided adequate feedback relatively soon. I attempt to keep the networking support area clear of junk threads that contribute nothing to our knowledge base. Without feedback your thread is near worthless to others, and is simply pointless clutter that will be queued for deletion.


You have 3 more days to provide the feedback required, if this hasn't been done by then, this thread will autolock.

3 Likes

This topic was automatically closed after 3 days. New replies are no longer allowed.