Bluetooth stops working

Greetings everyone,
I have been using Garuda for some time now and a while ago I started to have issues with the Bluetooth in Garuda, I posted the issue on the forum and despite great efforts from the community my problem remained unsolved. I thought it was because of my dual boot with Windows so I recently formatted my SSD and reinstalled Garuda only. However, the problem persists. The Bluetooth is initially usable using the solution by using this solution to my post but the fix isn’t permanent and the Bluetooth suddenly stops working and starts saying “Adapter not found”. Below I have also attached this happening when using bluetoothctl.

Output of garuda-inxi:

Kernel: 6.7.4-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=b3f7625d-2e45-4e53-ad78-5d24ccaa13a5 rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.10 tk: Qt v: N/A wm: kwin_wayland dm: SDDM
Distro: Garuda base: Arch Linux
Type: Laptop System: HP product: HP Pavilion Gaming Laptop 15-ec0xxx v: N/A
serial: <filter> Chassis: type: 10 serial: <filter>
Mobo: HP model: 86D5 v: 96.45 serial: <filter> part-nu: 169P5PA#ACJ
uuid: 30444335-3433-4e47-445a-842afd0e3d89 UEFI: AMI v: F.17
date: 03/16/2023
ID-1: BAT0 charge: 14.0 Wh (35.4%) condition: 39.5/39.5 Wh (100.0%)
power: 36.4 W volts: 12.6 min: 11.6 model: Hewlett-Packard Primary
type: Li-ion serial: N/A status: charging cycles: 355
Info: model: AMD Ryzen 5 3550H with Radeon Vega Mobile Gfx socket: FP5
bits: 64 type: MT MCP arch: Zen/Zen+ note: check gen: 1 level: v3
note: check built: 2019 process: GF 12nm family: 0x17 (23)
model-id: 0x18 (24) stepping: 1 microcode: 0x8108109
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 384 KiB desc: d-4x32 KiB; i-4x64 KiB L2: 2 MiB desc: 4x512 KiB L3: 4 MiB
desc: 1x4 MiB
Speed (MHz): avg: 1487 high: 2100 min/max: 1400/2100 boost: enabled
base/boost: 2100/3700 scaling: driver: acpi-cpufreq governor: schedutil
volts: 1.2 V ext-clock: 100 MHz cores: 1: 1400 2: 1400 3: 1400 4: 2100
5: 1400 6: 1400 7: 1400 8: 1400 bogomips: 33536
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Device-1: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q]
vendor: Hewlett-Packard driver: nvidia v: 545.29.06
alternate: nouveau,nvidia_drm non-free: 545.xx+ status: current (as of
2024-02; EOL~2026-12-xx) arch: Turing code: TUxxx process: TSMC 12nm FF
built: 2018-2022 pcie: gen: 1 speed: 2.5 GT/s lanes: 8 link-max: gen: 3
speed: 8 GT/s lanes: 16 ports: active: none empty: HDMI-A-1
bus-ID: 01:00.0 chip-ID: 10de:1f91 class-ID: 0300
Device-2: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
vendor: Hewlett-Packard driver: amdgpu v: kernel arch: GCN-5 code: Vega
process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
ports: active: eDP-1 empty: HDMI-A-2 bus-ID: 05:00.0 chip-ID: 1002:15d8
class-ID: 0300 temp: 60.0 C
Device-3: Quanta HP TrueVision HD Camera driver: uvcvideo type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-1:2 chip-ID: 0408:5365
class-ID: 0e02
Display: server: X.Org v: 23.2.4 with: Xwayland v: 23.2.4
compositor: kwin_wayland driver: X: loaded: amdgpu,nvidia
unloaded: modesetting,nouveau alternate: fbdev,nv,vesa dri: radeonsi
gpu: amdgpu display-ID: :1 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.00x11.26")
s-diag: 583mm (22.95")
Monitor-1: eDP-1 model: ChiMei InnoLux 0x1515 built: 2019 res: 1920x1080
hz: 60 dpi: 143 gamma: 1.2 size: 340x190mm (13.39x7.48") diag: 394mm (15.5")
ratio: 16:9 modes: max: 1920x1080 min: 640x480
API: EGL v: 1.5 hw: drv: nvidia drv: amd radeonsi platforms: device: 0
drv: nvidia device: 2 drv: radeonsi device: 3 drv: swrast gbm: drv: nvidia
surfaceless: drv: nvidia x11: drv: radeonsi inactive: wayland,device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: amd mesa v: 23.3.5-arch1.1
glx-v: 1.4 direct-render: yes renderer: AMD Radeon Vega 8 Graphics
(radeonsi raven LLVM 16.0.6 DRM 3.57 6.7.4-zen1-1-zen)
device-ID: 1002:15d8 memory: 1.95 GiB unified: no
API: Vulkan v: 1.3.276 layers: 4 device: 0 type: integrated-gpu name: AMD
Radeon Vega 8 Graphics (RADV RAVEN) driver: mesa radv v: 23.3.5-arch1.1
device-ID: 1002:15d8 surfaces: xcb,xlib device: 1 type: discrete-gpu
name: NVIDIA GeForce GTX 1650 driver: nvidia v: 545.29.06
device-ID: 10de:1f91 surfaces: xcb,xlib device: 2 type: cpu name: llvmpipe
(LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.3.5-arch1.1 (LLVM
16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Device-1: NVIDIA vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
pcie: gen: 3 speed: 8 GT/s lanes: 8 link-max: lanes: 16 bus-ID: 01:00.1
chip-ID: 10de:10fa class-ID: 0403
Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Hewlett-Packard
driver: snd_pci_acp3x v: kernel alternate: snd_rn_pci_acp3x, snd_pci_acp5x,
snd_pci_acp6x, snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps,
snd_sof_amd_renoir, snd_sof_amd_rembrandt, snd_sof_amd_vangogh,
snd_sof_amd_acp63 pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 05:00.5
chip-ID: 1022:15e2 class-ID: 0480
Device-3: AMD Family 17h/19h HD Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403
API: ALSA v: k6.7.4-zen1-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 1.0.3 status: n/a (root, process) with:
1: pipewire-pulse status: active 2: wireplumber status: active
3: pipewire-alsa type: plugin 4: pw-jack type: plugin
tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter
vendor: Hewlett-Packard driver: rtw_8822ce v: N/A modules: rtw88_8822ce
pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 03:00.0
chip-ID: 10ec:c822 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
vendor: Hewlett-Packard RTL8111/8168/8411 driver: r8169 v: kernel pcie:
gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 04:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: eno1 state: down mac: <filter>
Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
Local Storage: total: 1.14 TiB used: 350.92 GiB (30.0%)
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Gigabyte
model: GP-GSM2NE3256GNTD size: 238.47 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: EDFM20.0 temp: 24.9 C scheme: GPT
SMART: yes health: PASSED on: 335d 14h cycles: 6,765
read-units: 38,659,654 [19.7 TB] written-units: 43,901,660 [22.4 TB]
ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD10SPZX-60Z10T0 family: Blue Mobile (SMR) size: 931.51 GiB
block-size: physical: 4096 B logical: 512 B sata: 3.1 speed: 6.0 Gb/s
tech: HDD rpm: 5400 serial: <filter> fw-rev: 1A04 temp: 26 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 338d 3h cycles: 6761 Old-Age:
g-sense error rate: 5437
ID-1: / raw-size: 70 GiB size: 70 GiB (100.00%) used: 11.82 GiB (16.9%)
fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 513 MiB size: 512 MiB (99.80%)
used: 584 KiB (0.1%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
maj-min: 259:1
ID-3: /home raw-size: 167.97 GiB size: 167.97 GiB (100.00%)
used: 18.84 GiB (11.2%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p3
maj-min: 259:3
ID-4: /var/log raw-size: 70 GiB size: 70 GiB (100.00%)
used: 11.82 GiB (16.9%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-5: /var/tmp raw-size: 70 GiB size: 70 GiB (100.00%)
used: 11.82 GiB (16.9%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 5.66 GiB used: 4.45 GiB (78.6%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8
dev: /dev/zram0
System Temperatures: cpu: 58.5 C mobo: N/A gpu: amdgpu temp: 58.0 C
Fan Speeds (rpm): fan-1: 0 fan-2: 0
Memory: total: 6 GiB available: 5.66 GiB used: 4.53 GiB (80.0%)
Processes: 364 Power: uptime: 4h 20m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 1 fails: 1 hibernate: platform avail: shutdown,
reboot, suspend, test_resume image: 2.22 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: pm: pacman pkgs: 1338 libs: 378 tools: octopi,pamac,paru
Compilers: gcc: 13.2.1 Shell: garuda-inxi (sudo) default: Bash v: 5.2.26
running-in: konsole inxi: 3.3.33
Garuda (2.6.23-1):
System install date:     2024-02-13
Last full system update: 2024-02-15
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:
Waiting to connect to bluetoothd...[bluetooth]# Agent registered
[bluetooth]# scan on
[bluetooth]# SetDiscoveryFilter success
[bluetooth]# list
Controller 28:CD:C4:C7:35:3A garuda-linux [default]
[bluetooth]# Failed to start discovery: org.bluez.Error.InProgress
[bluetooth]# devices
Device 30:63:71:7F:80:34 itel N33
[bluetooth]# Changing 30:63:71:7F:80:34 trust succeeded
Attempting to pair with 30:63:71:7F:80:34
[bluetooth]# Failed to pair: org.bluez.Error.AlreadyExists
Attempting to connect to 30:63:71:7F:80:34
[bluetooth]# connect 30:63:71:7F:80:34
Attempting to connect to 30:63:71:7F:80:34
[bluetooth]# Failed to connect: org.bluez.Error.InProgress br-connection-busy
[bluetooth]# hci0 class of device changed: 0x000000
[bluetooth]# hci0 new_settings: bondable ssp br/edr le secure-conn
[bluetooth]# [CHG] Controller 28:CD:C4:C7:35:3A Class: 0x00000000 (0)
[bluetooth]# Failed to connect: org.bluez.Error.Failed br-connection-aborted-by-local
[bluetooth]# [CHG] Controller 28:CD:C4:C7:35:3A Powered: no
[bluetooth]# [CHG] Controller 28:CD:C4:C7:35:3A Discovering: no
[bluetooth]# hci0 removed
[bluetooth]# [DEL] Device 30:63:71:7F:80:34 itel N33
[bluetooth]# [DEL] Media /org/bluez/hci0
[bluetooth]#    SupportedUUIDs: 0000110a-0000-1000-8000-00805f9b34fb
[bluetooth]#    SupportedUUIDs: 0000110b-0000-1000-8000-00805f9b34fb
[bluetooth]# [DEL] Controller 28:CD:C4:C7:35:3A garuda-linux [default]
connectoth]# connect 30:63:71:7F:80:34
No default controller available

Any help would be appreciated. Thanks in advance to all​:slightly_smiling_face:

1 Like

Does it change anything if you repeat the command in your linked thread when it is not working?
Consider that this old kernel bug is still there, open…

1 Like

Below are some suggestions you should try:

According to your garuda-inxi output you are using the following wireless adapter and driver:

With the RTL8822CE WiFi/Bluetooth combo adapter, the following driver is generally recommended:


If you do not have the rtw88-dkms-git driver installed, you should issue the following command to install this driver:

sudo  pacman -Syu rtw88-dkms-git

Usually further configuration steps are required to get the rtw88-dkms-git driver working reliably.

I believe recent versions of this driver automatically blacklist the in-kernel driver modules, but you may want to double check that a blacklist file was created:


If you haven’t done so already, you will likely need to create a driver options configuration file or possibly add a kernel boot parameter to obtain the best reliability from the RTL8822CE wireless adapter.

For full details on these steps, refer to:

Sometimes resetting the bios to the factory default can help with the symptoms you’ve reported in the past. Boot into you bios setup utility and revert your bios to its factory default. After the bios reset is complete, power down and remove all power sources from your laptop. Let your laptop sit for 5 minutes without any power. After this, power up and enter your bios setup utility. You will need to alter some bios settings from the factory defaults to make your laptop Linux compatible. The most important ones are to disable fast startup and secure boot. Also be sure you have not enabled raid, RST, or optane, and only enable AHCI in your bios.

After completing the BIOS alterations, boot into Garuda and test your Bluetooth for proper operation.

You may want to try replacing the Bluetooth management utility bluez with blueman to see if there is any improvement. This switch sometimes helps Bluetooth users connect more reliably.

To install the blueman package, issue the command:

sudo pacman -S blueman

Also see the following threads for further ideas:


No, it does not. It only says “No Adapters available”

I tried all of the options mentioned here:

  1. installed rtw88-dkms-git from the aur with no success.
  2. Added the kernel boot parameter, it seemed to work for a day but eventually, the same result.

I would also like to mention that in the past I thought a solution had worked and reported on the forum but the same issue occurred again so this time I thought to first live with the solution for a few days before marking anything as a solution which may cause the issue to someone else. Sorry for the late reply.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.