Bluetooth not working properly, advice needed

As in the written title my bluetooth doesn't rly work. I even looked up some older topics related to this issue but didn't find smth. I already deactivated bluetooth in Windows 10. In Linux I can't use bluetooth unless I boot into Windows where I already deactivated bluetooth and then reboot into Linux. But it's a hassle. So I'd like to ask is there another way?

System:    Kernel: 5.15.7-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=38b58c54-3840-4789-a13f-3eb8107c3279
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Desktop Mobo: ASRock model: X370 Taichi serial: <superuser required>
UEFI: American Megatrends v: P5.50 date: 04/18/2019
CPU:       Info: 6-Core model: AMD Ryzen 5 1600 bits: 64 type: MT MCP arch: Zen family: 17 (23)
model-id: 1 stepping: 1 microcode: 8001137 cache: L1: 576 KiB L2: 3 MiB L3: 16 MiB
flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 91210
Speed: 2622 MHz min/max: 1550/3800 MHz boost: enabled Core speeds (MHz): 1: 2622 2: 1638
3: 2048 4: 3136 5: 2381 6: 1562 7: 3190 8: 3060 9: 2623 10: 2686 11: 2537 12: 1613
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: ZOTAC driver: nvidia v: 495.44
alternate: nouveau,nvidia_drm bus-ID: 22:00.0 chip-ID: 10de:1c03 class-ID: 0300
Device-2: Cubeternet USB2.0 Camera type: USB driver: uvcvideo bus-ID: 1-5:3 chip-ID: 1e4e:0110
class-ID: 0e02
Display: x11 server: X.Org 1.21.1.1 compositor: kwin_x11 driver: loaded: nvidia
unloaded: modesetting alternate: fbdev,nouveau,nv,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 92 s-size: 1060x301mm (41.7x11.9") s-diag: 1102mm (43.4")
Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 92 size: 531x299mm (20.9x11.8") diag: 609mm (24")
Monitor-2: DP-4 res: 1920x1080 dpi: 92 size: 531x299mm (20.9x11.8") diag: 609mm (24")
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:     Device-1: NVIDIA GP106 High Definition Audio vendor: ZOTAC driver: snd_hda_intel v: kernel
bus-ID: 22:00.1 chip-ID: 10de:10f1 class-ID: 0403
Device-2: AMD Family 17h HD Audio vendor: ASRock driver: snd_hda_intel v: kernel
bus-ID: 24:00.3 chip-ID: 1022:1457 class-ID: 0403
Device-3: TC Electronic GoXLRMini type: USB driver: snd-usb-audio bus-ID: 1-2:2
chip-ID: 1220:8fe4 class-ID: 0102
Sound Server-1: ALSA v: k5.15.7-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: yes
Sound Server-3: PulseAudio v: 15.0 running: yes
Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi v: kernel
bus-ID: 1c:00.0 chip-ID: 8086:24fb class-ID: 0280
IF: wlp28s0 state: down mac: <filter>
Device-2: Intel I211 Gigabit Network vendor: ASRock driver: igb v: kernel port: d000
bus-ID: 1e:00.0 chip-ID: 8086:1539 class-ID: 0200
IF: enp30s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Bluetooth: Device-1: Intel Wireless-AC 3168 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-9:5
chip-ID: 8087:0aa7 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: N/A
Drives:    Local Storage: total: 2.8 TiB used: 289.35 GiB (10.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 PRO 1TB size: 931.51 GiB
block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 3B2QGXA7 temp: 38.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST3320418AS size: 298.09 GiB block-size:
physical: 512 B logical: 512 B speed: 3.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: CC44
scheme: MBR
ID-3: /dev/sdb maj-min: 8:16 vendor: Toshiba model: DT01ACA100 size: 931.51 GiB block-size:
physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: A750
scheme: MBR
ID-4: /dev/sdc maj-min: 8:32 vendor: A-Data model: SU800 size: 238.47 GiB block-size:
physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 8BS scheme: MBR
ID-5: /dev/sdd maj-min: 8:48 vendor: Crucial model: CT500MX500SSD1 size: 465.76 GiB block-size:
physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 023 scheme: GPT
Partition: ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 212.95 GiB (22.9%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 580 KiB (0.2%) fs: vfat
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 212.95 GiB (22.9%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 212.95 GiB (22.9%)
fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 212.95 GiB (22.9%)
fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.34 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   Message: No sensor data found. Is lm-sensors configured?
Info:      Processes: 349 Uptime: 1h 10m wakeups: 0 Memory: 31.34 GiB used: 4.87 GiB (15.5%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1567 lib: 364
Shell: fish v: 3.3.1 running-in: konsole inxi: 3.3.09

I don't think so, at shutdown M$ apparently locks Bluetooth. If you make M$ think you want to reboot, it won't close it, great.

BTW, with my i3wm on PC and laptop with dualboot with M$ goes BT

image830

Have you already checked this thread?
It was about your same WiFi+USB adapter.

1 Like

Why?

What happens if you leave it activated and then try using it under Linux?

2 Likes

I'll look into it. There was another person having the same problem so I tried it with deactivating in Windows

Same as deactivated. I will try the solution in the other thread when I'm home again

You know how much windows is the enemy of Linux (especially) when it comes to wireless cards, bluetooth etc.?
It locks up all the resources and never let them go... :slight_smile:
It is possible that, even if the fix works, you'll have to unpair your devices from windows before pairing them in Linux.

1 Like

There is a setting in modern BIOS' that concerns whether or not, and how well Hardware Detection is applied at boot.

I had mine set to "Auto" and noticed BT had disappeared one day. (Stupid me; dual-boot with Windows.)

The only thing that resurrected Bluetooth hardware, was to turn the Hardware Detection to "Thorough."

You may have a similar BIOS setting. It can go by several names.

4 Likes

Should it be on or off then? Only have auto, on and off...

I would think that "on" would be the correct one. Where is it set now?

1 Like

I've set it on bluetooth on now. Still not working. I will look into it at the weekend when I have time.

If it is a Fast Boot setting, you want your BIOS to do as complete a hardware scan as possible. So whatever setting lets that happen, that is the one you want to use.

Also, if you're dual-booting with Windows then the BT adaptor's MAC address is probably might be being reset every time you re-boot from one OS to the other, if Windows does recognize the hardware. If that is happening it may make acquiring BT in Linux a PIA every time you re-boot between OSs.

I have had that experience on this 2019 Dell desktop machine dual-booting Arch & Windows 10, and solving the problem was not fun. (Dell was no help at all.) It was necessary to use the ol' hit-n-miss method and that takes some time. However, your machine's hardware is very different from mine so who the heck knows? :man_shrugging:

If you have not already been advised boot into windows and turn Bluetooth off, that will or should unpiar the device.

1 Like

Already did that at the beginnging.

Next question...you may have already answered it...has your BT adaptor (ever) been acquired in Garuda? If so, you'll now need to delete that, reboot, then re-acquire it once more (in Linux). Do not reboot into Windows yet or it may screw the pooch on the whole thing.

BT seems to be a "touchy" hardware area in any OS, and you'd think the support would be better 20-some years into it. :man_shrugging:

1 Like

Yes but it depends on the vendor mine works faultless as its mains powered so does not have a memory, its also on a desktop just unplug restart and it polls the source that is looking for it.

1 Like

It says No default controller available. I'll look into it tomorrow.

Booted into Linux-LTS 5.10 Kernel rn and BT works...
Don't know why it doesn't work with Linux-Zen but yeah. Have to look into it. GoXLR Mini and 5.10 don't work that well

Good for you, and good thinking.

But good golly Miss Molly, how did I miss recommending various kernels?
:rofl:

(See, folks, this is what happens when c00ter goes tobacco-free for 48 days, LOL!)

3 Likes

I'll still have audio stuttering on Kernel 5.10 hmm...