Bluetooth not Connecting


  Kernel: 5.9.11-zen2-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen 
  root=UUID=cd643c84-188a-4364-be5c-8013b5571f91 rw [email protected] quiet 
  splash rd.udev.log_priority=3 vt.global_cursor_default=0 
  systemd.unified_cgroup_hierarchy=1 loglevel=3 
  Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_wayland 
  dm: SDDM Distro: Garuda Linux 
  Type: Laptop System: LENOVO product: 80YL v: Lenovo ideapad 520-15IKB 
  serial: <filter> Chassis: type: 10 v: Lenovo ideapad 520-15IKB 
  serial: <filter> 
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40688 WIN serial: <filter> 
  UEFI: LENOVO v: 4WCN46WW date: 12/30/2019 
  ID-1: BAT0 charge: 15.8 Wh condition: 25.1/35.3 Wh (71%) volts: 8.3/7.6 
  model: CPT-COS L16C2PB1 type: Li-poly serial: <filter> status: Charging 
  Info: Dual Core model: Intel Core i7-7500U bits: 64 type: MT MCP 
  arch: Amber Lake family: 6 model-id: 8E (142) stepping: 9 microcode: DE 
  L2 cache: 4096 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 23199 
  Speed: 3150 MHz min/max: 400/3500 MHz Core speeds (MHz): 1: 1452 
  2: 2455 3: 1916 4: 3500 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, 
  SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel HD Graphics 620 vendor: Lenovo driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:5916 
  Device-2: NVIDIA GM108M [GeForce 940MX] vendor: Lenovo driver: nvidia 
  v: 455.38 alternate: nouveau,nvidia_drm bus ID: 01:00.0 
  chip ID: 10de:134d 
  Device-3: Syntek EasyCamera type: USB driver: uvcvideo bus ID: 1-8:5 
  chip ID: 174f:241a 
  Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 
  driver: modesetting display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 
  size: 344x194mm (13.5x7.6") diag: 395mm (15.5") 
  OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) 
  v: 4.6 Mesa 20.2.2 direct render: Yes 
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus ID: 00:1f.3 
  chip ID: 8086:9d71 
  Sound Server: ALSA v: k5.9.8-zen1-1-zen 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Lenovo driver: r8169 v: kernel port: 3000 bus ID: 02:00.0 
  chip ID: 10ec:8168 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter 
  vendor: Lenovo driver: ath10k_pci v: kernel port: 3000 bus ID: 03:00.0 
  chip ID: 168c:003e 
  IF: wlp3s0 state: up mac: <filter> 
  Device-3: Qualcomm Atheros QCA61x4 Bluetooth 4.0 type: USB 
  driver: btusb bus ID: 1-7:4 chip ID: 0cf3:e300 
  Local Storage: total: 945.83 GiB used: 624.8 MiB (0.1%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda vendor: Western Digital model: WD10SPZX-08Z10 
  size: 931.51 GiB block size: physical: 4096 B logical: 512 B 
  speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 1A05 
  scheme: GPT 
  ID-2: /dev/sdb type: USB vendor: SanDisk model: Cruzer Blade 
  size: 14.32 GiB block size: physical: 512 B logical: 512 B 
  serial: <filter> rev: 1.00 scheme: MBR 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci 
  v: 3.0 port: 5060 bus ID: 00:17.0 chip ID: 8086.282a rev: 21 
  ID-1: / raw size: 100.10 GiB size: 100.10 GiB (100.00%) used: 25.83 GiB (25.8%) 
  fs: btrfs dev: /dev/sda8
ID-2: /home raw size: 100.10 GiB size: 100.10 GiB (100.00%) 
  used: 25.83 GiB (25.8%) fs: btrfs dev: /dev/sda8 
  ID-3: /var/log raw size: 100.10 GiB size: 100.10 GiB (100.00%) 
  used: 25.83 GiB (25.8%) fs: btrfs dev: /dev/sda8 
  ID-4: /var/tmp raw size: 100.10 GiB size: 100.10 GiB (100.00%) 
  used: 25.83 GiB (25.8%) fs: btrfs dev: /dev/sda8 
  Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100) 
  ID-1: swap-1 type: zram size: 2.89 GiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram0 
  ID-2: swap-2 type: zram size: 2.89 GiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram1 
  ID-3: swap-3 type: zram size: 2.89 GiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram2 
  ID-4: swap-4 type: zram size: 2.89 GiB used: 0 KiB (0.0%) priority: 32767 
  dev: /dev/zram3 
  System Temperatures: cpu: 50.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 231 Uptime: 38m Memory: 7.56 GiB used: 2.09 GiB (27.6%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: pacman: 1943 
  lib: 554 flatpak: 0 Shell: Zsh v: 5.8 running in: konsole inxi: 3.1.06

Thank you :slight_smile:
As I never got response in telegram community, I hope issues get solved here sooner.
Nice to be here.


Me too :slight_smile:
I fixed you post for better reading/place.
Use three ~ in first and last line.

sorry, I didn't get you.
(three ~ )
well, lemme see wts the difference, n delete

oh, so there is no option for deleting immediately.
Anyways I got that about using "~ x3 " for code, this was just a test message
thanks, I'll use now on if needed :slight_smile:


I am sorry that your thread got burried under other issues and you had to ping us on telegram.

Tbh, I am usually in hurry and when you said

I thought the issue was solved :sweat_smile:.

And please ping on forums to revive the issue instead of telegram

So coming on topic, did you try bluedevil, the default software on KDE?



This was my first steps.
I have did everything that i can, and only after this I raised this issue here.
After all these i got to know that dual boot arch based systems have bluetooth issue.

Did you also try

sudo pacman -S pulseaudio-bluetooth

And reboot?

Are you dual booting with windows? Windows always try to block the resources for other os.

yes it is installed

yes, and i have tried replacing the pairing key, i changed some config files of bluetooth that was given in other issue. But still i cant connect, (but yes it won't give error for pairing)

@Naman @librewish Pinging again after some days expecting to get any solution to use this GarudaLinux (arch-based) soon with my bluetooth working properly.

Start here:



In the latest iso, it was fixed , imo


That probably just needed a rebuild for Pulseaudio 14.

If packages don't get rebuilt then using ChaoticAUR packages by default is going to create issues. :thinking:

1 Like

the last time i updated was may be <10days ago, and i have installed each and everything related to bluetooth

and yes i have installed pulseaudio-bluetooth

I've even tried this and mentioned in 1st post

OK, so how about you give us some useful information instead of expecting us to magically produce an answer based on you saying "nothing works" ?

If you have followed "everything" on the Arch wiki and "nothing works" then at least you will have some sort of output from commands which might be useful?

Or, we can keep pointing to pages if you want... try this one:,_but_connecting_does_not


The below thread that jonathon already linked to above has solved the issue for more than one person. I'm betting that if I go to my EOS install and do what I did here from that post I'll have my headphones working in a matter of minutes. That said please list everything you have done so far. Thanks

1 Like