Bluetooth no adapters available

hello all.
I find linux-amd-znver2 kernel most snappy in my everyday use. however, there is no working bluetooth ("No adapters available" error in kde), unlike other kernels.

btusb is loaded.
bluetoothctl power on shows: No default controller available

System:
Kernel: 5.17.5-1-ck-generic-v3 arch: x86_64 bits: 64 compiler: gcc
v: 11.2.0 parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-ck-generic-v3
root=UUID=ce5da691-f89b-4cd8-b44f-90011d7f627a rw [email protected]
loglevel=3 quiet sysrq_always_enabled=1 mitigations=off
Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.3 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X513UA_M513UA
v: 1.0 serial: <superuser required>
Mobo: ASUSTeK model: X513UA v: 1.0 serial: <superuser required>
UEFI: American Megatrends LLC. v: X513UA.311 date: 10/26/2021
Battery:
ID-1: BAT0 charge: 8.8 Wh (20.8%) condition: 42.3/42.1 Wh (100.5%)
volts: 11.8 min: 11.8 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
status: charging cycles: 9
Device-1: hidpp_battery_0 model: Logitech M570 serial: <filter>
charge: 70% rechargeable: yes status: discharging
CPU:
Info: model: AMD Ryzen 7 5700U with Radeon Graphics bits: 64 type: MT MCP
arch: Zen 2 family: 0x17 (23) model-id: 0x68 (104) stepping: 1
microcode: 0x8608103
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 8 MiB desc: 2x4 MiB
Speed (MHz): avg: 1399 high: 1448 min/max: 1400/4370 boost: enabled
scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1448 2: 1397
3: 1397 4: 1394 5: 1395 6: 1390 7: 1397 8: 1397 9: 1397 10: 1397 11: 1397
12: 1397 13: 1397 14: 1397 15: 1397 16: 1397 bogomips: 57493
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass status: Vulnerable
Type: spectre_v1 status: Vulnerable: __user pointer sanitization and
usercopy barriers only; no swapgs barriers
Type: spectre_v2 status: Vulnerable, IBPB: disabled, STIBP: disabled
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Lucienne vendor: ASUSTeK driver: amdgpu v: kernel pcie:
gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports:
active: eDP-1 empty: HDMI-A-1 bus-ID: 03:00.0 chip-ID: 1002:164c
class-ID: 0300
Device-2: Quanta USB2.0 HD UVC WebCam type: USB driver: uvcvideo
bus-ID: 3-3:3 chip-ID: 0408:30d4 class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 mapped: eDP model: Samsung 0x4161 built: 2020
res: 1920x1080 hz: 60 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
diag: 395mm (15.5") ratio: 16:9 modes: max: 1920x1080 min: 640x480
OpenGL:
renderer: AMD RENOIR (LLVM 13.0.1 DRM 3.44 5.17.5-1-ck-generic-v3)
v: 4.6 Mesa 22.0.3 direct render: Yes
Audio:
Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
speed: 16 GT/s bus-ID: 03:00.1 chip-ID: 1002:1637 class-ID: 0403
Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: ASUSTeK
driver: N/A alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x,
snd_pci_acp6x, snd_sof_amd_renoir
pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s
bus-ID: 03:00.5 chip-ID: 1022:15e2 class-ID: 0480
Device-3: AMD Family 17h/19h HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 03:00.6 chip-ID: 1022:15e3
class-ID: 0403
Sound Server-1: ALSA v: k5.17.5-1-ck-generic-v3 running: yes
Sound Server-2: JACK v: 1.9.21 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.51 running: yes
Network:
Device-1: MEDIATEK MT7921 802.11ax PCI Express Wireless Network Adapter
vendor: AzureWave driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s
lanes: 1 bus-ID: 01:00.0 chip-ID: 14c3:7961 class-ID: 0280
IF: wlp1s0 state: up mac: <filter>
Bluetooth:
Device-1: IMC Networks Wireless_Device type: USB driver: btusb v: 0.8
bus-ID: 3-2:2 chip-ID: 13d3:3563 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 2 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Drives:
Local Storage: total: 1.82 TiB used: 525.29 GiB (28.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Sabrent model: Rocket Q4
size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 type: SSD serial: <filter> rev: RKT40Q.2 temp: 27.9 C
scheme: GPT
Partition:
ID-1: / raw-size: 115.23 GiB size: 115.23 GiB (100.00%)
used: 36.93 GiB (32.1%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-2: /boot/efi raw-size: 256 MiB size: 252 MiB (98.46%)
used: 546 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p3 maj-min: 259:3
ID-3: /home raw-size: 1.59 TiB size: 1.59 TiB (100.00%)
used: 475.29 GiB (29.1%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
ID-4: /var/log raw-size: 115.23 GiB size: 115.23 GiB (100.00%)
used: 36.93 GiB (32.1%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-5: /var/tmp raw-size: 115.23 GiB size: 115.23 GiB (100.00%)
used: 36.93 GiB (32.1%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p5 maj-min: 259:5
ID-2: swap-2 type: zram size: 15.09 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 66.0 C mobo: N/A gpu: amdgpu temp: 58.0 C
Fan Speeds (RPM): cpu: 0
Info:
Processes: 457 Uptime: 2m wakeups: 5 Memory: 15.09 GiB
used: 3.63 GiB (24.1%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 12.1.0 clang: 13.0.1 Packages: pacman: 1557 lib: 383 Shell: fish
v: 3.4.1 running-in: konsole inxi: 3.3.15
Garuda (2.6.2-1):
System install date:     2021-04-26
Last full system update: 2022-05-11
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Timeshift
Failed units:            pacman-files.service systemd-oomd.socket

Like always, post your garuda-inxi.
You can edit your post and did you read?

Hello Garuda users.

Please read the following template before requesting assistance:

Please post the terminal/konsole input and output as text (no pictures) from the the following command:

garuda-inxi

Refusing to post the output of the required "garuda-inxi" on a help request will likely result in you not receiving any help from the Garuda team. A failure to provide your system specs may also result in your thread being closed without notice, (as without this information providing assistance is often next to impossible).

Before opening a new help request, please search the Arch and Garuda Wiki's, and read any relevant sections related to your issue. Also, thoroughly search any error messages in the forum's search engine and on the web. For in depth information on how to search for answers to Linux issues effectively read the tips on the Garuda Wiki:

How to search for solutions the right way

Find out what steps to take in order to find a solution to a problem

Please report in detail everything you have already attempted to solve your problem.

The template above should be deleted before posting your help request.

2 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.