Bluetooth is not being enabled

@Thinkerer Thanks for the reply :smiley:
systemctl status shows the following about bluetooth

โ”‚ โ”œโ”€bluetooth-autoconnect.service 
โ”‚ โ”‚ โ””โ”€501 /usr/bin/bluetooth-autoconnect -d
โ”‚ โ”œโ”€bluetooth.service 
โ”‚ โ”‚ โ””โ”€504 /usr/lib/bluetooth/bluetoothd

I'm very new to arch :slight_smile:
Please look past if did any mistake and guide me if I did anything wrong

Make sure nothing else is paired to Bluetooth like paired on windows, mobile phone, make sure as Bluetooth will not connect if already paired, it happens hear sometimes i forget that i've used bluetooth on my windows/Mac so now i don't use auto connect so Bluetooth on anything is disconnected.

3 Likes

You are just misinterpreting the logs and messages.
Your bluetooth device in your PC/Garuda system is working fine.
It just cannot find any bluetooth devices to connect to.
It's about your mobile device(s) that need to be unhidden or set to be discoverable.
How many bluetooth HW do you try to discover?
Deal with them. :man_shrugging:

4 Likes

Your bluetooth on the hardware end of things seems to be running without errors as @petsam says.

3 Likes

Here's some more information :

sudo lsmod | grep bluetooth

bluetooth             761856  14 btrtl,btintel,btbcm,bnep,btusb
ecdh_generic           16384  1 bluetooth
rfkill                 32768  10 asus_wmi,bluetooth,cfg80211
crc16                  16384  1 bluetooth
sudo hcitool dev 

Devices:
sudo dmesg | grep Blue

[    5.028505] Bluetooth: Core ver 2.22
[    5.028523] Bluetooth: HCI device and connection manager initialized
[    5.028526] Bluetooth: HCI socket layer initialized
[    5.028528] Bluetooth: L2CAP socket layer initialized
[    5.028531] Bluetooth: SCO socket layer initialized
[    5.588979] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    5.588982] Bluetooth: BNEP filters: protocol multicast
[    5.588987] Bluetooth: BNEP socket layer initialized

When I try to click enable on bluetooth in settings, it doesn't do anything. Restarting bluetooth module from the garuda network assistant doesn't help too.

I tried to disable bluetooth from the BIOS and then rebooting it and enabling it again, but it was still the same.

@petsam @tbg I get that it shows everything is working properly in simple terms as @petsam says.
As I'm a new user I can't post photos. The bluetooth in garuda network assistant and in the settings are unclickable/nothing happens when I try to enable it and it is always set to disabled. It's not about setting by mobile device(s) set at discoverable as @petsam says.

Edit : I just now earned a badge BASIC so I can post photos now

Screenshot__1


You are not listening at least 2 users have told you you have to unpair the device from what ever its paired to. and your comp as well. It could be your mobile or windows, the last thing it may not be compatible something i have never encountered mind you and very much doubt it. Photos don't help diagnose logs do. untick wifi power save as they may be connected.

1 Like

@mandog can you please explain what you meant by this :

You are not listening at least 2 users have told you you have to unpair the device from what ever its paired to. and your comp as well. It could be your mobile or windows,

So, I was using my wireless mouse connected to my laptop with the wireless usb. And it was working just fine on both windows and garuda but I tried to remove the usb when i was logged in to windows and then log in to garuda and insert the usb again, it doesn't seem to work then. Again when I log in to windows then again to garuda with the usb still connected, it works fine.
Can you dumb it down for me. :sweat_smile:

Have you missed a step, or just not posted?

Enter power on to turn the power to the controller on. It is off by default and will turn off again each reboot, see #Auto power-on after boot

1 Like

Please turn OFF that WiFi Powersave option (uncheck the box), then reboot, click the "Restart Bluetooth module" and try to re-acquire, please. You may need to try the latter steps in a slightly different order, depends.

Also, please disable any Power Saving settings in your BIOS.

You may need to re-boot several times when taking these steps.

Then please report back.

regards

2 Likes

It means log into windows go to devices and unpair bluetooth device so it no longer shows up, if you have a mobile pad or anything else do the same its not just a case of turning off its the unpairing that counts as if the device is paired even though its not being used it blocks the device from being used by anything else. Then boot into windows twice,
Go back to Garuda rfkill in terminal press enter. press the pairing button on the device till it flashes, now see if the device is visible if so enable. I should not be telling you this really you the user should do your own research

1 Like

@petsam Yes, I've followed the steps and changed

/etc/bluetooth/main.conf

[Policy]
AutoEnable=true

[General]
DiscoverableTimeout = 0

And when I try to power on it still shows : (as I've shown at the beginning of my post)

No default controller available

I haven't tried @mandog 's method yet, I'll have to do some research to completely get it.

hciconfig -a returns :

hciconfig -a
hci0:   Type: Primary  Bus: USB
BD Address: 00:00:00:00:00:00  ACL MTU: 0:0  SCO MTU: 0:0
DOWN
RX bytes:0 acl:0 sco:0 events:0 errors:0
TX bytes:3 acl:0 sco:0 commands:1 errors:0
Features: 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00
Packet type: DM1 DH1 HV1
Link policy:
Link mode: SLAVE ACCEPT

Go on the troubleshooting guide and see if you find a solution.
For example this and more.

Report back whatever you have already tried, so we don't suggest.

2 Likes

@Rupangkan I fixed the problem with this patch https://pastebin.pl/view/raw/152ca559 for 5.13.x. You have to either build a new kernel or wait till 5.15 because the patch is a part of linux-next.

Basically it adds missing Vendor/Device ids with corresponding flags.

2 Likes

@velemas thanks for the reply :smiley:
Can you show me the steps how to apply this patch? Or do I have to install linux-next?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.