Bluetooth is disabled after doing pacman -Syu

Could someone help me how to enable the bluetooth back?
I have played music with bluetooth after dual booting the Garuda Linux with Windows OS and before doing pacman -Syu.
The pacman -Syu possibly had made changes to the bluetooth.

╰─λ garuda-inxi
System:
Kernel: 5.18.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=1c1995a9-4167-46de-b0a9-fa58d32cb7ac rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.25.1 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: ASUSTeK product: X555LA v: 1.0
serial: <superuser required>
Mobo: ASUSTeK model: X555LA v: 1.0 serial: <superuser required>
UEFI: American Megatrends v: X555LA.308 date: 08/14/2014
Battery:
ID-1: BAT0 charge: N/A condition: N/A volts: N/A model: N/A type: Unknown
serial: N/A status: N/A
CPU:
Info: model: Intel Core i3-4030U bits: 64 type: MT MCP arch: Haswell
gen: core 4 built: 2013-15 process: Intel 22nm family: 6
model-id: 0x45 (69) stepping: 1 microcode: 0x26
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 1365 high: 1797 min/max: 800/1800 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 891 2: 1403 3: 1372
4: 1797 bogomips: 15164
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel Haswell-ULT Integrated Graphics vendor: ASUSTeK
driver: i915 v: kernel arch: Gen7.5 process: Intel 22nm built: 2013 ports:
active: DP-1,eDP-1 empty: HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:0a16
class-ID: 0300
Device-2: Realtek USB Camera type: USB driver: uvcvideo bus-ID: 2-5:4
chip-ID: 0bda:57b5 class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 2732x768 s-dpi: 96 s-size: 722x203mm (28.43x7.99")
s-diag: 750mm (29.53")
Monitor-1: DP-1 pos: primary,left model: AOC 2070L serial: <filter>
built: 2018 res: 1366x768 hz: 60 dpi: 80 gamma: 1.2
size: 434x236mm (17.09x9.29") diag: 494mm (19.4") ratio: 16:9 modes:
max: 1366x768 min: 720x400
Monitor-2: eDP-1 pos: right model: ChiMei InnoLux 0x15ab built: 2013
res: 1366x768 hz: 60 dpi: 101 gamma: 1.2 size: 344x193mm (13.54x7.6")
diag: 394mm (15.5") ratio: 16:9 modes: 1366x768
OpenGL: renderer: Mesa Intel HD Graphics 4400 (HSW GT2)
v: 4.6 Mesa 22.1.2 direct render: Yes
Audio:
Device-1: Intel Haswell-ULT HD Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel bus-ID: 00:03.0 chip-ID: 8086:0a0c class-ID: 0403
Sound Server-1: ALSA v: k5.18.7-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.52 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: e000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Device-2: Broadcom BCM43142 802.11b/g/n vendor: Lite-On driver: wl
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0
chip-ID: 14e4:4365 class-ID: 0280
IF: wlp3s0 state: dormant mac: <filter>
Bluetooth:
Device-1: Lite-On Broadcom BCM43142A0 Bluetooth Device type: USB
driver: btusb v: 0.8 bus-ID: 2-6:5 chip-ID: 04ca:2006 class-ID: fe01
serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: N/A
Drives:
Local Storage: total: 465.76 GiB used: 11.05 GiB (2.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ01ABF050
size: 465.76 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: 1J scheme: GPT
Partition:
ID-1: / raw-size: 114.62 GiB size: 114.62 GiB (100.00%)
used: 11.02 GiB (9.6%) fs: btrfs dev: /dev/sda5 maj-min: 8:5
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
used: 29.8 MiB (31.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 114.62 GiB size: 114.62 GiB (100.00%)
used: 11.02 GiB (9.6%) fs: btrfs dev: /dev/sda5 maj-min: 8:5
ID-4: /var/log raw-size: 114.62 GiB size: 114.62 GiB (100.00%)
used: 11.02 GiB (9.6%) fs: btrfs dev: /dev/sda5 maj-min: 8:5
ID-5: /var/tmp raw-size: 114.62 GiB size: 114.62 GiB (100.00%)
used: 11.02 GiB (9.6%) fs: btrfs dev: /dev/sda5 maj-min: 8:5
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 5.68 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 49.0 C pch: 48.0 C mobo: N/A
Fan Speeds (RPM): cpu: 3100
Info:
Processes: 192 Uptime: 17m wakeups: 1 Memory: 5.68 GiB
used: 2.3 GiB (40.4%) Init: systemd v: 251 default: graphical
tool: systemctl Compilers: gcc: 12.1.0 Packages: pacman: 1153 lib: 298
Shell: fish v: 3.4.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.19
Garuda (2.6.4-2):
System install date:     2022-06-13
Last full system update: 2022-06-28 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

Try rebooting your machine and see if it comes back. Sometimes things don't work right after taking an update until you reboot.

Also, the preferred way to update is not pacman -Syu, it is:

garuda-update

It includes extra considerations to help keep your system from breaking. :slightly_smiling_face:

5 Likes

I already tried this. But will try again to reboot...
Update: Bluetooth is still disabled...

╰─λ garuda-update
[sudo] password for devianvisuals:     
:: Synchronizing package databases...
garuda is up to date
core is up to date
extra is up to date
community is up to date
multilib is up to date
chaotic-aur is up to date

--> Refreshing mirrorlists using rate-mirrors, please be patient..
:: Synchronizing package databases...
garuda                                 73.2 KiB  11.6 KiB/s 00:06 [------------------------------------] 100%
core                                  156.4 KiB   175 KiB/s 00:01 [------------------------------------] 100%
extra                                1717.9 KiB   199 KiB/s 00:09 [------------------------------------] 100%
community                               6.7 MiB   876 KiB/s 00:08 [------------------------------------] 100%
multilib                              170.3 KiB   190 KiB/s 00:01 [------------------------------------] 100%
chaotic-aur                          1849.6 KiB   277 KiB/s 00:07 [------------------------------------] 100%
spawn pacman -Su
:: Starting full system upgrade...
there is nothing to do

Checking for plugin updates
Nothing to install / update

System updated! 🐧

Try the linux-lts kernel.

3 Likes

:point_up_2: That is updating, not the same as rebooting. Rebooting is when you ask your system to turn off and back on again. Save your work, then type in the terminal:

reboot
1 Like

Just installed the LTS kernel. Is this right dude?

╰─λ uname -r
5.15.50-1-lts

╰─λ sudo pacman -R linux
sudo grub-mkconfig -o /boot/grub/grub.cfg
[sudo] password for devianvisuals:     
error: target not found: linux
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/garuda-dr460nized/theme.txt
Found linux image: /boot/vmlinuz-linux-zen
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux-zen.img
Found fallback initrd image(s) in /boot:  intel-ucode.img initramfs-linux-zen-fallback.img
Found linux image: /boot/vmlinuz-linux-lts
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux-lts.img
Found fallback initrd image(s) in /boot:  intel-ucode.img initramfs-linux-lts-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Found Windows Boot Manager on /dev/[email protected]/EFI/Microsoft/Boot/bootmgfw.efi
Adding boot menu entry for UEFI Firmware Settings ...
Detecting snapshots ...
Found snapshot: 2022-06-28 10:45:54 | @/.snapshots/8/snapshot | post | linux-lts                              |
Found snapshot: 2022-06-28 10:44:28 | @/.snapshots/7/snapshot | pre  | pacman -S linux-lts                    |
Found snapshot: 2022-06-28 09:06:36 | @/.snapshots/6/snapshot | post | garuda-assistant garuda-common-settingsgaruda-dr460nized garuda-fish-co |
Found snapshot: 2022-06-28 09:06:14 | @/.snapshots/5/snapshot | pre  | pacman -Syu                            |
Found snapshot: 2022-06-27 22:06:57 | @/.snapshots/4/snapshot | post | aha alacritty alpm_octopi_utils alsa-card-profiles alsa-lib alsa-ucm-con |
Found snapshot: 2022-06-27 22:00:09 | @/.snapshots/3/snapshot | pre  | pacman -Syu                            |
Found snapshot: 2022-06-27 20:32:44 | @/.snapshots/2/snapshot | post | chaotic-keyring                        |
Found snapshot: 2022-06-27 20:32:35 | @/.snapshots/1/snapshot | pre  | pacman -Udd --noconfirm --needed archlinux-keyring-20220424-1-any.pkg.ta |
Found 8 snapshot(s)
Unmount /tmp/grub-btrfs.LsKNMBWxBN .. Success
Found memtest86+ image: /boot/memtest86+/memtest.bin
done

Thanks a lot Garuda Team it works to enable the bluetooth by using LTS kernel. But I have another problem in detecting bluetooth devices. Do you have another good idea?

Dual booting with Windows?

Windows often messes with Bluetooth acquisition in Linux.

1 Like

Look for a newer BIOS than 2014. I'm serious.

1 Like

Another thread, please, or is this thread not solved?

This thread is solved for enabling bluetooth using LTS kernel. Will make another thread or search a solution here for bluetooth problem for undetecting devices.
Thank you garuda team for all your assistance...

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.