Bluetooth Headphone Pairing Failing

I keep getting an error when I try my bluetooth headphones which are an ATH-M50x I have tried using switching from pipwire audio to pulseaudio. I then have tried to uninstall and reinstall bluez which was recommended somewhere on this forum . Tried looking at the bluetoothctl command to with no clue whats wrong. Below i have shared both the garuda-inxi and the bluetoothctl to try and see if someone can help. This device is not even paired to my windows 11 install.

[bluetooth]# list
Controller 50:84:92:FF:73:27 InmateGaruda [default]
[bluetooth]# show
Controller 50:84:92:FF:73:27 (public)
Manufacturer: 0x0002 (2)
Version: 0x0c (12)
Name: InmateGaruda
Alias: InmateGaruda
Class: 0x006c010c (7078156)
Powered: yes
PowerState: on
Discoverable: no
DiscoverableTimeout: 0x000000b4 (180)
Pairable: yes
UUID: A/V Remote Control        (0000110e-0000-1000-8000-00805f9b34fb)
UUID: Handsfree Audio Gateway   (0000111f-0000-1000-8000-00805f9b34fb)
UUID: PnP Information           (00001200-0000-1000-8000-00805f9b34fb)
UUID: Audio Sink                (0000110b-0000-1000-8000-00805f9b34fb)
UUID: Audio Source              (0000110a-0000-1000-8000-00805f9b34fb)
UUID: A/V Remote Control Target (0000110c-0000-1000-8000-00805f9b34fb)
UUID: Generic Access Profile    (00001800-0000-1000-8000-00805f9b34fb)
UUID: Generic Attribute Profile (00001801-0000-1000-8000-00805f9b34fb)
UUID: Device Information        (0000180a-0000-1000-8000-00805f9b34fb)
UUID: Vendor specific           (03b80e5a-ede8-4b33-a751-6ce34ec4c700)
UUID: Handsfree                 (0000111e-0000-1000-8000-00805f9b34fb)
Modalias: usb:v1D6Bp0246d054C
Discovering: no
Roles: central
Roles: peripheral
Advertising Features:
ActiveInstances: 0x00 (0)
SupportedInstances: 0x0c (12)
SupportedIncludes: tx-power
SupportedIncludes: appearance
SupportedIncludes: local-name
SupportedSecondaryChannels: 1M
SupportedSecondaryChannels: 2M
SupportedSecondaryChannels: Coded
erl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "en_US",
LC_ALL = (unset),
LC_ADDRESS = "fi_FI.UTF-8",
LC_NAME = "fi_FI.UTF-8",
LC_MONETARY = "en_FI.UTF-8",
LC_PAPER = "en_FI.UTF-8",
LC_IDENTIFICATION = "fi_FI.UTF-8",
LC_TELEPHONE = "fi_FI.UTF-8",
LC_MEASUREMENT = "en_FI.UTF-8",
LC_TIME = "en_FI.UTF-8",
LC_NUMERIC = "en_FI.UTF-8",
LANG = "en_US.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_US.UTF-8").
System:
Kernel: 6.9.3-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
clocksource: tsc avail: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=f944f352-5a3e-4b23-8326-5457943b7e1a rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.0.5 tk: Qt v: N/A info: frameworks v: 6.3.0
wm: kwin_wayland with: krunner vt: 1 dm: SDDM Distro: Garuda
base: Arch Linux
Machine:
Type: Laptop System: Razer product: Blade 17 (2022) - RZ09-0423 v: 8.04
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: Razer model: DI780 v: 4 serial: <superuser required>
part-nu: RZ09-0423PEF3 uuid: <superuser required> UEFI: Razer v: 1.09
date: 01/10/2023
Battery:
ID-1: BAT0 charge: 64.2 Wh (77.3%) condition: 83.0/82.1 Wh (101.2%)
volts: 15.4 min: 15.4 model: Razer Blade type: Unknown serial: <filter>
status: not charging
CPU:
Info: model: 12th Gen Intel Core i9-12900H bits: 64 type: MST AMCP
arch: Alder Lake gen: core 12 level: v3 note: check built: 2021+
process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 3
microcode: 0x433
Topology: cpus: 1x cores: 14 mt: 6 tpc: 2 st: 8 threads: 20 smt: enabled
cache: L1: 1.2 MiB desc: d-8x32 KiB, 6x48 KiB; i-6x32 KiB, 8x64 KiB
L2: 11.5 MiB desc: 6x1.2 MiB, 2x2 MiB L3: 24 MiB desc: 1x24 MiB
Speed (MHz): avg: 1224 high: 4081 min/max: 400/4900:5000:3800 scaling:
driver: intel_pstate governor: performance cores: 1: 492 2: 400 3: 400
4: 400 5: 400 6: 400 7: 4081 8: 400 9: 400 10: 400 11: 400 12: 400
13: 3800 14: 3768 15: 2370 16: 3095 17: 400 18: 400 19: 1690 20: 400
bogomips: 116736
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: Intel Alder Lake-P GT2 [Iris Xe Graphics] vendor: Razer USA
driver: i915 v: kernel alternate: xe arch: Gen-12.2 process: Intel 10nm
built: 2021-22+ ports: active: none off: eDP-1 empty: none bus-ID: 00:02.0
chip-ID: 8086:46a6 class-ID: 0300
Device-2: NVIDIA GA103M [GeForce RTX 3080 Ti Mobile] vendor: Razer USA
driver: nvidia v: 550.90.07 alternate: nouveau,nvidia_drm non-free: 550.xx+
status: current (as of 2024-04; EOL~2026-12-xx) arch: Ampere code: GAxxx
process: TSMC n7 (7nm) built: 2020-2023 pcie: gen: 4 speed: 16 GT/s
lanes: 8 link-max: lanes: 16 ports: active: none off: HDMI-A-1
empty: DP-1, DP-2, DP-3, DP-4 bus-ID: 01:00.0 chip-ID: 10de:2420
class-ID: 0300
Device-3: IMC Networks Integrated RGB Camera driver: uvcvideo type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-8:4 chip-ID: 13d3:5279
class-ID: 0e02 serial: <filter>
Display: wayland server: X.org v: 1.21.1.13 with: Xwayland v: 24.1.0
compositor: kwin_wayland driver: X: loaded: modesetting,nvidia
unloaded: nouveau alternate: fbdev,intel,nv,vesa dri: iris
gpu: i915,nvidia display-ID: 0
Monitor-1: HDMI-A-1 res: 5120x1440 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
drv: nvidia device: 2 drv: iris device: 3 drv: swrast gbm: drv: nvidia
surfaceless: drv: nvidia wayland: drv: iris x11: drv: iris
inactive: device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 24.1.1-arch1.1
glx-v: 1.4 direct-render: yes renderer: Mesa Intel Graphics (ADL GT2)
device-ID: 8086:46a6 memory: 15.15 GiB unified: yes display-ID: :1.0
API: Vulkan v: 1.3.279 layers: 10 device: 0 type: integrated-gpu
name: Intel Graphics (ADL GT2) driver: mesa intel v: 24.1.1-arch1.1
device-ID: 8086:46a6 surfaces: xcb,xlib,wayland device: 1
type: discrete-gpu name: NVIDIA GeForce RTX 3080 Ti Laptop GPU
driver: nvidia v: 550.90.07 device-ID: 10de:2420
surfaces: xcb,xlib,wayland device: 2 type: cpu name: llvmpipe (LLVM
17.0.6 256 bits) driver: mesa llvmpipe v: 24.1.1-arch1.1 (LLVM 17.0.6)
device-ID: 10005:0000 surfaces: xcb,xlib,wayland
Audio:
Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: Razer USA
driver: sof-audio-pci-intel-tgl alternate: snd_hda_intel, snd_soc_avs,
snd_sof_pci_intel_tgl bus-ID: 00:1f.3 chip-ID: 8086:51c8 class-ID: 0401
Device-2: NVIDIA vendor: Razer USA driver: snd_hda_intel v: kernel pcie:
gen: 4 speed: 16 GT/s lanes: 8 link-max: lanes: 16 bus-ID: 01:00.1
chip-ID: 10de:2288 class-ID: 0403
API: ALSA v: k6.9.3-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: alsactl,alsamixer,amixer
Server-1: PipeWire v: 1.0.7 status: active with: 1: wireplumber
status: active 2: pipewire-alsa type: plugin 3: pw-jack type: plugin
tools: pw-cat,pw-cli,wpctl
Server-2: PulseAudio v: 17.0 status: off with: pulseaudio-jack
type: module tools: pacat,pactl
Network:
Device-1: Intel Alder Lake-P PCH CNVi WiFi vendor: Rivet Networks
Simultaneous Dual Band Wi-Fi 6E AX1690i 160MHz 2x2 driver: iwlwifi
v: kernel bus-ID: 00:14.3 chip-ID: 8086:51f0 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Realtek RTL8125 2.5GbE vendor: Razer USA driver: r8169 v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 port: 3000 bus-ID: 04:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp4s0 state: down mac: <filter>
Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
Bluetooth:
Device-1: Intel AX211 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-10:6 chip-ID: 8087:0033
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.3
lmp-v: 12 status: discoverable: no pairing: no class-ID: 6c010c
Drives:
Local Storage: total: 4.57 TiB used: 53.53 GiB (1.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:6 vendor: Western Digital
model: WDS400T3X0C-00SJG0 size: 3.64 TiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 114000WD temp: 45.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Samsung
model: MZVL21T0HCLR-00B00 size: 953.87 GiB block-size: physical: 512 B
logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: GXA7601Q temp: 37.9 C scheme: GPT
Partition:
ID-1: / raw-size: 107.42 GiB size: 107.42 GiB (100.00%)
used: 53.49 GiB (49.8%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:9
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
used: 46.2 MiB (48.2%) fs: vfat dev: /dev/nvme1n1p2 maj-min: 259:2
ID-3: /home raw-size: 107.42 GiB size: 107.42 GiB (100.00%)
used: 53.49 GiB (49.8%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:9
ID-4: /var/log raw-size: 107.42 GiB size: 107.42 GiB (100.00%)
used: 53.49 GiB (49.8%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:9
ID-5: /var/tmp raw-size: 107.42 GiB size: 107.42 GiB (100.00%)
used: 53.49 GiB (49.8%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:9
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 31.03 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 20 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 54.0 C mobo: N/A
Fan Speeds (rpm): N/A
Info:
Memory: total: 32 GiB note: est. available: 31.03 GiB used: 5.58 GiB (18.0%)
Processes: 457 Power: uptime: 36m states: freeze,mem,disk suspend: s2idle
avail: deep wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 12.37 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 256 default: graphical
tool: systemctl
Packages: pm: pacman pkgs: 2089 libs: 601 tools: gnome-software, octopi,
pamac, paru Compilers: clang: 17.0.6 gcc: 14.1.1 Shell: garuda-inxi
default: fish v: 3.7.1 running-in: konsole inxi: 3.3.34
Garuda (2.6.26-1):
System install date:     2024-04-11
Last full system update: 2024-06-18
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       Probably (Run as root to verify)
Failed units:

See if you can turn this on from within the bluetoothctl prompt.

[bluetooth]# discoverable on

Make sure the agent is on and make it the default agent.

[bluetooth]# agent on
[bluetooth]# default-agent

Then scan for devices.

[bluetooth]# scan on

Wait for the device you want to show up, then make note of it’s MAC address. It will look similar to this:

[NEW] Device 00:1A:7D:DA:71:11 DeviceName

Once you have the MAC address, you can use that to initiate pairing.

[bluetooth]# pair 00:1A:7D:DA:71:11

“Trust” the device if you want to reconnect in the future without pairing again (optional, but you probably want to do it unless it isn’t your device you are pairing with or something).

[bluetooth]# trust 00:1A:7D:DA:71:11

Finally, connect to the device.

[bluetooth]# connect 00:1A:7D:DA:71:11

You may also wish to stop scanning.

[bluetooth]# scan off

See also this article: https://wiki.archlinux.org/title/Bluetooth#Pairing

All bluetooth devices present this problem sadly where says registration failed.

Copy and paste into the thread the input and output from the terminal so we can see what is happening.

1 Like

This Is An Extreme Measure. Use only if Bluetooth disappears in BOTH Windows AND Linux.

Do a hardware cold reset by holding down the power button right now , from Windows, preferably, for 30 seconds. Then unplug your machine from power for another 30 secs. or so. Then plug it back in, reboot into your BIOS and make sure Bluetooth is still enabled.

Boot back into your OS and do a file systems check, reboot again, and see if you can re-enable Bluetooth.

2 Likes

I did a force pairing with my headphones and it seemed to resolve itself and reinstalled garuda overall since there was a failed update that crashed my computer.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.