Bluetooth having an absolute stroke

Ok so I'm having a really scuffed and very annoying issue that I'm failing to deal with for several hours already...
What happened:

  1. I accidentally knocked out my flimsy bluetooth dongle out of my usb hub
  2. Rebooted, because it would not detect it again
  3. Worked
  4. Did it again
    1. didn't work anymore in the hub. It just refuses to register at all. It now only works in my pc's own usb ports, which is where I can't use it.
  5. Everything is in shambles

So after dealing with error upon error I decided to delete my headset's profile altogether and start from zero, but I'm still having issues. I can now connect to my headset again, but it's not registered in pipewire, even though it clearly sais it did exactly that. A minute later, the device disconnects again.

I have no clue what to do now. Nothing I try works. I don't even know where this issue started.
At this point, I'd like to have my deleted headset profile back, since deleting it really didn't work out. Where is that stored? I can't find the file...

Does anyone have an idea how to fix this? It does not seem to be related to an upgrade. The relevant stuff was the kernel, and downgrading or switching to LTS does not work.

Since I already have this typed, I'll post it, but I'm gonna try upgrading again in the hopes of that changing anything, but I doubt it. (Did not help)

Edit: Now, after another reboot, I'm getting the 6th completely undocumented error message: le-connection-abort-by-local Why does it abort?
Also, just to confirm, I just removed my own wireplumber and bluetooth/main.conf modifications, still no change.

  Kernel: 6.4.7-zen1-2-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: root=PARTUUID=fec66b8f-995b-8043-94b0-fcc9535362ba rw
    add_efi_memmap rootflags=subvol=@ initrd=@\boot\amd-ucode.img
    rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1 loglevel=3 sysrq_always_enabled=1
    iommu=soft initrd=\@\boot\initramfs-linux-zen.img
  Desktop: Hyprland info: waybar vt: 1 dm: greetd Distro: Garuda Linux
    base: Arch Linux
  Type: Desktop System: Gigabyte product: AX370-Gaming 3 v: N/A
    serial: <superuser required>
  Mobo: Gigabyte model: AX370-Gaming 3-CF v: x.x
    serial: <superuser required> UEFI: American Megatrends v: F50a
    date: 11/27/2019
  Info: model: AMD Ryzen 5 2600X bits: 64 type: MT MCP arch: Zen+ gen: 2
    level: v3 note: check built: 2018-21 process: GF 12nm family: 0x17 (23)
    model-id: 8 stepping: 2 microcode: 0x800820D
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 16 MiB desc: 2x8 MiB
  Speed (MHz): avg: 3532 high: 4144 min/max: 2200/3600 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 4144 2: 4129
    3: 4141 4: 4141 5: 3841 6: 2071 7: 3600 8: 3600 9: 3600 10: 4132 11: 2922
    12: 2071 bogomips: 86226
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
  Device-1: AMD Navi 22 [Radeon RX 6700/6700 XT/6750 XT / 6800M/6850M XT]
    vendor: Sapphire driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x
    process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s
    lanes: 16 ports: active: DP-3,HDMI-A-1 empty: DP-1,DP-2 bus-ID: 0a:00.0
    chip-ID: 1002:73df class-ID: 0300
  Display: wayland server: Xwayland v: 23.2.0 compositor: Hyprland driver:
    X: loaded: amdgpu unloaded: modesetting,radeon alternate: fbdev,vesa
    dri: radeonsi gpu: amdgpu display-ID: 1
  Monitor-1: DP-3 model: Apple Cinema HD Display serial: <filter>
    built: 2003 res: 1920x1200 dpi: 99 gamma: 1.2 size: 495x310mm (19.49x12.2")
    diag: 584mm (23") ratio: 16:10 modes: max: 1920x1200 min: 640x480
  Monitor-2: HDMI-A-1 model: Samsung SyncMaster serial: <filter> built: 2007
    res: 1680x1050 dpi: 90 gamma: 1.2 size: 474x296mm (18.66x11.65")
    diag: 559mm (22") ratio: 16:10 modes: max: 1680x1050 min: 720x400
  API: OpenGL v: 4.6 Mesa 23.1.5 renderer: AMD Radeon RX 6700 XT (navi22
    LLVM 15.0.7 DRM 3.52 6.4.7-zen1-2-zen) direct-render: Yes
  Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 0a:00.1 chip-ID: 1002:ab28
    class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 0c:00.3
    chip-ID: 1022:1457 class-ID: 0403
  Device-3: C-Media USB Microphone driver: hid-generic,snd-usb-audio,usbhid
    type: USB rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-4.1:6
    chip-ID: 0d8c:9700 class-ID: 0300 serial: <filter>
  Device-4: Textech USB Midi 4i4o driver: snd-usb-audio type: USB rev: 1.1
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-4.2:7 chip-ID: 15ca:1804
    class-ID: 0103
  Device-5: Comtrue Swissonic Audio ASIO driver: snd-usb-audio type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-4.3:8
    chip-ID: 2fc6:f04e class-ID: 0102 serial: <filter>
  Device-6: M-Audio Keystation 88 MK3 driver: snd-usb-audio type: USB
    rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-4.4:9
    chip-ID: 0763:0044 class-ID: 0103
  API: ALSA v: k6.4.7-zen1-2-zen status: kernel-api
    tools: alsactl,alsamixer,amixer
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 0.3.77 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: f000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-1: Broadcom BCM20702A0 Bluetooth 4.0 driver: btusb v: 0.8 type: USB
    rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-4:2 chip-ID: 0a5c:21e8
    class-ID: fe01 serial: <filter>
  Report: hciconfig ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.0
    lmp-v: 6 sub-v: 220e hci-v: 6 rev: 1000 class-ID: 7c0104
  Info: acl-mtu: 1021:8 sco-mtu: 64:1 link-policy: rswitch sniff
    link-mode: peripheral accept service-classes: rendering, capturing, object
    transfer, audio, telephony
  Local Storage: total: 2.96 TiB used: 810.77 GiB (26.8%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 4B6Q scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 860 EVO 250GB
    size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 1B6Q scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital
    model: WD20EFRX-68EUZN0 size: 1.82 TiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 5400 serial: <filter>
    fw-rev: 0A82 scheme: GPT
  ID-1: / raw-size: 195.03 GiB size: 195.03 GiB (100.00%)
    used: 104.04 GiB (53.3%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-2: /boot/efi raw-size: 301 MiB size: 300.4 MiB (99.79%)
    used: 19.1 MiB (6.3%) fs: vfat dev: /dev/sda2 maj-min: 8:2
  ID-3: /home raw-size: 736.18 GiB size: 736.18 GiB (100.00%)
    used: 358.54 GiB (48.7%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
  ID-4: /var/log raw-size: 195.03 GiB size: 195.03 GiB (100.00%)
    used: 104.04 GiB (53.3%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-5: /var/tmp raw-size: 195.03 GiB size: 195.03 GiB (100.00%)
    used: 104.04 GiB (53.3%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 31.29 GiB used: 0 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12 dev: /dev/zram0
  System Temperatures: cpu: 50.9 C mobo: 29.0 C gpu: amdgpu temp: 52.0 C
    mem: 50.0 C
  Fan Speeds (rpm): cpu: 0 fan-1: 0 fan-3: 0 gpu: amdgpu fan: 0
  Power: 12v: N/A 5v: N/A 3.3v: 3.33 vbat: 2.83 gpu: amdgpu watts: 12.00
  Processes: 367 Uptime: 12m wakeups: 0 Memory: total: 32 GiB
  available: 31.29 GiB used: 5.38 GiB (17.2%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 15.0.7
  Packages: pm: nix-default pkgs: 0 pm: nix-sys pkgs: 0 pm: nix-usr pkgs: 0
  pm: pacman pkgs: 1905 libs: 502 tools: yay Shell: Zsh v: 5.9
  running-in: alacritty inxi: 3.3.29
Garuda (2.6.16-1):
  System install date:     2023-01-08
  Last full system update: 2023-08-19
  Is partially upgraded:   Yes
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       No/Undetected
  Failed units:

I changed nothing, fixed a boot issue and now it's back to normal.

I hate when bluetooth breaks on linux, because this is always the outcome. An utter waste of time just for something out of my control to fix itself at random.

Edit: This is beyond fixed. I can't rely on it in this state. I did it again, and we're back to square one. Same issue. Still br-connection-busy, br-connection-unknown and br-connection-abort-by-local

That is what you get for using Garuda vvvvv

@mandog no.

my problem is randomly working or not working data transfer in my usb hub. Something is fishy about it.


quit beating it up.
technology and violence do not mix >=-)


The normal reason is windows and not killing every thing before shutting down well thats what happens here anyway

1 Like

I think you effed-up your port and possibly ruined your hub. Either overcome your gracelessness or buy a lot more hubs.


the weird thing is, this really only happens with my bluetooth dongle. I had no issues connecting literally anything else...

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.