Bluetooth devices not found

Im trying to pair a BT mouse and xbox controller. neither can be found for pairing. other devices such as earbuds and my cell phone are found immediately.

Mouse is a Razer Basilisk

controller is a standard xbox series controller

 System:
Kernel: 6.4.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=95a08173-925d-43e3-b7eb-3c00ac163287 rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
ibt=off
Desktop: KDE Plasma v: 5.27.6 tk: Qt v: 5.15.10 wm: kwin_x11 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Alienware product: Alienware m15 R6 v: N/A
serial: <filter> Chassis: type: 10 serial: <filter>
Mobo: Alienware model: 0TWG37 v: A01 serial: <filter> UEFI: Alienware
v: 1.21.0 date: 03/07/2023
Battery:
ID-1: BAT0 charge: 38.0 Wh (63.2%) condition: 60.1/84.3 Wh (71.3%)
volts: 11.0 min: 11.4 model: BYD DELL M59JH17 type: Li-poly serial: <filter>
status: discharging
CPU:
Info: model: 11th Gen Intel Core i7-11800H socket: U3E1 bits: 64
type: MT MCP arch: Tiger Lake gen: core 11 level: v4 note: check built: 2020
process: Intel 10nm family: 6 model-id: 0x8D (141) stepping: 1
microcode: 0x44
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 640 KiB desc: d-8x48 KiB; i-8x32 KiB L2: 10 MiB desc: 8x1.2 MiB
L3: 24 MiB desc: 1x24 MiB
Speed (MHz): avg: 1446 high: 2300 min/max: 800/4600 base/boost: 2277/5000
scaling: driver: intel_pstate governor: performance volts: 0.8 V
ext-clock: 100 MHz cores: 1: 2051 2: 2300 3: 1320 4: 1247 5: 1421 6: 1189
7: 2300 8: 801 9: 2177 10: 801 11: 1488 12: 801 13: 801 14: 1338 15: 2300
16: 801 bogomips: 73728
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: Dell driver: i915
v: kernel arch: Gen-12.1 process: Intel 10nm built: 2020-21 ports:
active: eDP-1 empty: DP-1,DP-2 bus-ID: 00:02.0 chip-ID: 8086:9a60
class-ID: 0300
Device-2: NVIDIA GA104M [GeForce RTX 3070 Mobile / Max-Q] vendor: Dell
driver: nvidia v: 535.54.03 alternate: nouveau,nvidia_drm non-free: 535.xx+
status: current (as of 2023-07) arch: Ampere code: GAxxx
process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 8
link-max: lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:24dd class-ID: 0300
Device-3: Microdia Integrated_Webcam_HD driver: uvcvideo type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-5:2 chip-ID: 0c45:672c
class-ID: 0e02
Display: server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia unloaded: nouveau
alternate: fbdev,intel,nv,vesa dri: iris gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 2048x1152 s-dpi: 96 s-size: 541x304mm (21.30x11.97")
s-diag: 621mm (24.43")
Monitor-1: eDP-1 model: LG Display 0x0690 built: 2020 res: 2048x1152
hz: 60 dpi: 151 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
ratio: 16:9 modes: 2560x1440
API: OpenGL v: 4.6 Mesa 23.1.3 renderer: Mesa Intel UHD Graphics (TGL GT1)
direct-render: Yes
Audio:
Device-1: Intel Tiger Lake-H HD Audio vendor: Dell
driver: sof-audio-pci-intel-tgl
alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
chip-ID: 8086:43c8 class-ID: 0401
Device-2: NVIDIA GA104 High Definition Audio driver: snd_hda_intel
v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 8 link-max: lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:228b class-ID: 0403
API: ALSA v: k6.4.2-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.73 status: n/a (root, process) with:
1: pipewire-pulse status: active 2: wireplumber status: active
3: pipewire-alsa type: plugin 4: pw-jack type: plugin
tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Intel Tiger Lake PCH CNVi WiFi vendor: Rivet Networks
driver: iwlwifi v: kernel bus-ID: 00:14.3 chip-ID: 8086:43f0 class-ID: 0280
IF: wlp0s20f3 state: up mac: <filter>
Device-2: Realtek vendor: Dell driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 2d:00.0 chip-ID: 10ec:2600
class-ID: 0200
IF: enp45s0 state: down mac: <filter>
Bluetooth:
Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-14:5 chip-ID: 8087:0026
class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 953.87 GiB used: 106.19 GiB (11.1%)
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: PC711 NVMe 1TB
size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 41001131 temp: 56.9 C
scheme: GPT
SMART: yes health: PASSED on: 374d 19h cycles: 284
read-units: 28,064,142 [14.3 TB] written-units: 24,351,534 [12.4 TB]
Partition:
ID-1: / raw-size: 692.91 GiB size: 692.91 GiB (100.00%)
used: 106.1 GiB (15.3%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p7
maj-min: 259:7
ID-2: /boot/efi raw-size: 250 MiB size: 246 MiB (98.40%)
used: 88.1 MiB (35.8%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
maj-min: 259:1
ID-3: /home raw-size: 692.91 GiB size: 692.91 GiB (100.00%)
used: 106.1 GiB (15.3%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p7
maj-min: 259:7
ID-4: /var/log raw-size: 692.91 GiB size: 692.91 GiB (100.00%)
used: 106.1 GiB (15.3%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p7
maj-min: 259:7
ID-5: /var/tmp raw-size: 692.91 GiB size: 692.91 GiB (100.00%)
used: 106.1 GiB (15.3%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p7
maj-min: 259:7
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.37 GiB used: 143 MiB (0.9%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 41.0 C mobo: 45.0 C
Fan Speeds (RPM): cpu: 4901
Info:
Processes: 394 Uptime: 5d 9h 24m wakeups: 53834 Memory: total: 16 GiB
available: 15.37 GiB used: 4.95 GiB (32.2%) igpu: 60 MiB Init: systemd
v: 253 default: graphical tool: systemctl Compilers: gcc: 13.1.1
Packages: 1903 pm: pacman pkgs: 1896 libs: 536 tools: octopi,pamac,paru
pm: flatpak pkgs: 7 Shell: garuda-inxi (sudo) default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.28
Garuda (2.6.16-1):
System install date:     2023-06-29
Last full system update: 2023-07-12 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       Yes
Failed units:

Welcome to the Garuda forum @druaga.

Just FYI, Windows often creates problems with Bluetooth/Linux when dual booting.

There is a lot of helpful information regarding Bluetooth connectivity on the Arch wiki:

https://wiki.archlinux.org/title/Gamepad#top-page

https://wiki.archlinux.org/title/Bluetooth

https://wiki.archlinux.org/index.php/Bluetooth#Troubleshooting

https://wiki.archlinux.org/title/Bluetooth#Discoverable_on_startup

Some other links that may be informative:


Bluetooth is a minefield of issues, especially when dual booting Windows. Good luck finding a resolution to your BT problems, and again welcome to the Garuda community.


2 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.