Bluemail stuck on opening

Hello, amazing garuda community,

I have a problem with the latest version of Bluemail (downloaded from AUR).

I have installed the application as new (never used it before on linux), and it gets stuck in the first opening window, I can't click any button or go ahead to configure my email account.

Has anyone else had the same problem? Any suggestions to solve it?

Thanks!

Hi there,

Bluemail is already available in Chaotic-AUR, so it would be best to install it from there.

Secondly, I just installed bluemail, and it works flawlessly here. Can you please share output of

garuda-inxi

as well as run bluemail from terminal ( using command bluemail ofc ) and posting its output here as text.

5 Likes

Hi Naman,

thanks for reply! I have try to install in my laptop (i have garuda in my main desktop and laptop too) from Chaotic-aur, but seems the problem is the same (i use gnome version of garuda).

> System:
  Kernel: 5.18.16-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=5fd15504-2df0-4898-891a-b6e92ff17f93 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=82a0b03a-c2f4-44c6-bc05-02cc24306b1a loglevel=3
  Desktop: GNOME v: 42.3.1 tk: GTK v: 3.24.34 wm: gnome-shell dm: GDM
    v: 42.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: Dell product: Latitude E7440 v: 00
    serial: <superuser required> Chassis: type: 9 serial: <superuser required>
  Mobo: Dell model: N/A serial: <superuser required> BIOS: Dell v: A27
    date: 10/09/2018
Battery:
  ID-1: BAT0 charge: 42.2 Wh (100.0%) condition: 42.2/47.7 Wh (88.5%)
    volts: 8.6 min: 7.4 model: SMP DELL 909H538 type: Li-ion serial: <filter>
    status: charging
CPU:
  Info: model: Intel Core i5-4310U bits: 64 type: MT MCP arch: Haswell
    gen: core 4 built: 2013-15 process: Intel 22nm family: 6
    model-id: 0x45 (69) stepping: 1 microcode: 0x26
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1521 high: 2710 min/max: 800/3000 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 1256 2: 1275 3: 846
    4: 2710 bogomips: 20752
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
    vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Dell driver: i915
    v: kernel arch: Gen-7.5 process: Intel 22nm built: 2013 ports:
    active: eDP-1 empty: DP-1,HDMI-A-1,HDMI-A-2 bus-ID: 00:02.0
    chip-ID: 8086:0a16 class-ID: 0300
  Device-2: Microdia Integrated Webcam type: USB driver: uvcvideo
    bus-ID: 2-4:2 chip-ID: 0c45:64d2 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
    compositor: gnome-shell driver: X: loaded: modesetting
    alternate: fbdev,intel,vesa gpu: i915 display-ID: :1 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
    s-diag: 414mm (16.31")
  Monitor-1: eDP-1 model: ChiMei InnoLux 0x1492 built: 2012 res: 1366x768
    hz: 60 dpi: 112 gamma: 1.2 size: 309x174mm (12.17x6.85") diag: 355mm (14")
    ratio: 16:9 modes: 1366x768
  Message: Unable to show GL data. Required tool glxinfo missing.
Audio:
  Device-1: Intel Haswell-ULT HD Audio vendor: Dell driver: snd_hda_intel
    v: kernel bus-ID: 00:03.0 chip-ID: 8086:0a0c class-ID: 0403
  Device-2: Intel 8 Series HD Audio vendor: Dell driver: snd_hda_intel
    v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9c20 class-ID: 0403
  Sound Server-1: ALSA v: k5.18.16-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
  Device-1: Intel Ethernet I218-LM vendor: Dell driver: e1000e v: kernel
    port: f080 bus-ID: 00:19.0 chip-ID: 8086:155a class-ID: 0200
  IF: eno1 state: down mac: <filter>
  Device-2: Intel Wireless 7260 driver: iwlwifi v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 8086:08b1 class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
Bluetooth:
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-1.3:3 chip-ID: 8087:07dc class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 4 state: down
    bt-service: enabled,running rfk-block: hardware: no software: no
    address: <filter>
RAID:
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
    v: 3.0 port: f060 bus-ID: 00:1f.2 chip-ID: 8086:282a rev: N/A
    class-ID: 0104
Drives:
  Local Storage: total: 223.57 GiB used: 36.5 GiB (16.3%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37240G
    size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 61K1 scheme: MBR
Partition:
  ID-1: / raw-size: 214.77 GiB size: 214.77 GiB (100.00%) used: 36.5 GiB
    (17.0%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-2: /home raw-size: 214.77 GiB size: 214.77 GiB (100.00%) used: 36.5
    GiB (17.0%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-3: /var/log raw-size: 214.77 GiB size: 214.77 GiB (100.00%) used: 36.5
    GiB (17.0%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-4: /var/tmp raw-size: 214.77 GiB size: 214.77 GiB (100.00%) used: 36.5
    GiB (17.0%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 7.7 GiB used: 256 KiB (0.0%) priority: 100
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 8.8 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda2 maj-min: 8:2
Sensors:
  System Temperatures: cpu: 65.0 C mobo: 47.0 C sodimm: SODIMM C
  Fan Speeds (RPM): cpu: 4100
Info:
  Processes: 282 Uptime: 8m wakeups: 1 Memory: 7.7 GiB used: 3.65 GiB (47.4%)
  Init: systemd v: 251 default: graphical tool: systemctl Compilers:
  gcc: 12.1.1 Packages: pacman: 1375 lib: 362 Shell: fish v: 3.5.1
  default: Bash v: 5.1.16 running-in: gnome-terminal inxi: 3.3.20
Garuda (2.6.5-1):
  System install date:     2022-05-31
  Last full system update: 2022-08-05 ↻
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       <superuser required>
  Snapshots:               Snapper
  Failed units:
> 5/8/2022, 09:05:11 :: Main thread initialized 
5/8/2022, 09:05:11 :: Getting system flags 
5/8/2022, 09:05:11 :: isLinux true 
5/8/2022, 09:05:11 :: isMac false 
5/8/2022, 09:05:11 :: isWindows false 
5/8/2022, 09:05:11 :: isWindowsExeBuild false 
5/8/2022, 09:05:11 :: isWindowsStoreBuild false 
5/8/2022, 09:05:11 :: Retrieving process agrs 
5/8/2022, 09:05:11 :: #0: || /opt/bluemail/bluemail || type: string -- /opt/bluemail/bluemail 
5/8/2022, 09:05:11 :: #1: || ofc || type: string -- ofc 
5/8/2022, 09:05:11 :: Retrieving LoginItemSettings 
5/8/2022, 09:05:11 :: {"openAtLogin":false,"openAsHidden":false,"restoreState":false,"wasOpenedAtLogin":false,"wasOpenedAsHidden":false} 
5/8/2022, 09:05:17 :: [splash] dataLoadedCallback 1 
5/8/2022, 09:05:18 :: [splash] dataLoadedCallback 2 
5/8/2022, 09:05:18 :: [splash] dataLoadedCallback 3 
5/8/2022, 09:05:18 :: [splash] dataLoadedCallback 4 
5/8/2022, 09:05:18 :: [splash] dataLoadedCallback 5 
5/8/2022, 09:05:18 :: [splash] dataLoadedCallback 6 
^C5/8/2022, 09:05:30 :: APP before-quit, uptimeSeconds: 19 
5/8/2022, 09:05:31 :: APP will-quit, uptimeSeconds: 20 
5/8/2022, 09:05:31 :: APP quit, uptimeSeconds: 20, exitCode: [object Object] 

Here is the output, the problem is the same i had on my desktop.

Thanks!

Post always your terminal in- and output as text like
~~~
garuda-inxi
System:
Kernel: 5.18.15-zen1-2-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
parameters:
~~~

looks like

garuda-inxi
System:
  Kernel: 5.18.15-zen1-2-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
    parameters:

in forum.

I have edited your post.

3 Likes

Oh, sorry, I didn't know that. Thank you

I wonder if the problem is in gnome or if there is something in the network connection. I read about a similar problem on Windows, and they say there are some changes to be made to the connection permissions (something like that). Anyway, I tried leaving the application open but even after 1 hour it is still stuck on the welcome pages and the buttons are still not clickable.

It looks normal upto this point. Then maybe it has stuck, so you pressed ctrl+c

Might be, I am using Cinnamon, and it started flawlessly right out of the box. I installed from Chaotic AUR

Also, you can try contacting their support regarding this issue. Maybe, they already know it....

2 Likes

I think it's a gnome problem because I tried to install it on a virtual machine with fedora (gnome version) and had the same problem.

I sent an e-mail to the support team, I hope they get it.

1 Like

I made one last attempt with the snap version of Bluemail, and I have the exact same problems.

I think there is a problem in every version with gnome.

1 Like